Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Additional Resources


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > FireWire and USB Audio Interfaces (Mac)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-03-2018, 08:38 AM
drooster drooster is offline
Member
 
Join Date: Jan 2018
Location: Texas
Posts: 1
Default MBox Pro 3 + 2017 iMac + Thunderbolt->Firewire adapters + latest drivers = success

I upgraded my computer to a new late-2017 27" iMac and spent a ridiculous amount of time trying to get my MBox Pro 3 to work on it, and was actually successful, so thought I would share what I did since I haven't seen any other threads on this:

1. Bought a new 2017 iMac that came with High Sierra (10.13.2) installed and no firewire ports
2. Used the following adapters to connect to the MBox Pro: iMac->Thunderbolt 3 to Thunderbolt 2 adapter->Thunderbolt 2 to Firewire 800 adapter->Firewire 800 to Firewire 400 adapter->Firewire 400 cable to MBox pro (side note: I still can't believe this worked)
3. Installed latest MBox Pro 3 drivers (1.3.5)

At this point nothing worked, the MBox control panel said "Hardware not connected", etc. So here's what I did:

4. Ran System Profiler (Apple Menu->About this Mac->System Report)
5. Looked under "Thunderbolt" and verified that the Thunderbolt 2 to Firewire 800 adapter was present
6. Looked under "Firewire" and verified that the MBox Pro is present. When I first looked under "Firewire", it showed "unknown device", so I reinstalled the driver and power cycled the MBox Pro 3, and then it showed up as an MBox Pro.

At this point the device showed up in System Profiler but the MBox control panel and Pro Tools still couldn't recognize it, until:

7. Opened Control Panel->Security and Privacy, saw the message "System software from developer 'Digidesign' was blocked from loading", and clicked on the "Allow" button.

After all of this, everything worked. Apparently there is a new "feature" in Mac OS 10.13.2 that requires a user's approval before installing 3rd party drivers, and for whatever reason the MBox Pro driver installer did not prompt me for for approval. Hope this helps someone.
Reply With Quote
  #2  
Old 01-03-2018, 01:46 PM
Balanced Jack Balanced Jack is offline
Member
 
Join Date: Jun 2004
Posts: 59
Default Re: MBox Pro 3 + 2017 iMac + Thunderbolt->Firewire adapters + latest drivers = succes




Sent from my iPad using Tapatalk
Reply With Quote
  #3  
Old 01-03-2018, 03:38 PM
albee1952 albee1952 is online now
Member
 
Join Date: May 2004
Location: nashville
Posts: 34,127
Default Re: MBox Pro 3 + 2017 iMac + Thunderbolt->Firewire adapters + latest drivers = succes

We need a troubleshooting award for your diligence
__________________
HP z820 12 core, 64GB RAM, HD/Native, HD IOx2, PT11HD, UAD Quad, preamps from Vintech, Five Fish Audio, Miktek, Focusrite, Chameleon Labs, Warm Audio and Midas..............................
https://www.facebook.com/search/top/...0sound%20works


The better I drink...the more I mix.....

BTW, my name is Dave, but most people call me.........................Dave
Reply With Quote
  #4  
Old 08-12-2018, 02:54 PM
Intini Intini is offline
Member
 
Join Date: May 2006
Location: UK and Brazil
Posts: 219
Default Re: MBox Pro 3 + 2017 iMac + Thunderbolt->Firewire adapters + latest drivers = succes

This is great! I just bought an iMac 5k 2017 and will have to do the same! Thank you so much!
Do you know of any Thunderbolt 3 dock that has a firewire port so we could connect the MBP3 straight on it?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apple ethernet adapters Thunderbolt vs USB tams Artist Series 1 05-04-2015 05:25 AM
Digi 003 via Thunderbolt on latest iMac SP4C3M4N FireWire and USB Audio Interfaces (Mac) 2 08-12-2013 03:24 AM
Mbox 2 Pro, iMac Thunderbolt and PT10 compatibility Maars Pro Tools Software (Mac) 15 05-06-2013 03:52 PM
firewire connection (adapters?) for MBox pro 3rd generation bscism Tips & Tricks 2 02-17-2012 02:07 AM
MBox 2 Pro with the latest iMac cougarman 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 2 09-03-2007 06:55 PM


All times are GMT -7. The time now is 09:41 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com