Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win)

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 01-05-2011, 08:49 AM
ajcsound ajcsound is offline
Member
 
Join Date: Dec 2010
Location: Luton
Posts: 5
Default Adding my ProTools LE to my Avid.com account

I have owned PT LE8 for one year and it has been nothing but trouble.

I think it is a corrupt installer DVD supplied with my MBox2 and I would like to download a new installer from Avid.com.

I registered my PT when I bought it back in '09 with digidesign and have the registration email and paperwork.

I have just registered with Avid.com but I can't add my PT version to my account so I can't access the appropriate installer downloads. Each time I put in my PT registration numbers it say it is already registered - which it is.....to me!

As Avid support have made themselves untouchable without buying an Avid Support Code, can anyone help me to add my PT to my avid account, as my PT is currently terrible.

Or if anyone at Avid can help I would be very greatful.
Thanks.
Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why PT 10.3.3 is not in my Avid Account flautista Pro Tools 10 12 01-08-2013 02:08 PM
I can't log in to My Account on Avid website Dot General Discussion 1 08-14-2012 04:28 PM
Ilok transfers / adding iloks to an account Raoul23 General Discussion 2 04-02-2012 08:28 PM
PT9 and my Avid account Carl Kolchak Pro Tools 9 8 03-13-2011 11:23 PM
AVID say: Account does not exist alex_rb General Discussion 2 04-25-2010 03:37 PM


All times are GMT -7. The time now is 04:50 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com