Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > Pro Tools | Duet & Pro Tools | Quartet

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 12-11-2019, 09:33 AM
Lightzy Lightzy is offline
Member
 
Join Date: Aug 2015
Location: Israel
Posts: 5
Default Duet driver (win) worse than no driver

With the Avid IO control and driver, there is insane latency and audio stutters causing the whole system to stutter when used as a regular workstation. On occasion there is even a whole system crash with the cause being something like "AvidDuet.sys"
Removing AVID drivers and IO control actually solves all these issues and gets rid of all latency. The Duet interface can now be used for any regular computer work without chaos. HOWEVER, now Duet cannot be used for actual DAW applications such as protools as protools refuses to recognize it while all other system applications do.

Please fix your windows drivers and remove the latency they cause, because your drivers are demonstrably the cause for whole-system-latency and computer crashes.
Also fix your customer support. I do not see an answer such as "please switch to apple" or "roll back to old versions of windows" as valid solutions, you ****lords, and maybe I'll consider buying and/or recommending Avid products in the future...

Last edited by Lightzy; 12-11-2019 at 10:24 AM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ASIO4ALL driver or audio interface driver for playback engine? slidincharlie Getting Started 2 02-26-2017 01:31 PM
Tried installing driver while mbox was on. Now cannot install new driver breathwater FireWire and USB Audio Interfaces (Win) 1 08-20-2014 09:07 PM
Bug in Digi Core Audio Driver? Driver update coming? mgbasinski 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 0 04-10-2003 09:59 PM
UNSUPPORTED DRIVER CALL, CHECK DRIVER VERSION finalcut 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 10 01-06-2003 11:51 PM


All times are GMT -7. The time now is 01:04 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com