Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > Pro Tools TDM Systems (Mac)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-02-2006, 01:37 PM
Jeffrey Talbot Jeffrey Talbot is offline
Member
 
Join Date: Dec 1999
Location: New Orleans, LA USA
Posts: 637
Default Line 981 Assertion

Ok.. so I've got a PT session open, and am dragging .mp3 files from the desktop to the reigon bin. Files convert and show up just fine... I can put them on the timeline, edit... but can't save session.

"Could not save as "session name" because Assertion in "PtSess_XChg.cpp", line 981"

Tried opening an old session, doing a few edits, saving the changes.. no problems... then dragging in the same .mp3 files from the desktop.. and the same error message as above.

"Timeline" shows up green, "Sesson" shows up as red.

Searched in PT Ref Guide for "Assertion" and for "981" no returns..

Now, the funny thing is, that if I IMPORT, thru the file menu the same .mp3 file, all is well, so it doesn't seem to be anything associated with the particular .mp3 file.

PT 7.1cs9, OS 10.4.7 Quad G5, 4.5 Gig Ram

Any ideas?
Reply With Quote
  #2  
Old 08-02-2006, 02:11 PM
crizdee's Avatar
crizdee crizdee is offline
Moderator
 
Join Date: Dec 2004
Location: Brighton, UK
Posts: 10,549
Default Re: Line 981 Assertion

Hi,

When dragging from the desktop the file is probably being link to the desktop when trying to save and this conflicts with the PT save protocol blah blah. when you import the audio file it is being converted and sent to the audio folder! thats my theory

Try placing the mp3's on the audio folder before dragging them into the session!

Chris
__________________
PT MAC Troubleshooting... http://duc.avid.com/showthread.php?t=54888

Producer, Engineer,
UKmastering Mixing & Mastering
Blinders_Columbia top 40 UK album charts
Slow Readers Club Joy Of The Return #9 UK album charts

www.ukmastering.com


PT10.3.10 Mountain Lion HD6 accel Magma PE6R4 D Command 32 MacPro 12 Core 3.46ghz UAD-2 Octo x2. Manley Vari-Mu, Manley Massive Passive, SSL VHD, ADL600, Grove Tubes ViPre, Tube-Tech CL-1B. Hafler TRM active monitoring.
Reply With Quote
  #3  
Old 08-02-2006, 02:56 PM
Jeffrey Talbot Jeffrey Talbot is offline
Member
 
Join Date: Dec 1999
Location: New Orleans, LA USA
Posts: 637
Default Re: Line 981 Assertion

Actually, since PT can't use .mp3 files it has to convert them, which it is doing when I drag them into the reigon bin. The converted .aiff files appear in the Audio Files associated with the session, but still can't save the session.

And of course, I'd also add that it used to work.... but now it doesn't.
Reply With Quote
  #4  
Old 08-02-2006, 04:06 PM
DigiTechSupt's Avatar
DigiTechSupt DigiTechSupt is offline
Avid
 
Join Date: Jan 2000
Location: Worldwide
Posts: 33,700
Default Re: Line 981 Assertion

We came across a problem with cs9 when dragging and dropping MP3's - the session can not be saved after importing any MP3/MP4 files by dragging from the Workspace browser, desktop, or finder. Until we provide the fix in an upcoming CS release, the workaround is to avoid using drag and drop importing of MP3/MP4 files, and instead use "Import Audio to Track" or "Import Audio to Regions List".
__________________
Avid Audio Tech Support
Help us help you - read this before posting
Support FAQ
Reply With Quote
  #5  
Old 08-02-2006, 08:55 PM
Jeffrey Talbot Jeffrey Talbot is offline
Member
 
Join Date: Dec 1999
Location: New Orleans, LA USA
Posts: 637
Default Re: Line 981 Assertion

No problem..

Glad to know it's not just me.
Reply With Quote
  #6  
Old 08-22-2006, 04:34 AM
Arno Peeters's Avatar
Arno Peeters Arno Peeters is offline
Member
 
Join Date: Dec 1998
Location: Utrecht, The Netherlands
Posts: 1,105
Default Re: Line 981 Assertion!!!!

Well: dunno, but I never ever seen this problem, but since this morning it happens to me too ... and I have been using LE cs9 ever since it came out without a problem.... Deleted all prefs, checked all settings and priv's, rebuild all databases and now it happens in a session that has worked so far without a glitch!!!

This is pretty alarming, since I'm in the middle of a production here and I did not even import an MP3 from the desktop, an 'unpriviliged drive' or whatsoever. Would re-installing make a difference or downgrading to cs8?

Please Digi, what can I do?!
__________________
Arno Peeters
Tape TV Productions
Reply With Quote
  #7  
Old 08-22-2006, 05:05 AM
drums77's Avatar
drums77 drums77 is offline
Member
 
Join Date: Nov 2004
Location: Treviso, Italy
Posts: 99
Default Re: Line 981 Assertion!!!!

this problem is already on the 7.2!!
__________________
Mac Pro (Mid 2010) Six Core 3.33GHz macOS 10.13.6
Pro Tools | HDX, HD I/O 16x16, HD I/O 8x8x8
Pro Tools Ultimate 2020.3

MacBook Pro (Mid 2012) i7 2.3GHz macOS 10.15.4
Pro Tools Ultimate 2020.3
Apogee Duet
Reply With Quote
  #8  
Old 08-22-2006, 08:30 AM
Arno Peeters's Avatar
Arno Peeters Arno Peeters is offline
Member
 
Join Date: Dec 1998
Location: Utrecht, The Netherlands
Posts: 1,105
Default Re: Line 981 Assertion!!!!

I've discovered that in the disk allocation-settings, my USB-external SFX-drive had changed to R-R, although I'm convinced I always had it on Transfer only! When I tried to change it, PT asks me if I'm sure, since files from that drive are contained within my session, which is definitely NOT the case!

I changed it back anyways and after that I could go on dragging files from the workspace-browser straight onto the tracks...
Haven't fiddled around with MP3's on the desktop yet (let somebody else waste his time on that...).
Can I somehow have changed this setting by accident... a keystroke perhaps?!
__________________
Arno Peeters
Tape TV Productions
Reply With Quote
  #9  
Old 08-22-2006, 08:54 AM
MorganPost MorganPost is offline
Member
 
Join Date: Nov 2004
Location: Toronto, Canada
Posts: 243
Default Re: Line 981 Assertion!!!!

7.1cs9 SUCKS!!!

I updated to 7.1cs9 BEFORE Digi posted their warning but by the time I figured out what was wrong my system directories were so corrupted that I had to reformat and load all my programs back in...

And this also occured when AIFF files were imported through the workspace/progect browsers...NOT JUST MP3/MP4 files as I didn't use either of those formats in any sessions.
Reply With Quote
  #10  
Old 08-22-2006, 11:24 AM
drums77's Avatar
drums77 drums77 is offline
Member
 
Join Date: Nov 2004
Location: Treviso, Italy
Posts: 99
Default Re: Line 981 Assertion!!!!

Quote:


And this also occured when AIFF files were imported through the workspace/progect browsers...NOT JUST MP3/MP4 files as I didn't use either of those formats in any sessions.
same problem!!!!
__________________
Mac Pro (Mid 2010) Six Core 3.33GHz macOS 10.13.6
Pro Tools | HDX, HD I/O 16x16, HD I/O 8x8x8
Pro Tools Ultimate 2020.3

MacBook Pro (Mid 2012) i7 2.3GHz macOS 10.15.4
Pro Tools Ultimate 2020.3
Apogee Duet
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Assertion in line 304 lobenmai Windows 0 12-24-2013 08:55 PM
Assertion line 330 steveskinner macOS 9 12-22-2012 10:34 PM
Assertion in ... line 199 Simmer 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 5 02-23-2012 02:53 PM
Assertion line 74 mikeeovitch macOS 0 10-08-2011 05:53 PM
Assertion line 481 jrtme Pro Tools TDM Systems (Mac) 2 04-18-2010 10:19 AM


All times are GMT -7. The time now is 10:24 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com