Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Post Production > Post - Surround - Video

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 04-01-2020, 12:41 PM
sw rec sw rec is offline
Member
 
Join Date: Oct 2005
Location: Colo Spgs Colo
Posts: 5,659
Default Video playback Windows 10

I have to be missing something elemental, I keep telling myself. Ever since PT 2019, (Win 10, build 1909) I have been unable to successfully import video of ANY format into Pro Tools, and where 2020.3 is otherwise working great, I still get the spinning icon of death and have to force-quit when I try to import video.

Avid says:
Supported video formats
DNxHR (MOV)
DNxHD (MOV)
Apple ProRes (MOV)
H.264 (CFR Media Only) (MOV, MP4, M4V)

Should I be able to play these videos OUTSIDE of Pro Tools, and if Windows won’t play them, that’s the underlying problem? Am I missing a Windows app somewhere? I’ve tried importing every one of these, with the “improved” video engine which comes with 2020.3 (you have to manually install it...doesn’t get installed with the main installer.)
I’m glad at this point that I left PT 10.3 in place, because I can still import .mov files without issue, and go to work. It even worked with 12.4, but video playback was very jerky.
Thanks in advance for any light you can shed on this.
Reply With Quote
  #2  
Old 04-03-2020, 11:23 AM
sw rec sw rec is offline
Member
 
Join Date: Oct 2005
Location: Colo Spgs Colo
Posts: 5,659
Default Re: Video playback Windows 10

Update. To the point. This new video engine DOES NOT WORK in Windows. Something as simple as trying to resize the (blank) video window crashes the video engine, and sends it into an endless loop trying to reinitialize. Wondering how well Studio One handles video import. But this is my last $399 I shell out for their “support/update plan.”
Reply With Quote
  #3  
Old 04-03-2020, 03:54 PM
AndrewAction's Avatar
AndrewAction AndrewAction is offline
Moderator
 
Join Date: Nov 2004
Location: Auckland
Posts: 451
Default Re: Video playback Windows 10

Quote:
Originally Posted by sw rec View Post
Am I missing a Windows app somewhere?
Try VLC- Media Player

Andrew
Reply With Quote
  #4  
Old 04-03-2020, 04:13 PM
sw rec sw rec is offline
Member
 
Join Date: Oct 2005
Location: Colo Spgs Colo
Posts: 5,659
Default Re: Video playback Windows 10

Does that need to be installed for video to play within Pro Tools? Interesting....I’ll try it.
Reply With Quote
  #5  
Old 04-07-2020, 08:08 AM
Brandonx1 Brandonx1 is offline
Member
 
Join Date: Oct 2003
Location: Los Angeles
Posts: 2,890
Default Re: Video playback Windows 10

Quote:
Originally Posted by sw rec View Post
Does that need to be installed for video to play within Pro Tools? Interesting....I’ll try it.
if you go to the video engine folder in the pro tools app, whats in that folder?
__________________
Brandon Howlett
Vibe Audio Post, Inc.
Re-recording Mixer
Custom Build CPU, HDX 1, Omni, 192 I/O Digital
S6 M10 24 fader
Satellite Mac Pro, HDNative, 192 I/0
Black Magic HD Extreme
Reply With Quote
  #6  
Old 04-19-2020, 12:09 PM
sw rec sw rec is offline
Member
 
Join Date: Oct 2005
Location: Colo Spgs Colo
Posts: 5,659
Default Re: Video playback Windows 10

From the “call me crazy, but at least it works” department. There’s a VST video player plugin (vidplayvst.com) that’s $25. And since I already have Blue Cat Patchwork, I says to myself “self, this is worth a try.” And it WORKS! I haven’t tried a lot of video formats with it yet, but I was able to open up an instrument track in pt 2020.3, insert Patchwork, put the video player on the first “pre” slot, and import a mxf-mpeg video file. (I have a converter that’ll output any file format I need.) One extra step: import audio, select the video you just imported, tell it “new track,” and it aligns the reference audio track to the reference audio on the video. I have a screen-shot, but unfortunately it won’t let me post it here. But I have video in PT 2020.3.
If this is something that has caused you frustration, this is certainly worth a try. Only downside so far...close the Patchwork window, it closes the video window too, and that’s one extra thing on the monitors, but that’s a minor inconvenience from where I sit.

Last edited by sw rec; 04-19-2020 at 12:47 PM.
Reply With Quote
  #7  
Old 04-19-2020, 06:52 PM
sw rec sw rec is offline
Member
 
Join Date: Oct 2005
Location: Colo Spgs Colo
Posts: 5,659
Default Re: Video playback Windows 10

Update. DNxHD works great, H264 works great, .mov files are good, mxf files give video but no audio reference track. One negative I’ll have to live with is that the video window doesn’t scrub with the audio. Spotting frame-specific effects will be a little trickier, but is doable.
Reply With Quote
  #8  
Old 05-06-2020, 02:39 PM
tom_lowe tom_lowe is offline
Member
 
Join Date: Sep 2006
Location: London, UK
Posts: 1,052
Default Re: Video playback Windows 10

Quote:
Originally Posted by sw rec View Post
Does that need to be installed for video to play within Pro Tools? Interesting....I’ll try it.
VLC has absolutely nothing to do with the AVE!
Reply With Quote
  #9  
Old 05-06-2020, 03:09 PM
Brandonx1 Brandonx1 is offline
Member
 
Join Date: Oct 2003
Location: Los Angeles
Posts: 2,890
Default Re: Video playback Windows 10

Quote:
Originally Posted by sw rec View Post
Update. DNxHD works great, H264 works great, .mov files are good, mxf files give video but no audio reference track. One negative I’ll have to live with is that the video window doesn’t scrub with the audio. Spotting frame-specific effects will be a little trickier, but is doable.
I think you have an install issue with pro tools. Again what is in your video engine folder in the pro tools. Does your video engine folder look like this?
Attached Images
File Type: jpg video engine folder.jpg (55.9 KB, 0 views)
__________________
Brandon Howlett
Vibe Audio Post, Inc.
Re-recording Mixer
Custom Build CPU, HDX 1, Omni, 192 I/O Digital
S6 M10 24 fader
Satellite Mac Pro, HDNative, 192 I/0
Black Magic HD Extreme
Reply With Quote
  #10  
Old 05-07-2020, 02:31 AM
unkJE's Avatar
unkJE unkJE is offline
Member
 
Join Date: Dec 2011
Location: Adelaide, Australia
Posts: 1,957
Default Re: Video playback Windows 10

I installed Apple QuickTime 7.79.80.95 – selecting “Custom Install” and only installed QuickTime Essentials, as described here:
https://www.pro-tools-pc.com/apple-q...security-risk/

Restarted the computer.

(I didn’t install QuickTime Player, as recommended in above instructions. I use VLC to play videos).

I installed the Avid Video Engine from:
Win10(C)>Program Files>Avid>Pro Tools>Pro Tools Utilities>Avid Video Engine

As a recent total-newbie to video, I had to hold down “N” while launching Pro Tools to open the Playback Engine and tick the “Enable Video” box.

My imported video showed its fps in red in Pro Tools Edit window, so I converted the video with free software called HandBrake:
https://handbrake.fr/

In the Presets drop-down menu I chose “Production Max (Modified)” which allows a Frame width of 1080 and a Frame height of 1920.

In HandBrake’s Video Tab, with Video Codec H.264 (264), I changed my Framerate (FPS) to 29.97 from the drop-down menu.
Immediately under this, I checked “Constant Framerate”.

In HandBrake’s Audio Tab, I tried both 128 and 320 Bitrates (I chose the latter).

To Save As, I named my File and followed this name with:
.mp4
For example:
Kookaburra.mp4

So far, so good – must have been a fluke!
__________________
Pro Tools 2020.5 and 12.5.1 HD - Studio One 4 Pro - Win10 64 Pro – Lenovo W520 ThinkPads & 433830U Docks – Mbox 3 Pro - Axiom Pro 49 - AIR Mini 32
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Playback, the video is dragging and mac's fan is agressive with video vmc.mariana Pro Tools 2019 4 08-23-2019 02:39 AM
Why use black magic devices to playback video instead of just playback in pro tools? Rockman413 Pro Tools 2018 3 12-25-2018 04:20 PM
No Video Playback (Black Video window and thumbs) winkelement Pro Tools 12 13 03-17-2016 11:03 AM
Playback from 002 with windows, video games etc MaKoRancid 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 5 10-27-2009 07:40 PM
PT LE 8 (Windows) No Video Playback with Quicktime 7.6 warrickmarais 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 1 04-01-2009 12:03 AM


All times are GMT -7. The time now is 03:53 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com