Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Mixing > Artist Series

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-10-2015, 09:20 PM
O-WYO O-WYO is offline
Member
 
Join Date: Jan 2015
Location: USA
Posts: 48
Default Updated firmware for MC Mix & EUCON networking fix - When?

Come on, Avid. It's been way too long since the last MC Mix firmware "upgrade" disabled the "Shift + fader sets level to 0dB" feature. And we've all been crippling along, ever since. That is (was) one of my favorite and often used features of the MC Mix.

When can we expect an updated firmware for the MC Mix?

While you're at it, how about updating EUCON to work properly in modern (ie beyond basic) networks - like v3.1.3 does?

Having spent thousands on my MC Control and MC Mixes, it's distressing to see firmware and driver "updates" actually regress the functionality of the Artist Series. I'm on the verge of upgrading my entire DAW and AD/DA I/O setup. For sure, this ongoing Artist Series debacle is killing any warm and fuzzy inclination to go with to Avid Protools & hardware!

*** Addendum, 1/13/2015: Per post #13 on this thread, the disabled "Shift+Touch Fader=0dB" bug is apparently not a problem with MC Mix firmware. As stated by several forum posters in various threads, it appears to be a problem with EUCON/EuControl.

I just downgraded EUCON/EuControl to v3.0.1, while leaving the MC Mix firmware at v1.5.2. Lo and behold, the "S+TF=0dB" feature has been restored. In addition, EUCON appears to be communicating properly with my network and my MC controllers. Time will tell how well v3.0.1 works with OS X 10.9.5 and Cubase 7.5.30; but, so far, so good.

Last edited by O-WYO; 01-13-2015 at 03:04 PM.
Reply With Quote
  #2  
Old 01-10-2015, 10:33 PM
Barlow Barlow is offline
Member
 
Join Date: Apr 2000
Location: Los Angeles, CA
Posts: 17
Default Re: Updated firmware for MC Mix & EUCON networking fix - When?

Option + Touch Fader = 0db. On a Mac anyway. Or Option + Click on Fader.
Reply With Quote
  #3  
Old 01-11-2015, 04:32 PM
O-WYO O-WYO is offline
Member
 
Join Date: Jan 2015
Location: USA
Posts: 48
Default Re: Updated firmware for MC Mix & EUCON networking fix - When?

Quote:
Originally Posted by Barlow View Post
Option + Touch Fader = 0db. On a Mac anyway. Or Option + Click on Fader.
Yeah, that's what I've been relegated to using ever since the firmware "update". While that resets the fader in the DAW, it does not reset the fader on the Mix. I didn't buy a bunch of MC Mix's, to then have to use the mouse to control my faders!
Reply With Quote
  #4  
Old 01-11-2015, 04:41 PM
O-WYO O-WYO is offline
Member
 
Join Date: Jan 2015
Location: USA
Posts: 48
Default Re: Updated firmware for MC Mix & EUCON networking fix - When?

Quote:
Originally Posted by kdarbyshirebryant View Post
The breakage of 'shift+touch fader = 0dB' feature on the Artist Mix (but not control) was as a result of fixing this http://protools.ideascale.com/a/dtd/...ks/113320-3779

From what I remember it's a EUCON problem rather than induced by firmware.
I don't believe it's a EUCON problem. My Mix units worked just fine, right up to the point I updated the firmware.

The EUCON problem I'm encountering is the inability of v3.2.x to evidently work with link aggregation and/or VLAN's. Inexplicably, v3.1.3 works just fine. It's a matter of properly interfacing EUCON with the host computer TCP/IP stack.
Reply With Quote
  #5  
Old 01-11-2015, 08:14 PM
Bill Denton Bill Denton is offline
Member
 
Join Date: Oct 2008
Location: Pittsburgh PA
Posts: 2,644
Default Re: Updated firmware for MC Mix & EUCON networking fix - When?

In order to get consistently good performance, you really should have your Eucon units on a separate physical network.

It appears that problems often result from having a mix of Eucon and non-Eucon traffic on the same physical network.

To facilitate having Eucon units on a separate network, Avid has a built-in DHCP server on their S6 system, and the manual strongly recommends the use of a separate network.

Using a separate network is a cheap "fix", it will in no way degrade performance, and it completely eliminates one possible source of problems.
__________________
X
Note that all opinions, observations, whatever, in this post are mine, unless I'm being mean or am wrong, in which case it's somebody else's fault. I do not work for Avid (their loss)...my only relationship with Avid is that of a customer (when I'm not too poor to buy stuff, like now)...and that hot administrative assistant...that's more of a "thing" than a "relationship" (that should keep them guessing for a while...)

Just rockin'...what more is there?

Bill in Pittsburgh
Reply With Quote
  #6  
Old 01-12-2015, 01:00 AM
robertg robertg is offline
Member
 
Join Date: Dec 2010
Location: earth
Posts: 555
Default Re: Updated firmware for MC Mix & EUCON networking fix - When?

Quote:
Originally Posted by Bill Denton View Post
In order to get consistently good performance, you really should have your Eucon units on a separate physical network.
This is not necessary.
Reply With Quote
  #7  
Old 01-12-2015, 05:00 AM
Bill Denton Bill Denton is offline
Member
 
Join Date: Oct 2008
Location: Pittsburgh PA
Posts: 2,644
Default Re: Updated firmware for MC Mix & EUCON networking fix - When?

Quote:
Originally Posted by kdarbyshirebryant View Post
I just tested this by loading v1.5.1 firmware on my mix unit - the 'shift - touch fader = 0dB' functionality is still broken in the sense that Pro Tools sees the control value change (ie the virtual fader moves) but unfortunately the real fader doesn't. The problem was introduced by a EUCon application update and not the firmware update.

Actually the behaviour is stranger than that. On the MC Control 'shift touch =0dB' works correctly all the time. On the Mix, the first time I load a session & touch a fader it works, if I undo the fader move and try 'shift touch' the PT fader moves but the real one doesn't. If I have the same channel mapped to an MC Control fader then the MC version of the fader moves correctly whilst the Mix fader doesn't.
Almost sounds like a hardware issue...

Do you have two mixes so you could see if the behavior is isolated to only one unit or if it might be consistent across multiple mixs?

A firmware issue might also be in play.

Good job on picking up on that...
__________________
X
Note that all opinions, observations, whatever, in this post are mine, unless I'm being mean or am wrong, in which case it's somebody else's fault. I do not work for Avid (their loss)...my only relationship with Avid is that of a customer (when I'm not too poor to buy stuff, like now)...and that hot administrative assistant...that's more of a "thing" than a "relationship" (that should keep them guessing for a while...)

Just rockin'...what more is there?

Bill in Pittsburgh
Reply With Quote
  #8  
Old 01-13-2015, 12:04 PM
O-WYO O-WYO is offline
Member
 
Join Date: Jan 2015
Location: USA
Posts: 48
Default Re: Updated firmware for MC Mix & EUCON networking fix - When?

Quote:
Originally Posted by Bill Denton View Post
In order to get consistently good performance, you really should have your Eucon units on a separate physical network.
It certainly makes sense to run EUCON on its own network; although, I don't see why it wouldn't function on a common network (assuming sufficient bandwidth and decent networking equipment).

My network is run on a 24-port, layer 2 switch. The switch runs several VLAN's, including the primary default VLAN and a dedicated EUCON VLAN. The default and EUCON VLAN's are on a different subnets.

The MC units connect to ports that are tagged to the EUCON VLAN. The MC units have static IP's on the EUCON subnet.

My MacPro's two NIC's are link aggregated and connect to switch ports that are untagged. The LAGG interface is configured to run on the switch's default VLAN. An additional virtual interface is configured for the EUCON VLAN. Outbound traffic through the EUCON VLAN is therefore tagged for the EUCON VLAN, before it reaches the switch. Thus, EUCON is essentially run on its own network.

While not exactly a common home network setup, the above is pretty basic for business environments - especially in commercial audio/visual production facilities.

The problem is v3.2.x lost its ability to recognize and connect with the network interfaces that are configured on my Mac. There is no connection problem with v3.1.3; although, EUCON does not properly identify the LAGG interface by name nor does it list the EUCON VLAN.

The bottom line is programming EUCON to properly function within the parameters of established TCP/IP protocols should not be a problem.
Reply With Quote
  #9  
Old 01-13-2015, 12:32 PM
O-WYO O-WYO is offline
Member
 
Join Date: Jan 2015
Location: USA
Posts: 48
Default Re: Updated firmware for MC Mix & EUCON networking fix - When?

Quote:
Originally Posted by kdarbyshirebryant View Post
I just tested this by loading v1.5.1 firmware on my mix unit - the 'shift - touch fader = 0dB' functionality is still broken in the sense that Pro Tools sees the control value change (ie the virtual fader moves) but unfortunately the real fader doesn't. The problem was introduced by a EUCon application update and not the firmware update.

Actually the behaviour is stranger than that. On the MC Control 'shift touch =0dB' works correctly all the time. On the Mix, the first time I load a session & touch a fader it works, if I undo the fader move and try 'shift touch' the PT fader moves but the real one doesn't. If I have the same channel mapped to an MC Control fader then the MC version of the fader moves correctly whilst the Mix fader doesn't.
Interesting! How did you downgrade the firmware to v1.5.1? EuControl only gives me the option to update the firmware.

I can't find a firmware revision list on the Avid website; however, it could be that v1.5.1 also disables the "shift+touch fader=0dB" feature. If that's the case, downgrading to v1.5.1 wouldn't solve the problem.

As far as it being a firmware, EUCON, and/or EuControl problem, it could well be a combination of two or all three. All I know is the feature worked fine until I updated the firmware.

BTW, I tried to duplicate your experience, loading a new session, then using "shift+touch fader=0dB". It didn't work for me. I'm on Cubase 7.5.30, though.
Reply With Quote
  #10  
Old 01-13-2015, 01:08 PM
O-WYO O-WYO is offline
Member
 
Join Date: Jan 2015
Location: USA
Posts: 48
Default Re: Updated firmware for MC Mix & EUCON networking fix - When?

Quote:
Originally Posted by kdarbyshirebryant View Post
To add to my previous reply - the 'shift + touch fader =0dB' feature not working on Artist Mix has been around quite some time and was introduced in EUCon 3.1 and is a side effect of fixing this http://www.protools.ideascale.com/a/...ks/113320-3779 which was documented in this http://duc.avid.com/showthread.php?t=346347

Discussion of the 'shift + touch =0dB' breaking is found here http://duc.avid.com/showthread.php?t=348646 itself now a year old. The breakage doesn't affect MC Control units because..... they don't have a flip mode. I could have sworn that there was an ideascale entry for the 'shift + touch = 0dB' thing not working but I can't find it. Oh well.

Meanwhile, ever since the release of PT 11 (!) there are persistent little irritants related to incorrect modifier key usage in the default soft key maps on Windows which still aren't fixed despite it being a very easy thing to do. See http://protools.ideascale.com/a/dtd/...gs/121345-3779 for example. And if you want the fix take a look at the attachment on that entry.

To not include these fixes which a customer has provided is shoddy, simple as. It's another thing that puts me off saying to others 'come on in, the water's lovely'.
Brilliant, my good man! Thanks for providing the link http://duc.avid.com/showthread.php?t=348646! I read that thread, quite some time ago, but had forgotten it's contents. (In hindsight, I should've subscribed for future reference.)

The crunchy nut in that thread is post #10; which was, in fact, posted by you! Following your lead, I installed EUCON v3.0.1, left the MC Mix firmware at v1.5.2, and, lo and behold, not only does EUCON properly connect to my network, the "Shift+Touch Fader=0dB" feature is back on my MC Mix controllers!

So, I stand corrected. The "S+TF=0dB" problem is apparently not a firmware problem, but a problem with EUCON/EuControl.

Last edited by O-WYO; 01-13-2015 at 02:51 PM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Has Eucon Protocol been updated? clusterer Avid S6 1 10-24-2013 04:42 PM
Updated Eucontrol to 2.7 and upgraded to Mountain Lion 10.8.2. Eucon now broken. Focuret macOS 0 03-08-2013 09:21 PM
this is what happened when I updated my firmware schumach 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 2 12-20-2007 12:01 PM
6.0.2. - Firmware needs to be updated? Axehell 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 8 06-18-2003 08:50 PM


All times are GMT -7. The time now is 08:19 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com