Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Additional Resources


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > FireWire and USB Audio Interfaces (Win)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-29-2017, 07:04 PM
watari banzai watari banzai is offline
Member
 
Join Date: Nov 2017
Location: Philippines
Posts: 5
Default Fast Track Ultra dropping connection

Good day! My Fast Track Ultra is exhibiting the commonly reported behavior of dropping the connection periodically and not powering up via USB (need to plug in the adapter to get it to work).

I have already Googled for a solution to the problem and found that it has something to do with units that have 'F' as the sixth character in the serial string, which my unit unfortunately does have. I did find this:

---------------
IRQ Troubleshooting (Windows)

If the 6th digital is the letter "F", there is a chance your device may be affected by this malfunction. Since the symptoms of this issue are identical to common system configuration issues; below are some troubleshooting steps you can try to eliminate any irregularities you may be experiencing. If you continue to experience this loss of connection or require assistance in determining the cause, please contact M-Audio Tech Support.
---------------

but as most users with the same problem are aware of, the links to the troubleshooting steps is now dead. I bought this unit second hand and I will probably not be willing/able to send it to an authorized repair center, even if there is one in my region (Southeast Asia), which I doubt.

Does anyone have any suggestions as to how I can proceed from here or even a copy paste of the trouble shooting steps? Possibly some suggestions on addressing power supply issues that I can pass on to a local tech?

I am using the device on an HP Elitebook laptop, win7x64.

Thanks for any help.
Reply With Quote
  #2  
Old 11-30-2017, 05:09 AM
JoelG's Avatar
JoelG JoelG is offline
Moderator
 
Join Date: Mar 2010
Location: Canada
Posts: 1,850
Default Re: Fast Track Ultra dropping connection

Honestly, by the time you ship the FTU to a repair centre, and they fix it you're probably going to be way over the cost of buying a newer, better and well supported (drivers) interface.

http://avid.force.com/pkb/articles/f...roduct-Repairs

Joel
__________________
Jame Space:
HP Elite 6300 / Core i5 3570 / 12GB RAM / Win 10 Pro
Pro Tools 12 HD / Focusrite 18i20 + M-Audio ProFire 2626

Home:
Intel S5000PSL / 2 x Xeon E5450 / 32GB RAM / Win 10 Pro
Pro Tools 12 HD / M-Audio Project Mix IO

Rig:
Eleven Rack / ART SLA1 / Fender Mustang V 412 / FCB1010 w/ EurekaPROM
Reply With Quote
  #3  
Old 11-30-2017, 03:30 PM
watari banzai watari banzai is offline
Member
 
Join Date: Nov 2017
Location: Philippines
Posts: 5
Default Re: Fast Track Ultra dropping connection

Yes, I realize that, which is why I'm hoping anyone who's ever had to deal with the problem has some suggestions I could pass on to my local tech. It does work for the most part (apart from three blown preamps--but that's another story), so it would be a shame to give it up without trying to address this 'dropped connection' issue.
Reply With Quote
  #4  
Old 11-30-2017, 04:01 PM
albee1952 albee1952 is offline
Member
 
Join Date: May 2004
Location: nashville
Posts: 33,972
Default Re: Fast Track Ultra dropping connection

Could the dropped connection be caused by USB port power management? Disabling that feature is a required tweak for any windows setup
__________________
Asus x99, Intel i7 6800K, 32 gig DDR4, GeForce 750 Ti, HD/Native, HD IOx2, PT11HD, UAD Quad, preamps from Vintech, Five Fish Audio, Miktek, Focusrite, Chameleon Labs and Midas..............................
https://www.facebook.com/search/top/...0sound%20works
www.capricornsoundworks.com

The better I drink...the more I mix.....

BTW, my name is Dave, but most people call me.........................Dave
Reply With Quote
  #5  
Old 11-30-2017, 05:37 PM
watari banzai watari banzai is offline
Member
 
Join Date: Nov 2017
Location: Philippines
Posts: 5
Default Re: Fast Track Ultra dropping connection

That's the first thing I checked, thanks.

Unfortunately, it's an acknowledged fault that I was unaware of before I bought it.
Reply With Quote
  #6  
Old 12-15-2017, 08:18 AM
Cal D Cal D is offline
Member
 
Join Date: Aug 2009
Posts: 150
Default Re: Fast Track Ultra dropping connection

Hi I saw your post and I had been having the same issues. You may want to read what I wrote here, as it may help:

http://duc.avid.com/showthread.php?t=395698

Last edited by Cal D; 12-15-2017 at 08:19 AM. Reason: spellin
Reply With Quote
  #7  
Old 12-15-2017, 09:32 AM
watari banzai watari banzai is offline
Member
 
Join Date: Nov 2017
Location: Philippines
Posts: 5
Default Re: Fast Track Ultra dropping connection

Quote:
Originally Posted by Cal D View Post
Hi I saw your post and I had been having the same issues. You may want to read what I wrote here, as it may help:

http://duc.avid.com/showthread.php?t=395698
Thank you, but it doesn't really apply to my case.

Strangely, my Ultra has been behaving fairly well recently if I keep it off before I turn on the computer and only turn it on after everything has settled down. I only experienced a drop out when the mains power fluctuated and was able to get it working again after a reset. No BSoD so far either, so fingers crossed..
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fast track ultra dropping out nzrkm1 General Discussion 0 08-01-2015 03:36 PM
Midi connection with fast track ultra m-audio signessx1 Pro Tools M-Powered (Win) 0 01-25-2013 06:46 PM
New PT10 User. MBox3, MAudio Fast Track Ultra, MAudio Fast Track 8R? epu Pro Tools 10 3 06-13-2012 03:55 PM
Fast Track Ultra 8R TwoEdgedSword Pro Tools M-Powered (Mac) 0 08-25-2011 07:11 PM
track confusion in fast track ultra interface deck Pro Tools M-Powered (Win) 0 02-24-2010 10:17 AM


All times are GMT -7. The time now is 03:54 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com