Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Mixing > ICON & C|24

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 06-22-2009, 02:40 PM
ekatsuleres ekatsuleres is offline
Member
 
Join Date: Jun 2009
Posts: 1
Default Help with Control 24 Issue of Flashing LEDS and Clicking Sound

Currently I am having problems with my Control 24. When I start the device up by flipping the switch in the back it begins to go into some kind of broken start up loop. The screens and LEDs will flash and then it will make a click noise. It continues this loop non-stop and never boots up. I am wondering if it is a power supply problem or some sort of other defect. I have encountered this problem before and fixed it but for the life of me I cannot fully remember I did it. I do know I stumbled upon a post a while ago of a "reset" key combination. A set of keys held down during start up to sort of reboot the system. Does that sound familiar to anyone? This was almost over a year ago and I have not had the problem resurface since until now.

if anyone has encountered this problem or knows a fix please help.

Thanks
Reply With Quote
  #2  
Old 06-25-2009, 09:44 AM
Scott Goldberg Scott Goldberg is offline
Member
 
Join Date: Mar 2005
Location: SF Bay Area USA
Posts: 1,066
Default Re: Help with Control 24 Issue of Flashing LEDS and Clicking Sound

Quote:
Originally Posted by ekatsuleres View Post
Currently I am having problems with my Control 24. When I start the device up by flipping the switch in the back it begins to go into some kind of broken start up loop. The screens and LEDs will flash and then it will make a click noise. It continues this loop non-stop and never boots up. I am wondering if it is a power supply problem or some sort of other defect. I have encountered this problem before and fixed it but for the life of me I cannot fully remember I did it. I do know I stumbled upon a post a while ago of a "reset" key combination. A set of keys held down during start up to sort of reboot the system. Does that sound familiar to anyone? This was almost over a year ago and I have not had the problem resurface since until now.

if anyone has encountered this problem or knows a fix please help.

Thanks
I have a friend who has a similar problem. He has had some luck with replacing the power supply. It's a known but that has been surfacing semi-regularly. My friend's problem did not completely go away but it's better than it was. Good luck.

P.S. Why don't you have you Control 24 power up with the rest of your gear. Maybe there's something going on with the power cycle you have chosen. Also, make sure that the firmware is updated on your board.
__________________
Scott Goldberg
Gold Recordings
http://www.goldrecordings.com
Reply With Quote
  #3  
Old 07-15-2009, 04:46 AM
lab9ceo lab9ceo is offline
Member
 
Join Date: Aug 2005
Posts: 4
Default Re: Help with Control 24 Issue of Flashing LEDS and Clicking Sound

I am also having this same problem with mine. From what I understand its a power supply problem. Digi is aware of it and may replace your power supply if you call them. I hear that it has somthing to do with the glue being loose and making a good connection for a while but due to music vibrations eventually goes out. What a pain! I still need to get my board fixed. I love the board, Hate the problem. If you get a fix let me know. I will do the same. Thanks.
Reply With Quote
  #4  
Old 08-04-2009, 08:05 AM
aux aux is offline
Member
 
Join Date: Sep 2004
Location: Amsterdam, The Netherlands
Posts: 425
Default Re: Help with Control 24 Issue of Flashing LEDS and Clicking Sound

We've had this problem with both our Control 24's and that is the PSU. You can replace the PSU through Digidesign, although with one of them the problem came back after a while. Replacing the Control 24's for a couple of C|24's was the best investment in years
__________________
Aux

MassiveMusic

SOS article
Reply With Quote
  #5  
Old 08-04-2009, 08:26 AM
amorlando amorlando is offline
Member
 
Join Date: Sep 2004
Location: Suburbia
Posts: 33
Default Re: Help with Control 24 Issue of Flashing LEDS and Clicking Sound

This is the classic failure of these machines. replacing the supply will fix it, but is expensive. rebuilding the supplies is also touchy, so go with the replacement.

this occurs because as the power supply comes up to power, the current draw of the board causes the supply to shut off, then try to reboot. hence the flashing leds. digi first asks you to clean all the molex connectors on the power supply, this has not fixed any of our failures but by all means try it.

someone adept at repairing switch mode power supplies could probably fix it for you, but again, Id just order a new one.
__________________
Studio Troll
Reply With Quote
  #6  
Old 08-08-2009, 02:13 PM
macaholic macaholic is offline
Member
 
Join Date: Mar 2001
Location: atlanta, ga
Posts: 260
Default Re: Help with Control 24 Issue of Flashing LEDS and Clicking Sound

Any idea what ballpark price you are looking at for a new power supply?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Avid Mbox flashing leds ym2149 General Discussion 2 04-02-2012 12:54 AM
c24 flashing all leds whenever it wants!!!! SKINNY ICON & C|24 3 03-10-2009 08:18 PM
Mbox 2 flashing Leds Luca Silipo 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 0 01-01-2007 01:42 AM
Mbox 2 Flashing Leds Luca Silipo Pro Tools TDM Systems (Mac) 2 12-31-2006 03:07 PM
002 makes a clicking sound, 1394 light flashing behaviour 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 6 11-11-2004 06:22 PM


All times are GMT -7. The time now is 06:05 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com