Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > FireWire and USB Audio Interfaces (Win)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-17-2020, 08:05 AM
simonastro simonastro is offline
Member
 
Join Date: May 2020
Location: Brighton
Posts: 3
Default code 28 driver error on Fast Track C600

hi there
I'm hoping someone might help.
I've been tearing my hair out
I've upgraded my DAW to Win10 and although my Fast Track Pro functions OK I bought a C600 as it has Win 10 drivers and can hack 96khz in AND out.

In device manager I have Fast Track C600 listed under other devices with a code 28 error.
I've tried every USB port.
I have tried every iteration of the drivers except v1.01 which I can't find.
I have tried each one in compatibility mode.
I have reinstalled all the USB controllers.

I've even uninstalled the recent Microsoft update kb4556799 that's been throwing out some generic audio drivers.

any insights would be great

cheers

Simon
Reply With Quote
  #2  
Old 05-22-2020, 03:22 PM
simonastro simonastro is offline
Member
 
Join Date: May 2020
Location: Brighton
Posts: 3
Default Re: code 28 driver error on Fast Track C600

if anyone is successfully running one could you do me a favour and tell me what the USB hardware ID is? (it's the 3rd drop down on Details tab of properties in device manager)
and in conjunction with which driver version?

many thanks in advance
Reply With Quote
  #3  
Old 05-22-2020, 03:26 PM
simonastro simonastro is offline
Member
 
Join Date: May 2020
Location: Brighton
Posts: 3
Default Re: code 28 driver error on Fast Track C600

the hardware itself appears ok - all the lights come on when connected etc

I've tried it on 3 PCs now - 2 win 10pro (one of which a fresh install) and one win7 32bit

cannot recognise drivers in any case but shows up as "Fast Track C600" as a code 10 in other devices.

it cost me £100 on eBay and I'm wondering if I have grounds to send it back!

cheers
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fast Track C600 Driver OSX 10.12.6 problem. ampman FireWire and USB Audio Interfaces (Mac) 0 09-01-2017 12:25 AM
M-Audio Fast Track C600 causes Blue Screen due to driver failure. destroyer5157 Pro Tools 10 3 08-26-2015 07:31 PM
11R and Fast Track C600 Platereverb Eleven Rack 8 03-03-2013 03:37 AM
Fast Track C600 stefano.9119 Pro Tools SE and Essential (Mac) 1 12-21-2012 02:10 PM


All times are GMT -7. The time now is 06:31 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com