Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > Third Party Interfaces

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 06-19-2015, 05:28 AM
jkeefauver jkeefauver is offline
Member
 
Join Date: Aug 2006
Location: Hanover, PA
Posts: 89
Default Focusrite 18i20

Have had this interface for about 18 months now, used it in the past on a mobile rig under PT10.

Tried to use it yesterday with a PT11 system. Totally and utterly useless.

O/S is Win7/64. Intel quad with 8GB.

Driver on site gens "cannot initialize" error from PT11. On their website they suggest using a "beta" driver. Beta driver causes CPU to peg at 100% the second you load a session. (session had 8 tracks and 4 plugs in it).

Created brand new session, no tracks at all - same result.

Have uninstalled / reinstalled both the Focusrite driver and PT11.

This thing might as well be a paperweight right now. Anyhow have experience?
Reply With Quote
  #2  
Old 06-19-2015, 10:22 AM
Christian.Focusrite's Avatar
Christian.Focusrite Christian.Focusrite is offline
Focusrite
 
Join Date: Aug 2014
Location: Los Angeles
Posts: 80
Default Re: Focusrite 18i20

Hi jkeefauver,

I see you you mentioned the beta driver. Did you by chance also install the beta version of MixControl. These both need to be installed in order for everything to work properly. Also double check that your windows sound preferences are set to the same sample rate.

This does seem to be an issue related to how your system is using the driver and our tech support team can most certainly help trouble shoot the issue. Please get in direct contact with us: http://us.focusrite.com/answerbase/contact
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pro Tools 11 with Focusrite Scarlett 18i20? hermonmusic Third Party Interfaces 24 06-27-2015 08:53 AM
Focusrite Scarlet 18i20 tchipman Third Party Interfaces 43 06-03-2015 09:05 PM
Focusrite 18i20 won't power on. Woodybear Third Party Interfaces 3 04-03-2014 04:19 PM
Focusrite 18i20 won't detect when switching on Kollen.col Third Party Interfaces 11 03-26-2014 02:04 PM
Focusrite 18i20 MEWCO Third Party Interfaces 17 03-03-2014 09:37 PM


All times are GMT -7. The time now is 01:00 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com