Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > FireWire and USB Audio Interfaces (Mac)

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 07-14-2014, 07:20 AM
greedismysin greedismysin is offline
Member
 
Join Date: Jul 2014
Location: Louisiana
Posts: 2
Default Mbox 2 Pro isn't turning on, Please Help!

Hello, I have Pro Tools 11, Macbook Pro Late 2013, Mbox 2 Pro, Mavericks OSX 10.9.4.

Pro Tools 11 installed and works fine, but my Mbox 2 Pro isnt turning on at all. I downloaded and installed the latest drivers from avid, but its still not coming on. I have the mbox 2 pro connected via firewire to thunderbolt. The box was blinking orange at one point in time, then I downloaded the drivers and it won't come on any more. I was thinking maybe it was the OSX 10.9.4 and I was trying to downgrade to 10.9.3, but I have no way of doing that. I was even trying to downgrade to Mountain Lion, but I tried and read that I can't downgrade my OSX with the Late 2013 models. I have read that some people have 10.9.4 and mbox 2 pro and their mbox comes on and works perfectly fine. If anyone has any ideas, please help me, because i've tried everything I can think of. Thanks
Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mbox 3 Pro not turning on. Dead? ripsta415 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 7 02-17-2012 06:20 PM
Mbox 2 Not Turning On cegan 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 3 11-05-2011 07:57 PM
Caveman needs help turning on Mbox 2. Rain City Rock Tips & Tricks 5 03-18-2011 06:01 AM
mbox hardware not turning on AStabbinHobo 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 8 11-27-2006 01:47 PM
Mbox 2 not 'turning on' with Mac Book pro atinyspeckofdust 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 2 09-24-2006 07:16 PM


All times are GMT -7. The time now is 07:27 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com