Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > Pro Tools TDM Systems (Mac)

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 03-20-2003, 04:19 PM
mrmxed mrmxed is offline
Member
 
Join Date: Dec 1969
Location: L.A.
Posts: 229
Default Digi Customer Service

Last Sunday a bad output was discovered on one of my 192 I/O interfaces. The interface was shipped via FedEx 2nd day delivery to Digi on Monday afternoon for repair; returned today, Thursday, with the problem fixed. The turnaround was so fast that I thought there had been a screw up by Federal Express. Well done Digi! [img]images/icons/smile.gif[/img]

Mark Green
Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Digi Customer Service ndrr1113 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 2 12-21-2008 09:38 AM
Attn: Digi Customer Service Scotty_OiArT 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 0 10-11-2005 11:39 PM
Congrates DIGI for Excellent Customer Service ii88tek 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 24 01-22-2005 06:27 AM
Digi customer service matocaster1202 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 11 02-24-2002 12:37 AM
Excellent Digi customer service rusmooth General Discussion 0 10-09-2001 03:55 PM


All times are GMT -7. The time now is 07:08 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com