Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > General Discussion & Off Topic > General Discussion

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 04-05-2019, 09:35 AM
rwbreck rwbreck is offline
Member
 
Join Date: Oct 2018
Location: Seattle
Posts: 8
Default 2019 iMac i9 + PT 2018 + Mojave

Hey all- just got a new 2019 iMac with 8-core i9, was tired of fighting my old machine whose CPU just could not keep up (2010 MBP... I know). When the track freezing feature was introduced that helped some, but it was just taking FOREVER to mix cause the computer just couldn't keep up, even on smaller sessions. I got the most powerful Mac I could afford, only to find that you can't run older versions of OS X than what the computer came with- whoops- so now I have about 13 days to decide to either return the computer (a fairly significant investment as you can imagine), or wade into the muddy waters of making stuff work in Mojave that has yet to be officially supported. I tried opening up a session just to see what would happen, and though everything basically works, I was expecting pretty stellar performance from such a powerful processor, but I'm still getting some clicks/pops/AAE -6101 CPU overload errors. I attached a screenshot of the session I'm running. I am for sure running a decent handful of plugins, but there are not "that" many tracks... I was getting fairly solid performance out of my work's 2015 MBP (which was maybe a quad core i5?) until adding my last few mastering plugins on the 2 buss, so I expected the new machine to be head and shoulders above that in performance, but have not been blown out of the water like I was expecting to be. Based on your guys' experience, what would you expect with a session this size and a computer of those specs?
Attached Images
File Type: jpg image_4_5_19_at_9_24_QooxX.jpg (87.9 KB, 0 views)
Reply With Quote
  #2  
Old 04-05-2019, 09:55 AM
Southsidemusic's Avatar
Southsidemusic Southsidemusic is offline
Moderator
 
Join Date: Dec 2011
Location: Stockholm - Sweden
Posts: 11,853
Default Re: 2019 iMac i9 + PT 2018 + Mojave

Please upload a sharper picture as this is too blurry to make out what plugins are used on what track etc
__________________
Best Regards
Christopher

—————————————
South Side Music Group
WEBHOME
—————————————
Reply With Quote
  #3  
Old 04-05-2019, 10:08 AM
Darryl Ramm Darryl Ramm is offline
Member
 
Join Date: Nov 2010
Location: USA
Posts: 13,427
Default Re: 2019 iMac i9 + PT 2018 + Mojave

What interface?
What session sample rate?
What IO buffer size?
What drive is the audio on? (You should be using the internal super fast SSD on this computer, disk issues can exacerbate CPU errors)

Make sure disk cache is enabled=set to a size
Ignore errors is off at least while troubleshooting
Dynamic plugin processing off

What troubleshooting have you done on this new system?
You should of at least already tried...
Trashing prefs
Testing with standard output as the playback engine
Removing all third party plugins
Testing starting with a new empty session
Testing from a newly created admin account
Disabling hyper-threading
Looking for possible denormalization issues (runaway/spiky CPU use of some plugins)
Reply With Quote
  #4  
Old 04-05-2019, 10:10 AM
rwbreck rwbreck is offline
Member
 
Join Date: Oct 2018
Location: Seattle
Posts: 8
Default Re: 2019 iMac i9 + PT 2018 + Mojave

Sorry, here's a dropbox link to full res screenshot.

https://www.dropbox.com/s/fvvrw812en...%20AM.jpg?dl=0
Reply With Quote
  #5  
Old 04-05-2019, 10:17 AM
rwbreck rwbreck is offline
Member
 
Join Date: Oct 2018
Location: Seattle
Posts: 8
Default Re: 2019 iMac i9 + PT 2018 + Mojave

Good questions-

Antelope Orion Studio 2017 connected via Thunderbolt 3-2 adapter (Apple)
96kHz, 1024 buffer size
Running off of external USB 3 HDD (I think 7200rpm?)

Initially I had disk cache set to normal, ignore errors off, dynamic processing on
I'll change those and try again

No real troubleshooting yet to speak of- just surprised that out of the gate, this computer that I was expecting to be fairly powerful (3.6GHz 8-core i9) is having a lot of trouble playing back more than a couple seconds of this session at a time, even after freezing basically all tracks except reverb returns and mix buss.
Reply With Quote
  #6  
Old 04-05-2019, 10:27 AM
Darryl Ramm Darryl Ramm is offline
Member
 
Join Date: Nov 2010
Location: USA
Posts: 13,427
Default Re: 2019 iMac i9 + PT 2018 + Mojave

Quote:
Originally Posted by rwbreck View Post
Good questions-

Antelope Orion Studio 2017 connected via Thunderbolt 3-2 adapter (Apple)
96kHz, 1024 buffer size
Running off of external USB 3 HDD (I think 7200rpm?)

Initially I had disk cache set to normal, ignore errors off, dynamic processing on
I'll change those and try again

No real troubleshooting yet to speak of- just surprised that out of the gate, this computer that I was expecting to be fairly powerful (3.6GHz 8-core i9) is having a lot of trouble playing back more than a couple seconds of this session at a time, even after freezing basically all tracks except reverb returns and mix buss.
Move your entire session to the internal SSD and disconnect the external boat-anchor.

It takes one bad plugin to trash even the most powerful computer... you don’t even need to have that plugin instantiated in the session, just installed.

Start at “Help us Help You” up the top of each DUC web page. Should take less than an hour to do this basic but very useful troubleshooting.
Reply With Quote
  #7  
Old 04-05-2019, 10:44 AM
Meads's Avatar
Meads Meads is offline
Member
 
Join Date: Jul 2010
Location: Germany
Posts: 2,829
Default Re: 2019 iMac i9 + PT 2018 + Mojave

Slate FG-X is quite a CPU hog, and it's possible that some of the other plugins in use have oversampling activated.
Have you tried looking at the system usage meter and deactivating (not bypassing) plugin by plugin?

Do you have any background processes running? A fresh MacOs install has spotlight indexing for quite a while if you have a lot of emails/documents/files in general. Also the scan of photos and face recognition that runs in the background if you have a huge picture library synced from your phone uses up a lot of resources.
Check the activity monitor for CPU usage of your system if there's a process consuming CPU % other than PT. Any process that uses more than 10-15% is worth investigating, if you did not consciously initiate it.

It's certainly not normal behavior for that machine to not be able to handle this session.
__________________

iMac Pro
- MacOS 10.14.6
---
- Pro Tools U HDN 2019.6
- Avid HD Omni + HD I/O 8x8x8
- C|24
Reply With Quote
  #8  
Old 04-05-2019, 10:47 AM
Darryl Ramm Darryl Ramm is offline
Member
 
Join Date: Nov 2010
Location: USA
Posts: 13,427
Default Re: 2019 iMac i9 + PT 2018 + Mojave

And looking at your plugins very quickly, lots to want to troubleshoot there, esp. Slate VMR, old Ozone 6, etc. we cannot guess what you are doing in VMR. Try removing all .aaxplugin files, and restarting (Pro Tools will magically reinstall its own default plugins) if that is rock solid, try putting back say VMR and seeing if that works.
Reply With Quote
  #9  
Old 04-05-2019, 12:01 PM
rwbreck rwbreck is offline
Member
 
Join Date: Oct 2018
Location: Seattle
Posts: 8
Default Re: 2019 iMac i9 + PT 2018 + Mojave

Thanks for the helpful tips guys, sorry I didn't do a little more due diligence up front. My hope was to just restore my new machine from a backup of my old machine and get back to work without making a big project out of this- how naive! I had been keeping an eye on Activity Monitor, no other significant processes running in background. I trashed prefs, turned off Spotlight indexing, moved session to internal SSD, and moved all 3rd party plugins to unused plugins folder and started to replace. Session was still fairly responsive after adding back Slate and Waves plugs, no CPU overload errors to speak of. Adding Melodyne back, it took a little bit of a hit. Overall it is performing much better without Ozone which I still haven't added back (all I'm doing there is IRC 1 limiter), but there is still an incessant clicking happening the whole time. I know I'm on shaky ground as far as Pro Tools is concerned with Mojave, and Antelope doesn't officially support it yet either, so I'm wondering if the clicking is related to that rather than general performance issues.

My only real point of reference for all of this is my work's 2015 MBP like I said, so I expected the performance of this machine with twice the processor cores to be in another league, but so far that just hasn't seemed to be the case.
Reply With Quote
  #10  
Old 04-05-2019, 12:21 PM
Darryl Ramm Darryl Ramm is offline
Member
 
Join Date: Nov 2010
Location: USA
Posts: 13,427
Default Re: 2019 iMac i9 + PT 2018 + Mojave

Did you ever actually try to troubleshoot any issues on your old computer? It was your decision to buy a new iMac Pro — why not ask here for advice before doing that? I would have only done that after carefully troubleshooting everything else.

Maybe you should go look again at the old computer and see if you clean up/troubleshoot the software and plugins there if will work OK for you. Maybe consider upgrades to DRAM and disk would have helped there as well.

And forgot earlier: are theses systems fully optimized? Get every last optimization done, however annoying, at least to start with. If you did that before go check again.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PT won't record with 2018.12 and Mojave Ravenswood Pro Tools 2018 5 02-28-2019 05:59 AM
New MacMini(i7), Mojave, PT 2018.12U, HD-Native littlesicily macOS 12 12-26-2018 06:03 PM
PT 2018.7 on MacOS 10.14 Mojave works for me veinticinco Pro Tools 2018 38 12-09-2018 07:35 AM
2018.10 works on MBP i9 with Vega 20 and Mojave DarkandKurious Pro Tools 2018 3 11-27-2018 12:23 PM


All times are GMT -7. The time now is 05:00 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com