Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > FireWire and USB Audio Interfaces (Mac)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 07-14-2014, 06:20 AM
greedismysin greedismysin is offline
Member
 
Join Date: Jul 2014
Location: Louisiana
Posts: 2
Default Mbox 2 Pro isn't turning on, Please Help!

Hello, I have Pro Tools 11, Macbook Pro Late 2013, Mbox 2 Pro, Mavericks OSX 10.9.4.

Pro Tools 11 installed and works fine, but my Mbox 2 Pro isnt turning on at all. I downloaded and installed the latest drivers from avid, but its still not coming on. I have the mbox 2 pro connected via firewire to thunderbolt. The box was blinking orange at one point in time, then I downloaded the drivers and it won't come on any more. I was thinking maybe it was the OSX 10.9.4 and I was trying to downgrade to 10.9.3, but I have no way of doing that. I was even trying to downgrade to Mountain Lion, but I tried and read that I can't downgrade my OSX with the Late 2013 models. I have read that some people have 10.9.4 and mbox 2 pro and their mbox comes on and works perfectly fine. If anyone has any ideas, please help me, because i've tried everything I can think of. Thanks
Reply With Quote
  #2  
Old 07-14-2014, 07:21 AM
YYR123's Avatar
YYR123 YYR123 is offline
Member
 
Join Date: Dec 2010
Location: Austin TX
Posts: 13,666
Default Re: Mbox 2 Pro isn't turning on, Please Help!

Find the info on how to flash the firmware on the unit......

That and make sure power is connected and power supply is outputting voltage (the correct voltage)

Great USER name
__________________
Daniel
HDX - PT12.5.1 - HD I/O 16x8x8
Win10-Pro (v1709)- 6 Core i7-6850k - ASUS X99 Deluxe ii
D-Command Main Unit - 'Ole Blue


http://www.sknoteaudio.com/ plugins rock and are affordable.
Reply With Quote
  #3  
Old 07-14-2014, 07:42 AM
greedismysin greedismysin is offline
Member
 
Join Date: Jul 2014
Location: Louisiana
Posts: 2
Default Re: Mbox 2 Pro isn't turning on, Please Help!

Thanks for the reply and compliment on the name YYR123. Do you have the direct page for me to look at how to flash the firmware and the mbox 2 pro had just powered on mainly with just the firewire cord, but I don't mind at all to go pick up a cord if it will fix the problem, do I get something like that from radio shack or another place? Thanks
Reply With Quote
  #4  
Old 07-14-2014, 07:44 AM
YYR123's Avatar
YYR123 YYR123 is offline
Member
 
Join Date: Dec 2010
Location: Austin TX
Posts: 13,666
Default Re: Mbox 2 Pro isn't turning on, Please Help!

It should have come with a power cord....but you may have to look at the manual and discern what the volts/amps config is....

Maybe avid has them in the store still?
__________________
Daniel
HDX - PT12.5.1 - HD I/O 16x8x8
Win10-Pro (v1709)- 6 Core i7-6850k - ASUS X99 Deluxe ii
D-Command Main Unit - 'Ole Blue


http://www.sknoteaudio.com/ plugins rock and are affordable.
Reply With Quote
  #5  
Old 07-14-2014, 07:50 AM
YYR123's Avatar
YYR123 YYR123 is offline
Member
 
Join Date: Dec 2010
Location: Austin TX
Posts: 13,666
Default Re: Mbox 2 Pro isn't turning on, Please Help!

http://avid.force.com/pkb/articles/e...qrm=0&filter=0

Sounds like your issue, surf around avid's site is decent enough
__________________
Daniel
HDX - PT12.5.1 - HD I/O 16x8x8
Win10-Pro (v1709)- 6 Core i7-6850k - ASUS X99 Deluxe ii
D-Command Main Unit - 'Ole Blue


http://www.sknoteaudio.com/ plugins rock and are affordable.
Reply With Quote
  #6  
Old 07-15-2014, 01:30 AM
arnoldi arnoldi is offline
Member
 
Join Date: Jul 2014
Location: Finland
Posts: 7
Default Re: Mbox 2 Pro isn't turning on, Please Help!

Quote:
Originally Posted by greedismysin View Post
Hello, I have Pro Tools 11, Macbook Pro Late 2013, Mbox 2 Pro, Mavericks OSX 10.9.4.

Pro Tools 11 installed and works fine, but my Mbox 2 Pro isnt turning on at all. I downloaded and installed the latest drivers from avid, but its still not coming on. I have the mbox 2 pro connected via firewire to thunderbolt. The box was blinking orange at one point in time, then I downloaded the drivers and it won't come on any more. I was thinking maybe it was the OSX 10.9.4 and I was trying to downgrade to 10.9.3, but I have no way of doing that. I was even trying to downgrade to Mountain Lion, but I tried and read that I can't downgrade my OSX with the Late 2013 models. I have read that some people have 10.9.4 and mbox 2 pro and their mbox comes on and works perfectly fine. If anyone has any ideas, please help me, because i've tried everything I can think of. Thanks
Hello. I have also Mavericks 10.9.4, MacBook Pro and Mbox 2 Pro with PT 10 at the moment and had same problems. I found certain things to check and now setup works mainly ok:

First, make sure you download driver 10.3.3 from here, system restarts after install:
http://avid.force.com/pkb/articles/e...-2-Pro-Drivers

Install driver and confirm from your control panel (Mbox 2 Pro icon) that Mbox Pro has firmware updated and lights should now turn on to your mbox. I had problem first that after shutdown or restart Mbox was not turned on anymore. Also whole computer crashed couple of times. For big part of solution was that I used FW 400/800 adapter connected to my FW800 slot in MBP: FW 400 for Mbox and FW 800 for ext. drive -->Then I bought FW800 --> thunderbolt adapter and connected ext. drive to that and left FW only for Mbox. Then system started work more stabile and now even after computer restart Mbox 2 is recognized automatically.

So my advice is to check how your other devices are connected, they SURELY can affect on how MBP works, at least in Mavericks. This was not the case for Lion when no such issues were there.

But still it seems drivers for Mavericks are not yet fully supported for Mavericks 10.9.4 at least because when computer goes to sleep mode and return with Mbox connected, system will crash. I'd like ask Avid to make update Mbox 2 Pro drivers still more stabile.

Last edited by arnoldi; 07-16-2014 at 01:01 AM.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mbox 3 Pro not turning on. Dead? ripsta415 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 7 02-17-2012 05:20 PM
Mbox 2 Not Turning On cegan 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 3 11-05-2011 06:57 PM
Caveman needs help turning on Mbox 2. Rain City Rock Tips & Tricks 5 03-18-2011 05:01 AM
mbox hardware not turning on AStabbinHobo 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 8 11-27-2006 12:47 PM
Mbox 2 not 'turning on' with Mac Book pro atinyspeckofdust 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 2 09-24-2006 06:16 PM


All times are GMT -7. The time now is 09:49 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com