Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Additional Resources


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Hardware > FireWire and USB Audio Interfaces (Mac)

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 09-27-2013, 12:33 AM
Bruce Paine Bruce Paine is offline
Admin Emeritus
 
Join Date: Apr 1998
Location: Carmel, CA
Posts: 2,818
Default Mbox/Mbox Pro & Fast Track USB/Pro Driver Updates

The following driver updates are available for download from the driver pages:


Mbox Pro (3rd gen) Drivers
  • Mac v1.2.2
  • Win v1.1.9

Mbox (3rd gen) Drivers
  • Mac v1.1.5

Fast Track Pro Drivers
  • Mac v1.9.3

Fast Track USB Drivers
  • Mac v1.9.4
__________________
Bruce Paine
System Details
Reply With Quote
  #2  
Old 09-27-2013, 06:00 PM
jryser's Avatar
jryser jryser is offline
Member
 
Join Date: Nov 2011
Location: Plainfield, IN
Posts: 909
Default Re: Mbox/Mbox Pro & Fast Track USB/Pro Driver Updates

Dangit! My MBox Pro 3 tuner stopped working again. Had everything fine until now. Any way to fix this? Thanks.


Sent from my PT beating heart
__________________
A Rig: MacBook Pro Spring 2013, 2.8Ghz I7, 16GB RAM,
OSX Mavericks 10.9.4, PT 11.2, MBox Pro 3, Glyph GT 050 Qx3 1.5 TB drives Thunderbolt-FW400, Presonus Faderport. 10 REMOVED!
B Rig:MacBook Pro Spring 11, 2.33 GHz I7, 16GB RAM, OSX Mavericks 10.9.4, PT 11.2, MBox Pro 3, Glyph Portagig 62 portable 1 TB drive Firewired with 400, Presonus Faderport. 10 REMOVED!
I am the main songwriter/performer for Midwest Whitetail, Cabela's Deer Nation, Spring Thunder, and Northern Waters Series!
Reply With Quote
  #3  
Old 09-28-2013, 08:45 AM
serio serio is offline
Member
 
Join Date: Aug 2009
Location: SWFLA
Posts: 384
Default Re: Mbox/Mbox Pro & Fast Track USB/Pro Driver Updates

It stopped working after updating to the new drivers? that sucks

For anyone interested:
This is a list of fixes included in this update:

Fixed problem where Mbox Pro Control Panel would become unresponsive if it was launched before Pro Tools
Fixed problem where Low Latency Monitoring would duplicate signal
Fixed problem where Pro Tools would not take proper control over Stereo Mix controls in Mbox Control Panel
Fixed problem where monitoring of record-enabled channels in Pro Tools with Low Latency Monitoring enabled would not function until a recording was made


I had experienced the last two problems and the bottom one seems to be addressed. But Pro Tools seems to still have a problem fully taking over the mbox control panel in LLM mode. Mono signals are fine, but if i try to monitor a stereo signal, the left channel gain is set higher than the right. This happens with any of the stereo analog inputs
Also, I didn't expect it to get fixed in a driver update, but the DSP effects are still dead.
Attached Thumbnails
Click image for larger version

Name:	mboxcp.jpg
Views:	0
Size:	63.4 KB
ID:	818  
__________________
21.5" Mid-2011 iMac i5 QUAD 2.5GHZ 4G RAM ML 10.8.5--Pro Tools 10.3.9--Avid Mbox Pro / 003R--ICY DOCK MB664UEA-1S FW400 With: 500GB Samsung HD502HJ
Reply With Quote
  #4  
Old 09-28-2013, 09:00 AM
jryser's Avatar
jryser jryser is offline
Member
 
Join Date: Nov 2011
Location: Plainfield, IN
Posts: 909
Default Re: Mbox/Mbox Pro & Fast Track USB/Pro Driver Updates

Serio - it's you and and me again! My DSP fx work perfectly - the tuner is what's gone again! I have a comp code from my pt 11 I will use to see what's up and let u know. I can live without the tuner (have a Petersen on my phone) but I'm one of those geeks who likes things to work correctly. Undoubtedly it's an error somewhere in my gear, but I will resolve it!


Sent from my PT beating heart
__________________
A Rig: MacBook Pro Spring 2013, 2.8Ghz I7, 16GB RAM,
OSX Mavericks 10.9.4, PT 11.2, MBox Pro 3, Glyph GT 050 Qx3 1.5 TB drives Thunderbolt-FW400, Presonus Faderport. 10 REMOVED!
B Rig:MacBook Pro Spring 11, 2.33 GHz I7, 16GB RAM, OSX Mavericks 10.9.4, PT 11.2, MBox Pro 3, Glyph Portagig 62 portable 1 TB drive Firewired with 400, Presonus Faderport. 10 REMOVED!
I am the main songwriter/performer for Midwest Whitetail, Cabela's Deer Nation, Spring Thunder, and Northern Waters Series!
Reply With Quote
  #5  
Old 09-28-2013, 05:19 PM
serio serio is offline
Member
 
Join Date: Aug 2009
Location: SWFLA
Posts: 384
Default Re: Mbox/Mbox Pro & Fast Track USB/Pro Driver Updates

Quote:
Originally Posted by jryser View Post
but I'm one of those geeks who likes things to work correctly.
Well the device really should work as advertised. I'm getting along ok without the broken features but it's not the point. If the box didn't sound as good as it does, I'd just stick with my trusty old 003R.

Here's some workarounds:
For anyone needing Reverb while tracking, Shan's LLM Reverb trick will work(see Pic).

As for the LLM not working properly, people can just mute the track they are recording to and then use another Stereo Mix in the Mbox Pro Control Panel to monitor with. Pro Tools only takes over Stereo Mix 1. This doesn't work for everyone's work flows though.
Attached Thumbnails
Click image for larger version

Name:	LLMVerbReturn.jpg
Views:	0
Size:	31.7 KB
ID:	819  
__________________
21.5" Mid-2011 iMac i5 QUAD 2.5GHZ 4G RAM ML 10.8.5--Pro Tools 10.3.9--Avid Mbox Pro / 003R--ICY DOCK MB664UEA-1S FW400 With: 500GB Samsung HD502HJ
Reply With Quote
  #6  
Old 02-22-2014, 03:47 PM
zappity zappity is offline
Member
 
Join Date: Apr 2009
Posts: 4
Default Re: Mbox/Mbox Pro & Fast Track USB/Pro Driver Updates

I'm chiming in here in the hopes of saving you some time.

I'm running PT 9.0.6, Mbox Pro 3, on OSX 10.6.8

Recently updated my Mbox driver to 1.2.2 but then kept getting "Pro Tools hardware is either not installed or used by another program" error messages. I could not get Mbox to show up as the Current Engine in the Playback Engine window (only saw Pro Tools Aggregate I/O). Upgrading directly to 1.3.0 from 1.2.2 did not work. Neither did uninstalling the driver and just installing 1.3.0

Here's what worked for me on my set up:

Download and install 1.1.5. Then, without uninstalling, upgrade to 1.3.0 directly. Restart and cross your fingers.

I hope this works for you. But wanted to let people know that I was able to get the most current Mbox driver working with Pro Tools 9.

Good luck
Reply With Quote
  #7  
Old 02-24-2014, 06:21 AM
JoelG's Avatar
JoelG JoelG is offline
Moderator
 
Join Date: Mar 2010
Location: Canada
Posts: 1,850
Default Re: Mbox/Mbox Pro & Fast Track USB/Pro Driver Updates

The 1.3 driver is for Mavericks support only, http://avid.force.com/pkb/articles/d...ox-Pro-Drivers

1.3 Nov 12, 2013
Mac OS X 10.9, 10.9.1 Mavericks support only.
Mac OS X 10.9 Requires Pro Tools 11.0.3 or higher
Mac OS X 10.9.1 Requires Pro Tools 11.1.2 or higher
Tested with Avid-qualified Apple Computers

Joel
__________________
Jame Space:
HP Elite 6300 / Core i5 3570 / 12GB RAM / Win 10 Pro
Pro Tools 12 HD / Focusrite 18i20 + M-Audio ProFire 2626

Home:
Intel S5000PSL / 2 x Xeon E5450 / 32GB RAM / Win 10 Pro
Pro Tools 12 HD / M-Audio Project Mix IO

Rig:
Eleven Rack / ART SLA1 / Fender Mustang V 412 / FCB1010 w/ EurekaPROM
Reply With Quote
  #8  
Old 04-09-2014, 12:09 AM
Delayfinder Delayfinder is offline
Member
 
Join Date: Apr 2014
Location: Germany
Posts: 1
Default Re: Mbox/Mbox Pro & Fast Track USB/Pro Driver Updates

Quote:
Originally Posted by Bruce Paine View Post
The following driver updates are available for download from the driver pages:


Fast Track Pro Drivers
  • Mac v1.9.3
MacBookPro Mid 2009, MacOS 10.9.2 Mavericks, Fast Track Pro (Firmware 1.02).

The FastTrackPro Driver 1.9.3 does not work. The Interface has no audio output.

Uninstalling the driver, building an aggregate device in MacOS' Audio/MIDI setup by using the core audio drivers works.

But is there a chance to get a driver which working fine like about the last 5 years??? Please!!
Do you have an idea why the driver is not working?

Last edited by Delayfinder; 04-11-2014 at 03:36 PM.
Reply With Quote
  #9  
Old 05-23-2014, 09:39 AM
PonchoS PonchoS is offline
Member
 
Join Date: Feb 2014
Location: Stockholm
Posts: 2
Default Re: Mbox/Mbox Pro & Fast Track USB/Pro Driver Updates

[QUOTE=Delayfinder;2147475]
Quote:
Originally Posted by Bruce Paine View Post
The following driver updates are available for download from the driver pages:


Fast Track Pro Drivers
  • Mac v1.9.3


MacBookPro Mid 2009, MacOS 10.9.2 Mavericks, Fast Track Pro (Firmware 1.02).

The FastTrackPro Driver 1.9.3 does not work. The Interface has no audio output.

Uninstalling the driver, building an aggregate device in MacOS' Audio/MIDI setup by using the core audio drivers works.

But is there a chance to get a driver which working fine like about the last 5 years??? Please!!
Do you have an idea why the driver is not working?
Yes, where are the drivers??? Will you not get us (your costumers) the drivers for OS X 10.9.x?
Reply With Quote
  #10  
Old 06-05-2014, 11:07 AM
Mike J Vaughn Mike J Vaughn is offline
Member
 
Join Date: Aug 2005
Posts: 14
Default Re: Mbox/Mbox Pro & Fast Track USB/Pro Driver Updates

Wow! Huge thanks to Avid for not updating the drivers for the MBox 3 since 2013! It's not like you had any major software updates like Pro Tools 11 and it's certainly not like Mac or Windows had any software updates either.

Nope, everything is just fine. I'll continue to work in Mono since my MBox still wont output two channels. Who doesn't just love everything in MONO anyway, right?

Or, I could use the audio output of the Mac, Because I'm sure Pro Tools won't have any problems with that either.

Keep it up Avid. We'll all be Apogee, PreSonus users soon enough.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mbox Pro Driver Updates Bruce Paine FireWire and USB Audio Interfaces (Win) 16 03-19-2018 01:19 AM
Mbox/Mbox Pro & Fast Track USB/Pro Driver Updates Bruce Paine Technical Alerts 0 09-27-2013 12:33 AM
mbox 2 factory driver updates Felix777 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 4 12-01-2012 03:09 PM
Updated Mac Drivers for Mbox, Mbox Pro and Fast Track Ultra now available Avid Technical Alerts 0 10-30-2012 04:24 PM


All times are GMT -7. The time now is 10:45 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com