Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > macOS

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-29-2015, 08:29 PM
manyrains manyrains is offline
Member
 
Join Date: Oct 2007
Location: Dallas, TX
Posts: 344
Default Been gone a long time—upgrade help?

I haven't been using my studio hardly at all past 2 years, my head is totally out of the Pro Tools world. Just bought new Mac Pro (base version) as my old one running Leopard (?) 8.0 just died. Didn't even cross my mind at Apple store about upgrade issues. Duh. What do I should I expect to spend, what do I upgrade to, do I need new interface (current 002) what the deal with plug-ins these days?
Please be gentle. Thanks.
__________________
www.jimsavage.net
www.manyrainsmedia.com
Mac Pro Late 2013, 3.7, 12GB, Apollo Twin, PT12, ADL 600, UA 2-1176, Mojave MA-200
Reply With Quote
  #2  
Old 05-29-2015, 08:46 PM
Craig F Craig F is offline
Member
 
Join Date: Aug 2000
Location: Portland, OR
Posts: 12,591
Default

OSX 10.10 is going to need Pro Tools 11.3.1 or 12
most of the major retailers still have LE to 12 upgrades
RTAS plugs are dead and replaced with AAX 64 bit (PT 10 supports 32 bit AAX), most venders have reasonable upgrades, some are dropped totally from development
I think the 002 will work but there are a plethora of options open to you now that you are no longer tied to hardware
you will need a v2 iLok, Slate Digital has a deal that you buy select plug-ins they will send you a v2 iLok (the second one http://www.slatedigital.com/online-shop/rc-tube)
__________________
...

"Fly High Freeee click psst tic tic tic click Bird Yeah!" - dave911

PT11 System Requirements link http://avid.force.com/pkb/articles/C...m-Requirements


Thank you,

Craig
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Long time 001 user with upgrade questions Folkcafe 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 5 09-23-2007 07:30 PM
It's been a long time... brian brilliant 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 3 02-06-2007 11:47 AM
It's been a long time... brian brilliant Pro Tools TDM Systems (Mac) 0 02-06-2007 06:30 AM
1st time caller, long time listener brill bedroom 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 2 03-23-2005 06:12 PM
Long, long Time loading PTLE on G4 DP 1.25!! pockets745 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 3 11-30-2004 05:09 PM


All times are GMT -7. The time now is 04:49 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com