Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Legacy Products > Pro Tools 12

Reply
 
Thread Tools Search this Thread Display Modes
  #11  
Old 08-04-2019, 12:13 PM
musicman691 musicman691 is offline
Member
 
Join Date: Dec 2009
Location: The Soprano State (NJ)
Posts: 16,662
Default Re: Getting all confused...want to update PT9

Quote:
Originally Posted by Patill View Post
Hey guys,

so I just bought the Avid Update, a new iLok 3 and would like to get started...when looking at compatibilities, it seems like Battery 3 by Native Instruments is no longer supportet with ProTools 11 (right?), so Pro Tools 10 seems to be the right choice. Can I run Pro Tools 10 with El Capitan?

Or do I have to install some other OS?


Thanks
Lots of questions and lots of confusion.
What Avid update did you buy?
PT11 only supports aax64 format plugins so Battery 3 won't run in it.
PT10 will NOT run in El Crapitan; the latest OSX it'll run is is OSX 10.9.5

But none of your post makes any sense. What exactly are you trying to accomplish?
__________________
Jack
See profile for system details
iMac dead & retired as of 11/4/17

QAPLA!
Reply With Quote
  #12  
Old 08-07-2019, 12:40 PM
Patill Patill is offline
Member
 
Join Date: May 2007
Posts: 178
Default Re: Getting all confused...want to update PT9

I had ProTools 9 and wanted to update since some plugins won´t work anymore. So I bought the recent Pro Tools Update one to be able to install ProTools 10.
Reply With Quote
  #13  
Old 08-07-2019, 01:42 PM
musicman691 musicman691 is offline
Member
 
Join Date: Dec 2009
Location: The Soprano State (NJ)
Posts: 16,662
Default Re: Getting all confused...want to update PT9

Quote:
Originally Posted by Patill View Post
I had ProTools 9 and wanted to update since some plugins won´t work anymore. So I bought the recent Pro Tools Update one to be able to install ProTools 10.
What OSX do you have on the computer now? The latest PT10 will run on is OSX 10.9.5. But really - you should see if you can get updates for your plugins so you can run something better/newer than PT10.

Did you spend $299 just so you could run PT10? False economy to do that and not get upgrades for your plugins (not to mention a waste of money).
__________________
Jack
See profile for system details
iMac dead & retired as of 11/4/17

QAPLA!
Reply With Quote
  #14  
Old 08-09-2019, 11:07 AM
Patill Patill is offline
Member
 
Join Date: May 2007
Posts: 178
Default Re: Getting all confused...want to update PT9

Well, I have the money to update pro tools but do I also have the money to buy upgrades like battery 4 and lots of other stuff? I mean this is how they make their money. Compatibility. And (my opinion) this is also how they make people like me feel scammed, at least a little. You spend a lot of money and suddenly it doesn‘t work anymore because of „compatibility issues“ even if it easily could.

I will update once again now and then never anymore. It’s not like much better music than nowdays has been made with much „cheaper“ equipment 50 years ago
Reply With Quote
  #15  
Old 08-09-2019, 11:07 AM
Patill Patill is offline
Member
 
Join Date: May 2007
Posts: 178
Default Re: Getting all confused...want to update PT9

oh sorry...but thank you for your help :) somehow I cannot edit the post before
Reply With Quote
  #16  
Old 08-09-2019, 12:30 PM
musicman691 musicman691 is offline
Member
 
Join Date: Dec 2009
Location: The Soprano State (NJ)
Posts: 16,662
Default Re: Getting all confused...want to update PT9

Quote:
Originally Posted by Patill View Post
Well, I have the money to update pro tools but do I also have the money to buy upgrades like battery 4 and lots of other stuff? I mean this is how they make their money. Compatibility. And (my opinion) this is also how they make people like me feel scammed, at least a little. You spend a lot of money and suddenly it doesn‘t work anymore because of „compatibility issues“ even if it easily could.

I will update once again now and then never anymore. It’s not like much better music than nowdays has been made with much „cheaper“ equipment 50 years ago
There's no easy way to make old s/w compatible with new operating systems or the other way around. Developers can't keep supporting old stuff forever.
Quote:
Originally Posted by Patill View Post
oh sorry...but thank you for your help :) somehow I cannot edit the post before
You still haven't answered questions I asked like which specific upgrade did you buy? What OSX are you running?

More specifically what exactly are you trying to accomplish? I know what you said in your first post here but you don't give any system details. If you could see your way to answering the questions here we may well be able to help you.
__________________
Jack
See profile for system details
iMac dead & retired as of 11/4/17

QAPLA!
Reply With Quote
  #17  
Old 08-10-2019, 07:09 AM
Patill Patill is offline
Member
 
Join Date: May 2007
Posts: 178
Default Re: Getting all confused...want to update PT9

sorry...running el capitan latest version on a mac pro 2008 and ssd

I bought the ProTools Update and Support plan, but I think I won’t renew the lease after one year. Which I should be fine with right?


What I am trying to accomplish is to get my Eventide Plugins running which are no more supported for ProTools 9. Apart from those plugins running I want to make sure that my existing plug ins are also running with no compatibility issues.
Reply With Quote
  #18  
Old 08-10-2019, 12:11 PM
musicman691 musicman691 is offline
Member
 
Join Date: Dec 2009
Location: The Soprano State (NJ)
Posts: 16,662
Default Re: Getting all confused...want to update PT9

Quote:
Originally Posted by Patill View Post
sorry...running el capitan latest version on a mac pro 2008 and ssd

I bought the ProTools Update and Support plan, but I think I won’t renew the lease after one year. Which I should be fine with right?


What I am trying to accomplish is to get my Eventide Plugins running which are no more supported for ProTools 9. Apart from those plugins running I want to make sure that my existing plug ins are also running with no compatibility issues.
Your plugins aren't so much the issue as the OSX you're trying to run PT10 in. Simply put it won't properly run in El Crapitan. As a matter of fact it won't run properly in Yosemite. The last usable OSX for PT10 was Mavericks OSX 10.9.5.

You are NOT going to be fine. You're going to have to backdate your OSX to 10.9.5 if you want to run PT10. Period. What is it going to cost to update your Eventide plugins (if you can)? You never mentioned Eventide before but Battery 3. Hard to help you when you keep changing the story and giving incomplete information.

Basically you wasted money on the upgrade IF you purchased the $299 upgrade. You STILL haven't said what EXACT upgrade you purchased.
__________________
Jack
See profile for system details
iMac dead & retired as of 11/4/17

QAPLA!
Reply With Quote
  #19  
Old 08-11-2019, 11:57 AM
Patill Patill is offline
Member
 
Join Date: May 2007
Posts: 178
Default Re: Getting all confused...want to update PT9

dude what do you want to hear...there is only one pro tools "update" you can buy since it is a support plan.

Which is what I wrote. "I bought the ProTools Update and Support plan"

As for the eventide plugins, I never said I had to update those. I said I have to update pro tools to get these plug ins running, leading to compatibility problems with other plug ins.
Reply With Quote
  #20  
Old 08-11-2019, 12:36 PM
musicman691 musicman691 is offline
Member
 
Join Date: Dec 2009
Location: The Soprano State (NJ)
Posts: 16,662
Default Re: Getting all confused...want to update PT9

Quote:
Originally Posted by Patill View Post
dude what do you want to hear...there is only one pro tools "update" you can buy since it is a support plan.

Which is what I wrote. "I bought the ProTools Update and Support plan"

As for the eventide plugins, I never said I had to update those. I said I have to update pro tools to get these plug ins running, leading to compatibility problems with other plug ins.
There are multiple upgrade plans that can be purchased. Say going from PT 10 to PT 2019.x (which is what I did) costs $299 US and gets me a license asset for PT 10/11/12/2019.x As I understand it the subscription upgrades only get you a license asset for PT 2019.x. THAT is why I'm asking what exact upgrade you purchased.



As to compatibility with plugins you're chasing two variables at once which is never good. You talk about a couple different plugins and compatibility issues differ for each. There is no reason you should need to upgrade PT to get your existing plugins working if they are working NOW. And a lot of that has to do with what OSX you're running.


Once again there are so many variables going on and you're not nailing down what you want to do. You give info that doesn't make any sense. If you can't answer the questions I posted then I'm outta here; let someone else try and figure it out.
__________________
Jack
See profile for system details
iMac dead & retired as of 11/4/17

QAPLA!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
11.0.3 update compatibility - I'm confused musicman691 Pro Tools 11 12 12-10-2013 10:13 PM
Bit confused PT9 with CPTK update to PT10 Rob_A Windows 1 10-27-2011 09:38 AM
Confused over the 8.0.3cs2 update lowlevelowls 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 2 04-01-2010 08:31 AM
im confused about 7.4 update scuffle 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 1 06-16-2008 04:01 PM
:confused: Confused Re: Expansion Chasis BA Studios 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 2 02-26-2008 09:24 AM


All times are GMT -7. The time now is 05:03 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com