Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > macOS

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 10-08-2014, 09:53 PM
kirkbross's Avatar
kirkbross kirkbross is offline
Member
 
Join Date: Jul 2004
Location: Los Angeles
Posts: 347
Default Logitech mouse response "absolutely terrible" in OS X?

I have a Logitch MX Pro mouse from around 2009 and I love(d) it... I love all the buttons, the shape, weight and everything. With all my custom button assignments it has become integral to my PT and Melodyne universe.

However... and I'm not sure when it started... but I can't for the life of me get smooth, responsive scrolling. In particular, horizontal scrolling (shift + wheel). No matter how I set the settings, it's like the worst, choppy, non-responsive mouse movement. Truly frustrating.

I really, really, really miss being able to scroll up, down, left and right, smoothly. It should feel like a web page, but there is so much lag and dropped data that it baffles me.

Is this the mouse or OS X or PT11?

2008 Mac Pro
Mavericks 10.9.5
PT11
__________________
Pearlman Church Microphone > Great River MP-2NV > Warm Audio WA-76 > Apogee Symphony MK II 8x8+8MP > PT2018 on 2018 Mac Mini with 32GB of RAM running Mojave.
Reply With Quote
  #2  
Old 10-08-2014, 10:17 PM
Simon Morrison's Avatar
Simon Morrison Simon Morrison is offline
Member
 
Join Date: Jun 2013
Location: California
Posts: 82
Default Re: Logitech mouse response "absolutely terrible" in OS X?

It sounds like you don't have the latest Logitech driver installed for your mouse.

Check the Logitech support page for an update: https://support.logitech.com/en_us/home
__________________

Simon Morrison • Audio Architect • Mastering Engineer • Music Technologist
Pro Tools 12.8.3 (Native) | macOS 10.12.6
[ www.MorrisonStudios.com ]
Reply With Quote
  #3  
Old 10-09-2014, 03:07 AM
Delta Music Belgium's Avatar
Delta Music Belgium Delta Music Belgium is offline
Member
 
Join Date: Oct 1999
Location: Sint-Truiden, Belgium, Europe
Posts: 569
Default Re: Logitech mouse response "absolutely terrible" in OS X?

I can't help noticing your mouse dates from 2009.

I use the Logitech Marble Mouse (trackball) on 4 different Mac's and I like it very much, but after approx. one year of intensive use I need to replace it by a new one. The problem is always the same: the small buttons become less responsive. So I have a big pile of broken trackballs + a stock of new ones, but I consider this has normal 'wear and tear' (and maybe intended as such by Logitech, if you make things that last forever you will go bankrupt)

So probably your shift button has become less responsive too, or the scroll wheel, or both and it's time to replace it by a new one.

On the driver part: I use the same version of 'Logitech Control Center' on Max OS 10.7, 10.8 and 10.9, always with the same type of Logitech Marble Mouse. Once calibrated all the mouses (trackballs) perform identical. So I don't think the driver would be the problem
__________________
Marc Schellekens
Delta Music Belgium - Pro Tools | HDX Studio
http://www.deltamusic.be

System 1: Mac Pro (Mid 2012) 3.33 GHz 6-core - 32 GB RAM - OS X 10.13.6 - Magma EB7 - PT HDX3 - PT Ultimate 2018.12 - HD I/O 16x16 - 192 I/O - 192D I/O (x3) - SYNC HD I/O - Apogee Big Ben - Rosetta 200 - Slate RAVEN MTi2 (x3)

System 2: Mac Pro (Mid 2010) 3.33 GHz 6-core - 32 GB RAM - OS X 10.9.5 - Magma PE6R4-I - PT HD 6 Accel PCI - PT HD 10.3.10 - 192D I/O - SYNC I/O
Reply With Quote
  #4  
Old 10-09-2014, 04:15 AM
groundcontrol's Avatar
groundcontrol groundcontrol is offline
Member
 
Join Date: Aug 2001
Location: Montreal, Canada
Posts: 961
Default Re: Logitech mouse response "absolutely terrible" in OS X?

The Mx Pro is a great mouse but it's relatively fragile and prone to mechanical failure of its parts. I know this first hand.
__________________
Can you please send yourself over fiber to go spam some other forum?

Darryl Ramm
Reply With Quote
  #5  
Old 10-11-2014, 03:16 AM
holler holler is offline
Member
 
Join Date: Apr 2014
Location: Stockholm, Sweden
Posts: 161
Default Logitech mouse response "absolutely terrible" in OS X?

If you're used to Windows I've found OS X to have a completely different feel with mice, trackpad's etc, despite the same hardware.

Not as "snappy" for better or worse
Reply With Quote
  #6  
Old 10-11-2014, 03:43 AM
musicman691 musicman691 is offline
Member
 
Join Date: Dec 2009
Location: The Soprano State (NJ)
Posts: 16,273
Default Re: Logitech mouse response "absolutely terrible" in OS X?

Quote:
Originally Posted by kirkbross View Post
I have a Logitch MX Pro mouse from around 2009 and I love(d) it... I love all the buttons, the shape, weight and everything. With all my custom button assignments it has become integral to my PT and Melodyne universe.

However... and I'm not sure when it started... but I can't for the life of me get smooth, responsive scrolling. In particular, horizontal scrolling (shift + wheel). No matter how I set the settings, it's like the worst, choppy, non-responsive mouse movement. Truly frustrating.

I really, really, really miss being able to scroll up, down, left and right, smoothly. It should feel like a web page, but there is so much lag and dropped data that it baffles me.

Is this the mouse or OS X or PT11?

2008 Mac Pro
Mavericks 10.9.5
PT11
Your mouse is old and worn out; it's amazing the buttons are still working but I'll bet you're having issues with those and haven't really noticed it. Logitech stuff works just fine on any version of Mac provided you have the latest drivers. The buttons and such do wear out over time.
__________________
Jack
See profile for system details
iMac dead & retired as of 11/4/17

QAPLA!
Reply With Quote
  #7  
Old 10-12-2014, 11:02 AM
kirkbross's Avatar
kirkbross kirkbross is offline
Member
 
Join Date: Jul 2004
Location: Los Angeles
Posts: 347
Default Re: Logitech mouse response "absolutely terrible" in OS X?

Quote:
Originally Posted by musicman691 View Post
Your mouse is old and worn out; it's amazing the buttons are still working but I'll bet you're having issues with those and haven't really noticed it. Logitech stuff works just fine on any version of Mac provided you have the latest drivers. The buttons and such do wear out over time.
What I find odd is that 1) I do have the latest driver and 2) tracking an responsiveness is fine in other applications. That makes me think it's not hardware-related, but everyone's point that it's old is still true!

The first step is to test out an old analog mouse and see how it responds.
__________________
Pearlman Church Microphone > Great River MP-2NV > Warm Audio WA-76 > Apogee Symphony MK II 8x8+8MP > PT2018 on 2018 Mac Mini with 32GB of RAM running Mojave.
Reply With Quote
  #8  
Old 10-12-2014, 01:49 PM
musicman691 musicman691 is offline
Member
 
Join Date: Dec 2009
Location: The Soprano State (NJ)
Posts: 16,273
Default Re: Logitech mouse response "absolutely terrible" in OS X?

Quote:
Originally Posted by kirkbross View Post
What I find odd is that 1) I do have the latest driver and 2) tracking an responsiveness is fine in other applications. That makes me think it's not hardware-related, but everyone's point that it's old is still true!

The first step is to test out an old analog mouse and see how it responds.
Why not just spend the money (mice are inexpensive compared to the rest of what one spends on a daw and s/w) and get a new mouse? At best you have an old mouse that's intermittent and at worst it'll crap out on you when you least expect it to.
__________________
Jack
See profile for system details
iMac dead & retired as of 11/4/17

QAPLA!
Reply With Quote
  #9  
Old 10-12-2014, 07:13 PM
Brock Mixwell Brock Mixwell is offline
Member
 
Join Date: Jan 2013
Location: Perth
Posts: 54
Default Re: Logitech mouse response "absolutely terrible" in OS X?

You need to get this app for OSX to make mouse response acceptable IMHO.

http://smoothmouse.com/
Reply With Quote
  #10  
Old 10-14-2014, 07:36 PM
cwsand's Avatar
cwsand cwsand is offline
Moderator
 
Join Date: Feb 2006
Location: Nashville, TN
Posts: 3,181
Default Re: Logitech mouse response "absolutely terrible" in OS X?

FWIW, my MBP is up on a shelf as I use an external monitor for the main screen, but I was having similar issues with both a bluetooth mouse and a wireless Logitech mouse. I finally figured out that the MBP was too far away to get a good connection, so I bought a USB extension cable for the Logitech mouse, put the receiver on the end of it, and placed it right there next to the mousepad. Works perfectly now!
__________________
Help Us Help You



Chris
__________________________________________________
Focusrite Liquid Saffire 56
TCE Studio Konnekt 48
PreSonus Digimax LT
Gigabyte GA-Z170-HD3P / i7 6700K 4.1 GHz / 32GB Crucial DDR4
macOS High Sierra Version 10.13.6
Pro Tools HD 2019.6
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
hardware buttons for "preview", "capture" and "punch" evs Post - Surround - Video 1 12-06-2010 12:28 PM
TL Space - no Impulse Response library "installer" / can't install kirkbross 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 9 03-22-2010 08:07 AM
Faster Dialog Editing "setup tips, mouse,etc. needed" Erinugene Pro Tools TDM Systems (Mac) 17 01-25-2003 12:06 AM
Problem "apparently" finally solved; No more mouse freeze! dkrausz 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 2 07-15-2002 08:00 PM
Digidesign engineering's response to the HD "bass-lite" criticism is .... ngisedigid Pro Tools TDM Systems (Mac) 58 04-28-2002 10:01 PM


All times are GMT -7. The time now is 08:11 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com