Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Mixing > System 5

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-25-2019, 11:04 AM
MarcOFB MarcOFB is offline
Member
 
Join Date: Feb 2019
Location: Denmark
Posts: 43
Default MC524 PSU possibly dead

Hello Everybody!

I had my MC524 behave strangely last week. Audio would drop out and only return upon a reboot of the MC524. I then noticed that the little green LED (visible through the front vents) was blinking, and I was pretty sure normally it would be lighting up consistantly.

After a few days the unit then stopped passing audio, and made a loud “click” and then stopped working all together. As well as smelling like “hot electronics” from the back of the fan.

My local electrician (he has experience with Euphonix) pulled the Switchmode PSU out and told me this was probably faulty.

Has anyone tried anything similar? Perhaps a fix for the PSU exsists?





Sent from my iPhone using Tapatalk
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MC524 Monitor Board Activity LED is flickering Scott_Pilgrim System 5 1 02-25-2019 10:00 PM
Audio on only one channel from MC524 qtvaudio System 5 0 12-17-2018 10:38 PM
MC524 not passing audio on all channels qtvaudio System 5 1 12-04-2018 02:18 AM
MC524 not responding to serial qtvaudio System 5 6 12-04-2018 12:49 AM
MC524 Alternatives? audiobee System 5 3 08-26-2016 08:24 AM


All times are GMT -7. The time now is 12:13 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com