Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > AAX Plug-ins

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 08-30-2019, 12:18 PM
musicman691 musicman691 is offline
Member
 
Join Date: Dec 2009
Location: The Soprano State (NJ)
Posts: 16,644
Default McDSP site issues

Just got an email from McDSP about their Labor Day sale and amongst other things Futzbox and EC300 are on sale for $79. When I click on the 'buy now' button in the email a page comes up and then across the opt of the page is a windowlet saying:
Authentication Required
A username and password are being requested by http://www.retroplugins.com The site says "Restricted Area"
And it has a Cancel button and an OK button. If I hit Cancel it takes me to the product page. Thinking something is amiss in the email if I got to the McDsp straight from Firefox and navigate through to go to the product page for EC-300 I get the same message.

I'm a little shy about going through the purchase process with this happening. In the email there's a '?' where the product thumbnail would be. This usually means something is buggered at the website side.

Anybody else having issues?
__________________
Jack
See profile for system details
iMac dead & retired as of 11/4/17

QAPLA!
Reply With Quote
  #2  
Old 08-30-2019, 05:30 PM
s.d. finley s.d. finley is offline
Member
 
Join Date: May 2000
Location: Houston, TX. USA
Posts: 1,459
Default Re: McDSP site issues

I updated a McDSP plug in today actually, Analog Channel. I surrender an ilok asset and got a new asset no issues.
__________________
sdf

sugarhillstudios.com
Reply With Quote
  #3  
Old 08-31-2019, 05:15 AM
musicman691 musicman691 is offline
Member
 
Join Date: Dec 2009
Location: The Soprano State (NJ)
Posts: 16,644
Default Re: McDSP site issues

Quote:
Originally Posted by s.d. finley View Post
I updated a McDSP plug in today actually, Analog Channel. I surrender an ilok asset and got a new asset no issues.
Thanks.
What are you using for a browser? Using Firefox 46.0.1 on OSX 10.6.8. If I try with Safari 5.1.1 the front page graphics are scrambled but I don't get the security business I mentioned previously. If I Google retroplugins.com there come up a bunch of stuff that shows ties to the McDsp site. I wonder if it's some kind of security thing that FF isn't handling right?
__________________
Jack
See profile for system details
iMac dead & retired as of 11/4/17

QAPLA!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
McDSP V6.2 Plugins, PTHD 10, Win10 Issues Greg M AAX Plug-ins 14 08-11-2016 01:43 AM
FS: McDSP 6030 HD v5 & FutzBox Native v5 (for sale with permit from McDSP) Dusty Angel Buy & Sell 3 11-15-2013 08:00 AM
Web Site issues Touchwood Studios Pro Tools TDM Systems (Mac) 3 07-10-2009 07:38 PM
Site Check!! My New Site is up. Tell me what you think! English Jim 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) 13 02-03-2003 01:47 AM
Site Check! New SIte! Tell me what you think citi 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 1 02-02-2003 01:57 AM


All times are GMT -7. The time now is 05:05 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com