Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Mixing > Artist Series

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-23-2013, 10:30 AM
Herbieoz Herbieoz is offline
Member
 
Join Date: May 2009
Location: Earth
Posts: 78
Question ATTN JC. Eucon 2.7 + Artist Mix/Control via HUI

Hi JC,
you are a busy person so I will keep it brief. The parameters of my testing are below, and I hope this may help define the issue, but may also suggest what action might be appropriate for me to take to try and address the issue? (as before, I understand Eucon is the preferred communication protocol for Avid.)

• Mac 10.8.3;
• Protools 10.3.4 Native;
• Eucon 2.7 (build 87367);
• Tested with static IP and dynamic IP for artist units (using router not wireless) - no difference in test results;
• Artist Control screen shows the Frontmost application correctly, and changes when I move between apps;
• Finder soft keys are working from the Artist Control unit
• Your menubar "EuControl Settings" sees both Artist units are connected and seems to communicate correctly with them;
• Apps & Protocols non-functioning - Euphonix MIDI ports, Audio/MIDI setup, Logic Pro 9.1.8, Protools 10.3.4.

Here is where some symptoms arise that may prompt an idea or solution.
Context:
• Logic and Protools have been added to the Eucon system preference Pane.
• Logic set to HUI Ports 1 - 4
• Protools set to HUI Ports 5 - 8
• Live set to use Ports 9 - 12
• Regardless of how many ports are created in the Eucon system pref pane, Audio MIDI setup only thinks there are 4, and the "Device is online" button is unchecked and greyed out, and "remove device" is also greyed out.

Regardless of whether I set Protools to use ports 1-4, 5-8, or 9-12 etc in the Eucon system prefs pane, MIDI setup app only sees ports 1-4, and only 1-4 show up in Protools > Setup > Peripherals > MIDI Controllers > receive and send. Using ports 1 - 4 does not work - they seem to be ghosts. Ports 5 and up do not appear anywhere apart from in the Eucon Sys Prefs Pane.

The issue: While the Artist Control window does track which is the foremost app, all faders, transport etc, do not light up or communicate in any way. The Artist Mix is dead as well. This suggests logically that there is no MIDI communication happening through your software and the ports are not being seen by the system at all apart from the Eucon system pane thinking they should be there.

Oh - and in case there were any conflicts I had removed all drivers from /Library/Audio/MIDI Drivers except EuphonixMIDI.plugin.

I know your first priority is a stable and functioning Eucon software. If what I have outlined causes a synaptic connection in someone and a solution is presented, very happy to try anything.

Thanks,
Herbie.
Reply With Quote
  #2  
Old 03-23-2013, 08:21 PM
Herbieoz Herbieoz is offline
Member
 
Join Date: May 2009
Location: Earth
Posts: 78
Default Re: ATTN JC. Eucon 2.7 + Artist Mix/Control via HUI

Hi, an update.
After removing lots of eucon / euphonix files left by the official uninstaller and doing a fresh install (after permissions fix etc) I did indeed find the Euphonix MIDI channels to be ghosts. Apps can be added to the Eucon sys prefs pane but there is no appearance of Euphonix MIDI channels anywhere across the system or apps.

On my systems at least, The 2.7 installer is not writing / creating / updating whatever files are needed to make your software function properly.
hope that helps and thanks,
Herbie
Reply With Quote
  #3  
Old 04-26-2014, 10:12 AM
joren joren is offline
Member
 
Join Date: Feb 2014
Location: Gent, Belgium
Posts: 20
Default Re: ATTN JC. Eucon 2.7 + Artist Mix/Control via HUI

Thought I'd revive this old thread because I have the exact same problem along with some others.
You can put apps in the list in system preferences > EUCON,
but only one in the list will work because only ports 1-4 can be used.
All other ports never appear in any application, nor Audio Midi Setup.

Has anyone been able to fix this?
Why did this not get fixed in recent driver updates.
__________________
Mac Pro 8 core OSX Mojave
PT10HD, PT11HD, PT12HD Native
3x Avid Artist Mix, Euphonix MC Transport, PT|Control
Reply With Quote
  #4  
Old 05-28-2014, 04:11 PM
joren joren is offline
Member
 
Join Date: Feb 2014
Location: Gent, Belgium
Posts: 20
Default Re: ATTN JC. Eucon 2.7 + Artist Mix/Control via HUI

Finally found a bug in eucontrol that provides sort of a workaround.

Add one application to the list in system preferences > Eucon, ports 1-4
Have that application open all the time while you work in mackie controlled apps.
Lock surface to that application in the Eucontrol Settings.
It will lock Eucon to ports 1-4.
Assign all your other Mackie enabled apps to ports 1-4.
(or the ones where Eucon won't work, §#3&##)
Application switching is a bit jumpy but seems to work here.

All these issues, as well as stability, should really be adressed!!!
Everywhere you go, you see trouble with Eucon.
Come on, Avid. You can do it.
__________________
Mac Pro 8 core OSX Mojave
PT10HD, PT11HD, PT12HD Native
3x Avid Artist Mix, Euphonix MC Transport, PT|Control
Reply With Quote
  #5  
Old 12-10-2014, 01:40 AM
TabSel TabSel is offline
Member
 
Join Date: Dec 2014
Location: Penzing Germany
Posts: 4
Default Re: ATTN JC. Eucon 2.7 + Artist Mix/Control via HUI

Same issues here, can not get it to work. Only Euphonix MIDI ports 1-4 available, no matter what I try.

Will there be a bug fix update addressing this?
Reply With Quote
  #6  
Old 01-09-2015, 03:14 AM
Herbieoz Herbieoz is offline
Member
 
Join Date: May 2009
Location: Earth
Posts: 78
Default Re: ATTN JC. Eucon 2.7 + Artist Mix/Control via HUI

Hi. Mac OS 10.8.5. Eucon 3.2.1 Can't get more than 4 ports working and none working under HUI, 1-4 working under Mackie Control only. Pref pane will see all ports, say they are created, but only 1-4 appear in the system or any apps. Is there anyone who is able to get more than 4 ports working in Mac OS please? I would like to ask some quick questions. Many thanks.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Eucon 3 - Artist Control not connecting to PT Trazan Artist Series 50 04-04-2016 04:14 AM
Eucon, Artist Control and mouse. vinnyburns Artist Series 6 04-16-2014 07:43 PM
Artist Control not working with Eucon 3 on OS X 10.8.4 Jerry Woolsey Artist Series 1 06-24-2013 02:21 AM
Artist Control check EUCON version on page 74 Audioartist Artist Series 1 04-18-2013 11:29 AM
Artist Mix freezed , Eucon 2.62 peterle Artist Series 4 09-11-2012 09:32 AM


All times are GMT -7. The time now is 01:02 PM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com