Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Pro Tools Software > Pro Tools 2020

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 05-04-2020, 08:12 AM
lesbrunn's Avatar
lesbrunn lesbrunn is offline
Member
 
Join Date: Feb 2002
Location: Accra, Ghana
Posts: 737
Default After A Few Months, What Do You Now Feel About PT 2020?

Hey guys,

My initial feelings were super, but I'm not too sure now.

In 2019.12 my video engine did not work. A fellow DUCer who had had similar problems pointed me to 2019.6, which solved my problem. When i updated to 2020 my video engine problem was solved. (I know other users have complained about video engine problems in 2020) It seemed to me that CPU usage had improved in 2020. However, I realized that my processor upgrade had coincided with the update so I cannot be sure if it's PT or the new processor that is making things better.

Definitely, folder tracks are a huge plus for me despite initial difficulties.

I'm interested in knowing what other users feel/think about 2020 in general. And specifically about CPU usage and Playback Engine compared with 2019. Bugs too! Thanks!
__________________
X99 | i7 5960x @4.6GHz | 64GB GSkill DDR4 | Nvidia GTX 950 | Samsung 950 Pro NVMe 256GB | Samsung SM961 NVMe 1TB | Samsung 850 EVO 1TB | Samsung MZ7PD256 SSD 256GB | Kingston 120GB SSD | WD Black 1TB x2 | G-Drive 4TB x2 | WD Elements 4TB | Audient ID14 | PT2020.5 | Windows 10 Pro

Last edited by lesbrunn; 05-04-2020 at 10:41 AM.
Reply With Quote
  #2  
Old 05-04-2020, 08:34 AM
Emi's Avatar
Emi Emi is offline
Member
 
Join Date: Dec 2017
Location: Madrid. Spain
Posts: 319
Default Re: After A Few Months, What Do You Now Feel About PT 2020?

It feels solid to me. I even stopped using turbo boost switch and run sessions at 256 buffer size with the cpu at more than 60% without crushing...

In recording I can go down to 64 (and even 32) buffer and can use some reverbs or maybe some compression or eq without crashing...thats' something.
__________________
Mac Mini late 2012 i5 | Mac OS Catalina 10.15 | Motu 16A | Motu 828ES | Pro Tools 2020.5 Native
Reply With Quote
  #3  
Old 05-04-2020, 08:47 AM
lesbrunn's Avatar
lesbrunn lesbrunn is offline
Member
 
Join Date: Feb 2002
Location: Accra, Ghana
Posts: 737
Default Re: After A Few Months, What Do You Now Feel About PT 2020?

Quote:
Originally Posted by Emi View Post
It feels solid to me. I even stopped using turbo boost switch and run sessions at 256 buffer size with the cpu at more than 60% without crushing...

In recording I can go down to 64 (and even 32) buffer and can use some reverbs or maybe some compression or eq without crashing...thats' something.
Yes. Thanks for your input. That was exactly the way I felt initially. However, you are a Mac user, and the dynamics are somewhat different? Nonetheless, your response is encouraging. I seem to be getting fewer crashes, but I can't be absolutely certain.
__________________
X99 | i7 5960x @4.6GHz | 64GB GSkill DDR4 | Nvidia GTX 950 | Samsung 950 Pro NVMe 256GB | Samsung SM961 NVMe 1TB | Samsung 850 EVO 1TB | Samsung MZ7PD256 SSD 256GB | Kingston 120GB SSD | WD Black 1TB x2 | G-Drive 4TB x2 | WD Elements 4TB | Audient ID14 | PT2020.5 | Windows 10 Pro
Reply With Quote
  #4  
Old 05-04-2020, 08:52 AM
lesbrunn's Avatar
lesbrunn lesbrunn is offline
Member
 
Join Date: Feb 2002
Location: Accra, Ghana
Posts: 737
Default Re: After A Few Months, What Do You Now Feel About PT 2020?

Answers to this question will be interesting, because many users will say this is the buggiest version ever...But PT has always been like this. Every user's experience is different depending on hardware. I do not think this is acceptable.
__________________
X99 | i7 5960x @4.6GHz | 64GB GSkill DDR4 | Nvidia GTX 950 | Samsung 950 Pro NVMe 256GB | Samsung SM961 NVMe 1TB | Samsung 850 EVO 1TB | Samsung MZ7PD256 SSD 256GB | Kingston 120GB SSD | WD Black 1TB x2 | G-Drive 4TB x2 | WD Elements 4TB | Audient ID14 | PT2020.5 | Windows 10 Pro
Reply With Quote
  #5  
Old 05-04-2020, 09:24 AM
danyg danyg is offline
Member
 
Join Date: Sep 2013
Location: Belgium
Posts: 195
Default Re: After A Few Months, What Do You Now Feel About PT 2020?

happy here, running solid
__________________
Mac Pro 12 core 3.46Ghz - 64 Gb ram - SSD 500 Gb - HD1 2T - HD2 2T - OS 10.10. - Mac Book Pro retina- OS 10.10. - SSL Alphalink convertor - Pro Tools 12 native - SSL Matrix console - Logic Pro X
Reply With Quote
  #6  
Old 05-04-2020, 09:42 AM
lesbrunn's Avatar
lesbrunn lesbrunn is offline
Member
 
Join Date: Feb 2002
Location: Accra, Ghana
Posts: 737
Default Re: After A Few Months, What Do You Now Feel About PT 2020?

Quote:
Originally Posted by danyg View Post
happy here, running solid
OK.
__________________
X99 | i7 5960x @4.6GHz | 64GB GSkill DDR4 | Nvidia GTX 950 | Samsung 950 Pro NVMe 256GB | Samsung SM961 NVMe 1TB | Samsung 850 EVO 1TB | Samsung MZ7PD256 SSD 256GB | Kingston 120GB SSD | WD Black 1TB x2 | G-Drive 4TB x2 | WD Elements 4TB | Audient ID14 | PT2020.5 | Windows 10 Pro
Reply With Quote
  #7  
Old 05-04-2020, 10:51 AM
Rectifried Rectifried is offline
Member
 
Join Date: Apr 2000
Location: Los Angeles
Posts: 389
Default Re: After A Few Months, What Do You Now Feel About PT 2020?

Folders are cool.
still -9xxx errors at 30% cpu
frozen stuttering thing sometimes


still midi assignment bug
feels the same.


love to say it was better
but going to save that.. for when it is
__________________
Hal Cragin On the DUC Since The Year 2000 AD

PT 2020.5, macpro 12 core trashcan 64 gig ram, MBP i7 9,1 16gig ram OS 10.12.3.. TBlt UA Apollo16 SSD's [samsung],
Reply With Quote
  #8  
Old 05-04-2020, 10:57 AM
lesbrunn's Avatar
lesbrunn lesbrunn is offline
Member
 
Join Date: Feb 2002
Location: Accra, Ghana
Posts: 737
Default Re: After A Few Months, What Do You Now Feel About PT 2020?

Quote:
Originally Posted by Rectifried View Post
Folders are cool.
still -9xxx errors at 30% cpu
frozen stuttering thing sometimes


still midi assignment bug
feels the same.


love to say it was better
but going to save that.. for when it is
Had problems when I first updated, and had to uninstall, clean up and do a clean new install. That worked. I'm aware, of course, that many old bugs are still present. That's Avid's style...Don't fix old bugs, and implement 'new' features 10 years after every DAW has done so.
__________________
X99 | i7 5960x @4.6GHz | 64GB GSkill DDR4 | Nvidia GTX 950 | Samsung 950 Pro NVMe 256GB | Samsung SM961 NVMe 1TB | Samsung 850 EVO 1TB | Samsung MZ7PD256 SSD 256GB | Kingston 120GB SSD | WD Black 1TB x2 | G-Drive 4TB x2 | WD Elements 4TB | Audient ID14 | PT2020.5 | Windows 10 Pro
Reply With Quote
  #9  
Old 05-04-2020, 11:12 AM
wwittman wwittman is offline
Member
 
Join Date: May 2000
Location: Westchester, NY, USA
Posts: 515
Default Re: After A Few Months, What Do You Now Feel About PT 2020?

It’s okay

It about the same degree of stable as 2019.12
And I still don’t give a toss about folder tracks.
__________________
William Wittman
Producer/Engineer
(Cyndi Lauper, Joan Osborne, The Fixx, The Outfield, Hooters...Kinky Boots!)
Reply With Quote
  #10  
Old 05-04-2020, 01:07 PM
TOM@METRO's Avatar
TOM@METRO TOM@METRO is offline
Moderator
 
Join Date: Apr 2006
Location: Los Angeles
Posts: 17,153
Default Re: After A Few Months, What Do You Now Feel About PT 2020?

No complaints here. Working well (HDX, Windows 10.)
__________________
~ tom thomas

Formerly hobotom

Pro Tools Ultimate 2020.5 HDX
HD Omni and 192 I/Os
Windows 10
Intel Hexcore i7
All Samsung Pro SSDs
Ampex MM1200 2" 24 trk tape
Outboard: UREI, Eventide, Lexicon, Yamaha, TC Electronics, Orban, ART, EchoAudio, Dolby, Hughes, API, Neve, Audio Arts, BBE, Aphex, Berringer, MOTU, dbx, Allison, etc.
Plug-ins: Too many to talk about.

www.metrostudios.com
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Pro Tools (2020.3) on MacBook Air 2020 compatibility pellekuipers Pro Tools 2020 1 04-04-2020 08:01 AM
New Avid Link 2020.1 - launched today 1/16/2020 marianna Licensing & Accounts 8 01-16-2020 11:43 PM
Almost Two Months gonsdeejay Pro Tools 12 2 08-16-2017 04:23 PM
It's been 3 months MEAT Pro Tools TDM Systems (Win) 40 06-09-2009 03:18 PM
PTLE 5.0.1 : a month, 2 months, 6 months, a year? Kickin.da.speaker 003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) 3 05-11-2000 06:51 AM


All times are GMT -7. The time now is 08:25 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com