View Single Post
Old 06-16-2015, 02:34 PM
musictycoon musictycoon is offline
Join Date: Sep 2008
Location: Atlanta, GA
Posts: 20
Default Re: Keyboard shortcuts not working with new iMac

Originally Posted by PD-John View Post
Have you clicked "Use all F1, F2, etc. keys as standard function keys" in System Preferences > Keyboard?
NICE FIX MAN! That was my EXACT problem and was
d r i v i n g m e Fn C r a z y! I like to edit fast and this was having me twitching and on the verge of tears whilst inexplicably gigle-crying. So... the FULL FIX for me was this:
1. Fully disable dashboard function.
Type or paste the following exactly into the Terminal window:

defaults write mcx-disabled -boolean YES

Next, kill the currently running Dashboard by killing the Dock (the Dock will reload itself, don’t worry):

killall Dock

That’s it, now Dashboard is completely disabled. Hit F12 or swipe around in Mission Control or Spaces, and nothing will happen.

2. Un-check all F key functions in keyboard shortcuts in 'keyboard>shortcuts>keyboard (there are 10 of them).
3. Check the "Use all F1, F2 etc. keys as standard function keys".

BadaBoom Fixed and able to use F keys as tool selectors. Yay.

Thanks guys, hope my full explanation helped as well.
Reply With Quote