View Single Post
  #1  
Old 12-05-2017, 04:16 AM
Ed@bersey.com Ed@bersey.com is offline
Member
 
Join Date: Mar 2012
Location: Shaftesbury, UK
Posts: 9
Default PT 12.8.2 Virtual Instrument latency

Hi All

I'm a long time PT user and know it well but have only just really started using VIs in anger. I've always experienced latency when monitoring VIs but worked around it by playing notes in hearing my keyboards own sound and recording the midi, then playing back the midi to the required Vi and getting what I want. However now I am working with better artists and the work arounds won't wash anymore. I have to be able to have good VI live playback while recording with sub 10ms latency at the fingers.

What is very annoying is that I recently installed Logic and had a dabble and I don't seem to have any delay issues when using VIs in there. I've not tested it on a big session, but it seems so much quicker. I LOVE PT and would be very reluctant to do projects in Logic just so I can reduce latency - there must be a way - please help.

I think I have a really strong setup in terms of hardware, yet I can't seem to configure things to solve this problem. My typical scenario is that I work on a session with an artist - tracking say drums (8 mics) , guitar bass, and may end up with 20 or so tracks all using various plugins. THEN they say oh lets add some cool keys/synth so out come the VIs at which point I can't really run the session at buffers=32 as I'll get too much crackle due to the load of existing tracks and plugs. I can maybe get away with buffers= 64 or 128, but at these setting I get too much latency on the keys before hearing the instrument.

I happen to use UAD interface hardware and use lots of their plugs as well as host based ones, I'd have thought because their plugs run in their external DSP that this would help me but I still have the issue.

I could just always track keys first - but life and creativity isnt always like that! How do you guys get around this issue... and don't say use Logic!

Some of my instruments are pretty heavy on CPU but even the light ones are too slow. Help.

Setup:
Mac Pro - 12 core 2.7Ghz
System disk 1 TB PCIE SSD with OS and PT installed
Projects disk 1 TB external Thunderbolt SSD
RAM 32GB
Interface: 2 x UAD Apollo 8p
Keyboard Controller: Akai Professional 49 (USB midi)

PT Payback Engine settings
H/W Buffer: 32-128 as described above
Host Engine: Ignore Errors during playback TICKED
Minimize additional latency TICKED
Dynamic Plug in Processing TICKED
Disk Playback Cache size: 10GB

In Options menu
Delay compensation is TICKED
Low latency monitoring NOT ticked
Reply With Quote