View Single Post
  #4  
Old 12-05-2012, 05:05 PM
Buttonjaw Buttonjaw is offline
Member
 
Join Date: Dec 2012
Location: Portland, OR
Posts: 14
Default

My good friend says I should buy an Mbox Pro 3 which comes with Pro Tools 10 (with a free upgrade to PT11 when it comes out). But according to the Avid knowledge Base i need Snow Leopard to run PT10 and I can only run 10.5.8 on my dual G5. Is that right?
Reply With Quote