Avid Pro Audio Community

Avid Pro Audio Community

How to Join & Post  •  Community Terms of Use  •  Help Us Help You

Knowledge Base Search  •  Community Search  •  Learn & Support


Avid Home Page

Go Back   Avid Pro Audio Community > Search Forums

Showing results 1 to 6 of 6
Search took 0.00 seconds.
Search: Posts Made By: djdubceast49
Forum: FireWire and USB Audio Interfaces (Mac) 10-05-2019, 02:17 PM
Replies: 7
Views: 2,964
Posted By djdubceast49
Re: Mbox family driver support for Mac OS Catalina

I just checked out the avid end of life dates and the mbox 3rd generation has just ended its support on 8/30/2019. This sucks. I wil have to buy another interface. :( but I can keep this for this...
Forum: FireWire and USB Audio Interfaces (Mac) 10-05-2019, 01:15 PM
Replies: 7
Views: 2,964
Posted By djdubceast49
Mbox family driver support for Mac OS Catalina

Will there be updated drivers for Mac OS Catalina? This is a very good product and still is one of the best audio interfaces.
Forum: FireWire and USB Audio Interfaces (Mac) 10-05-2019, 01:13 PM
Replies: 2
Views: 2,710
Posted By djdubceast49
Re: Mbox3 family new drivers?

Yes it works with Mac OS Mojave. Not issues at all.
Forum: FireWire and USB Audio Interfaces (Mac) 10-30-2018, 12:06 AM
Replies: 1
Views: 3,875
Posted By djdubceast49
Re: Mbox 3 does not work after exporting audio from cubase elements 9.5

Problem solved. It was Cubase that had the error.:D
Forum: FireWire and USB Audio Interfaces (Mac) 10-30-2018, 12:02 AM
Replies: 0
Views: 2,675
Posted By djdubceast49
64 bit drivers for mbox 3 family

Will there be an update for the Mbox 3 family? I installed, opened and it said it will soon need to be compatible with the new 64 bit standard for macOS :confused:
Forum: FireWire and USB Audio Interfaces (Mac) 05-26-2018, 10:37 PM
Replies: 1
Views: 3,875
Posted By djdubceast49
Mbox 3 does not work after exporting audio from cubase elements 9.5

Every time I export audio, the mbox does not work. I have to unplug the mbox and replug it back in order to get it to work. I have optimized the system and everything. I even tried it with just the...
Showing results 1 to 6 of 6

 
Forum Jump

All times are GMT -7. The time now is 09:45 AM.


Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com