Avid Pro Audio Community

Avid Pro Audio Community (http://duc.avid.com/index.php)
-   003, Mbox 2, Digi 002, original Mbox, Digi 001 (Mac) (http://duc.avid.com/forumdisplay.php?f=15)
-   -   Yosemite and Mbox 2 Drivers (Good news so far) (http://duc.avid.com/showthread.php?t=356951)

thegame15 07-26-2014 05:59 PM

Yosemite and Mbox 2 Drivers (Good news so far)
 
1 Attachment(s)
Im a Macbook user who has a Intel Core 2 Duo system, and currently use Mavericks as my main OS. I've been granted access to the Yosemite Public Beta, and after a couple of hours of testing on external HD this morning I can confirm that the current Mbox 2 10.3.3 drivers work the same way as they do on Mavericks (I'm currently on 10.9.2) with the use of a USB hub. I tested it with Logic, Safari Playback via Youtube, and iTunes. Everything worked as my current Mavericks setup does.

I can also say that I've had success with the Mbox 2 directly plugged into my USB ports of my Mid 2010 Macbook Pro, but that it was spotty very spotty. After installing the drivers and plugging it in and booting up Safari (only thing I was able to get sound out of) and testing a youtube clip the sound worked right away but made a few stutters before perfect playback, that could also be because I've booted the OS from USB.

Then I tried pulling the USB out and plugging it back in, and after the system recognized that the Mbox 2 was attached, it wouldn't continue playback of sound like it did when the system first started, but if I refreshed the webpage in Safari the playback would start again, but only after I refreshed the page.

As updates for OS X 10.10 Yosemite Public Beta come along I will continue to test these drivers out in the same capacity. I don't own current Protools software (10 & 11), so I can't test this or answer anything about that.

Just thought I would share my experience, and hope that when the final software is released this Fall that everything will work the way it should (As it currently stands). I'm someone who likes to be on the newest OS whenever possible, but if something works for you and you have full compatibility don't change anything.

thegame15 10-19-2014 07:31 PM

Re: Yosemite and Mbox 2 Drivers (Good news so far)
 
1 Attachment(s)
Sorry I've been a lil busy since my last post, and never really got around to posting my results from the public beta updates until today.

All Yosemite public betas (1-6) all worked the same way as they do on Mavericks (Intel Core 2 Duo), Mbox 2 outputs no sound when connected directly to USB ports, only on the the first beta did I actually get sound sound directly connected, and that was very spotty. The only way to get sound was using a USB hub as per the directions of Avid for people of Intel Core 2 Duo systems like myself.

So today I was finally able to update my Yosemite Public Beta thumbdrive to the full retail version of Yosemite, it took several hours mostly because it's a USB 2.0 but not the less. The result was the same as the Public Beta, sound output worked only when Mbox 2 was connected to a USB Hub just like Mavericks. A side note Mbox 2 sound works Mavericks 10.9.5 w/hub which is currently not supported/approved by Avid.

The only reasons why I was testing Yosemite was to make sure the drivers for the Mbox 2 would work. I used to use Protools 7 and 8 before it wasn't supported properly on Lion and up, I will be doing a fresh install on my main drive once I've backed up everything I've needed, but for those who wanted to take the plunge these are the results which have been positive so far.

Im a person who always wants to jump on the newest thing, but I always do my own personal research/testing prior to doing it, but this expression always remains true "If it ain't broke, don't fix it".

Best of luck to those who make the jump to Yosemite :)

aba_spidey 10-20-2014 04:07 AM

Re: Yosemite and Mbox 2 Drivers (Good news so far)
 
I have an Mbox 2 and just installed OS X Yosemite on my Mac Mini. Unfortunately the Mbox 2 isn't working properly since I upgraded to Yosemite. Need some help please..I already tried downloading the latest driver for Mbox 2 from the Avid website but the Mbox 2 is still not working.

LAXerton 10-20-2014 09:21 AM

Re: Yosemite and Mbox 2 Drivers (Good news so far)
 
Same here. Recently updated to Yosemite and my Mbox2 Micro isn't even recognized by the system. I can't 'see' it. I'll have to downgrade to Mavericks 10.9.4 (not even 10.9.5) or Mountain Lion, this is unfortunate. C'mon Avid help us out and upgrade your drivers! :D

backporch 10-20-2014 04:15 PM

bad news is... good news?
 
Wasn't working for me, either.... new Mac Pro running Yosemite and Mbox Mini 2.

Weirdly, it must have done something in the background (auto updating drivers?) while I was typing this... because it's working now!

The green light wasn't coming on, and now it's on and my monitors are working.

(I did unplug and replug the USB cable a couple of times, so maybe that triggered it.)

thegame15 10-20-2014 07:05 PM

Re: Yosemite and Mbox 2 Drivers (Good news so far)
 
Well I did some more testing last night, and today after work. Because I was running the new OS via USB 2.0 thumb drive, I've decided to copy it over to an external hard drive and now were at full speed.

So today I uninstalled the Mbox 2 driver 10.3.3 manually, and then installed the new 10.3.9 that was released earlier this month, unfortunately that killed all connections I had with the Mbox, it would say unable to connect to Mbox 2, and all the lights would be super dim. I did this about 4 times with no results.

I decided to take a crack at the 10.3.3 drivers again same approach install/uninstalled about 4 times, and bam it all worked again with no issues. I noted that it took about 30 seconds to register it was connected, but after unplug/replug it worked instantly.

Something else I noticed between the drivers that the 10.3.9 drivers doesn't install com.digi.plist like 10.3.3 does, so maybe that could be an issue who knows.

10.3.9 appears to be useless on Yosemite, while 10.3.3 seems to work at least for me. I'm also using the 10.3.3 drivers on Mavericks 10.9.5 from all my tests.

As i've state previously I'm using one of the Core 2 Duo systems that apparently just doesn't want to work without a hub for some odd reasons. So it may sound stupid, but have you guys tried using a hub? If so what were your results?

orchetect 10-21-2014 04:56 PM

Re: Yosemite and Mbox 2 Drivers (Good news so far)
 
Thanks for the update. I too have an Mbox 2 mini with the 10.3.3 drivers installed, then upgraded to Yosemite and the device disappeared - no green LED light, "Unable to connect to Mbox 2" in the preference panel.

I will tinker with the 10.3.3 driver like you suggest and see if I can coax it into working again.

Cheers

EDIT: Aha! Success! (For Now)

Here's what I did to get the MBox 2 mini to work:

1) Manually uninstalled the driver components (delete, then empty trash):
• /System/library/extensions/DigidesignMbox2.kext
• /System/library/extensions/DigidesignMbox2Boot.kext
• /Library/Audio/MIDI Drivers/DigidesignMbox2MIDI.plugin
• /Library/Startupitems/Digidesign Mbox2
• /Library/Startupitems/DigidesignLoader

2) Opened System Preferences, right-clicked "Digidesign MBox 2" icon, selected "Remove "Digidesign MBox 2" Preference Pane"

3) Rebooted

4) Installed Mbox 2 Driver 10.3.3. After, the computer rebooted.

5) Switched the physical USB port the MBox was connected to, then after a few seconds the green LED came on and it's working normally now.

Buccanears 10-21-2014 07:52 PM

Re: Yosemite and Mbox 2 Drivers (Good news so far)
 
Nice sleuthing peeps!

stephensmattlee 10-23-2014 01:08 AM

Re: Yosemite and Mbox 2 Drivers (Good news so far)
 
Wow, you my friend are a life saver, followed through your steps and also got my loyal old Mbox 2 Mini light up and working on a 2014 retina MacBook Pro running Yosemite ☺️

tfd543 10-23-2014 01:52 PM

Re: Yosemite and Mbox 2 Drivers (Good news so far)
 
It works also for mbox 2, however I always need to detach the physical USB every time I start up my mac. It wont recognize the mbox during start-up. Its a pity, but better than nothing so far.. This is tried with version 10.3.3. I wonder if the problem persists with 10.3.9..


All times are GMT -7. The time now is 10:07 AM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com