Avid Pro Audio Community

Avid Pro Audio Community (http://duc.avid.com/index.php)
-   FireWire and USB Audio Interfaces (Win) (http://duc.avid.com/forumdisplay.php?f=19)
-   -   Looking to replace my Mbox Pro 3 (http://duc.avid.com/showthread.php?t=407480)

PastaSource 12-07-2019 06:58 AM

Looking to replace my Mbox Pro 3
 
I bought the Mbox Pro 3 earlier this year second hand, it really looked quite amazing, and did everything I needed it too.
...Unfortunately as most of you know, Windows and the Mbox Pro 3 really don't get along, I've tried so many different things to get this thing to be stable, but it's just a battle I'm not gonna win.
I've been trying to find an audio interface which will fit the needs I thought the Mbox would satisfy.
At least two inputs, love the mono button to check my mixes, and the input meters on the front are so helpful for when I'm recording a video or something, so I know I'm not clipping with a quick glance.
I really am struggling to find something at least somewhat similar to the Mbox, I thought maybe I could get a regular interface, and somehow have an external audio meter for my inputs, but I think that might be a bit of a pipe dream on a budget haha.
Any advice would be greatly appreciated!

Ben Jenssen 12-07-2019 10:34 AM

Re: Looking to replace my Mbox Pro 3
 
Hi. Welcome to the forum, the DUC. (It used to be known as the Digidesign User Conference, a long time ago. Hence the duck in the top left corner.)

I think you need to provide a little more info if you are to get any useful input. Like:
Your PC. OS? Specs, what type of connections does it have?
Do you use Pro Tools or other software?
What type of work do you use it for?
Budget, more specific?

What exactly is not working for you now?

Also, have a look here:
Help Us Help You

albee1952 12-07-2019 01:18 PM

Re: Looking to replace my Mbox Pro 3
 
I had no issues running an Mbox 2 PRO on Windows 7 or Windows 10, so I can't imagine why the Mbox 3 should have troubles(other than an incompatible motherboard or FW controller which isn't the fault of the Mbox). Assuming you have a compatible computer and FW controller, a used 003 rack can be a great choice(I paid $89 plus tax for mine:D). Moving to a USB interface gives dozens of options with Focusrite(at the budget end), RME(at the expensive end) and MOTU filling in between. I can't recommend anything from M-Audio and a friend had no luck with Audient on his Windows 10 rig.

I would dig into trying to get the Mbox to work before dropping more money. Things to try:
1-On all Windows systems, set Windows>Sound Properties to use the on-board sound card as the "Default Playback Device"
2-Figure out what FW controller you have. TI are the preferred brand. In the past, VIA controllers were usually a show-stopper(but its working here on Windows 10 with my 003 rack)
3-Sometimes changing the FW driver can make or break. Avid recommends the Legacy driver, but that never worked here. The TI Compliant driver does.
4-Always(as in ALWAYS) install Pro Tools software using the Run as Admin option(right-click on the Setup icon)


All times are GMT -7. The time now is 10:06 PM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com