Avid Pro Audio Community

Avid Pro Audio Community (http://duc.avid.com/index.php)
-   Pro Tools TDM Systems (Mac) (http://duc.avid.com/forumdisplay.php?f=11)
-   -   Midi notes completely disappearing ... including all backups! (http://duc.avid.com/showthread.php?t=247877)

meech 06-10-2009 08:46 PM

Midi notes completely disappearing ... including all backups!
 
I was working on a session, cutting parts on instrument tracks (I had several up). The regions were absolutely there with plenty of notes within them ... for several hours. Time Machine did two backups, Pro Tools created plenty of backup sessions.

I closed the session and opened another to listen to a track, and went back to the session I was working on. On two of the tracks, the midi regions were still there but were completely blank! On one of those tracks, the very first note still remained but that's all.

I'm 100% positive that the notes were there and 100% positive that they aren't any longer ... they weren't bizarrely transposed out of view (my zoom toggle setting would reveal them), the midi tracks were assigned to the correct plugins.

:eek:
Now the crazy thing is ... every single backup of the session file shows the same thing! The notes were there at 7:15 when I went into the other session. When I came back they were gone. All the backups Pro Tools made (up to 2 hours earlier) showed the same thing ... The midi regions were there, but containing no notes (except for the one). It is the same thing with restored time machine backups. It's like the midi was erased from the session and simultaneously erased from two dozen backup sessions on two different hard drives! :confused: I called Digi tech support and emailed them the session (and a backup) and their computer also showed that the midi was missing (the sessions files were somehow changed, it wasn't PT on my computer reading the sessions funny).

So the midi notes are almost certainly gone for good, but does anyone have any ideas on how to recover the session files (when you save a session, does it write over the existing file, or would the previous version be recoverable if I bought DiskWarrior)? Does anyone have any idea what causes this problem?

I had several virtual instruments open in the session ... one omnisphere, one ivory, one Kontakt 2 player, one minimonsta, and a Vienna Ensemble with 5 or so patches loaded. Tech support told me that Digi doesn't recommend used Time Machine because it can cause archiving issues. I have never had this problem after using time machine for probably a year. What I don't normally use however, is Kontant 2 player and Vienna Ensemble at the same time. So maybe those plugins (or just VE) were acting strange in conjunction with Time Machine? Kontakt 2 player is awful with Leopard ... taking 30 seconds to save a session, so I know it doesn't perform well, but I use it fairly regularly without incident so I would suspect Vienna Ensemble.

My specs are
Mac Pro 8 core 2.8 ghz xeon
6 gb ram
Mac OS 10.5.6
Pro Tools HD 8.0cs2

I tried uninstalling and reinstalling Pro Tools (updated to cs3, i couldn't find cs2) to see if the midi would reappear (it didn't). But now I'm trying to see if I can recreate the problem but maybe it won't happen with cs3. I also deleted prefs and repaired permissions but of course the notes are gone for certain...

So I know this is a lot of information and even Digi's tech support on the phone couldn't find an answer ... but if anyone can help please don't hesitate! And if you know whether a data recovery program could help please tell me :-)

BGMusic 06-10-2009 08:53 PM

Re: Midi notes completely disappearing ... including all backups!
 
Exactly this was happening to me as well in LE 8.0 cs2 and they claiming it related to unsupported plugins. The only work around I could find was to save as whenever I did a lot of midi editing. It seems to have stopped. Could have been related to Kontakt 3. But for all midi of a given track to disappear in all backups?????

DigiTechSupt 06-11-2009 10:03 AM

Re: Midi notes completely disappearing ... including all backups!
 
Quote:

one Kontakt 2 player
Quote:

Could have been related to Kontakt 3
Neither of these are compatible with Pro Tools 8 and could be the cause of your problems. Having incompatible plug-ins installed can cause all sorts of unpredictable behavior.

It's possible the corruption occurred early on, but did not exhibit itself in the session until later on - which would explain why the backups are corrupted as well. What can trigger this is cached plug-in or other data. The 'state' of a session is saved, but the cached data (preferences, etc.) can change - which is likely what happened here. When you reopen the session, the cached data interacts differently because of changes in the cache.

I don't know there's much that can be done in this case. I would definitely go through your plug-ins and remove any that are known incompatible or questionable, then trash prefs and restart. Since the sessions themselves have become corrupted, there's no real way to recover the corrupted data, unfortunately.

BGMusic 06-11-2009 11:13 AM

Re: Midi notes completely disappearing ... including all backups!
 
Yep the problem went away when I removed Kontakt. It's a shame though, because Structure is a poor substitute (a topic for another thread).

So digi, I suppose what was happening was that the data appeared to be in the session, but instead was merely cached, which got dumped when the session was closed. It was never actually "written" to any version of the session. The only work around I found for this was that save as seemed to force the data to get written, as going back to a previously saved as version always did have the midi data. Strange huh?

meech 06-15-2009 09:13 AM

Re: Midi notes completely disappearing ... including all backups!
 
Quote:

Originally Posted by DigiTechSupt (Post 1410381)
Neither of these are compatible with Pro Tools 8 and could be the cause of your problems. Having incompatible plug-ins installed can cause all sorts of unpredictable behavior.

It's possible the corruption occurred early on, but did not exhibit itself in the session until later on - which would explain why the backups are corrupted as well. What can trigger this is cached plug-in or other data. The 'state' of a session is saved, but the cached data (preferences, etc.) can change - which is likely what happened here. When you reopen the session, the cached data interacts differently because of changes in the cache.


If the corruption occured early on, it wasn't Kontakt that caused the problem ... that was only added to the session within the last 20 minutes and the midi that disappeared had been there for 2, 3 hours. The thing is, I'm not sure if I can recreate this problem and so I don't know if it will happen again! Which is a really worrying thought :(

tonwurm 06-15-2009 10:16 AM

Re: Midi notes completely disappearing ... including all backups!
 
Quote:

Originally Posted by DigiTechSupt (Post 1410381)
...Having incompatible plug-ins installed can cause all sorts of unpredictable behavior...

it´s totally annoying to hear that again and again

what kind of interface is this rtas, if some crazy plugs can make midi-notes disappear ?

never had such a problem with logic, digital performer or cubase - there are crashes too (of course), but something like that - very poor

AND the question is: why is digi advertising those plugs (http://www.digidesign.com/index.cfm?navid=115&mkt=all), if they aren´t compatible ?

not to mention that most popular plugs are not compatible (f.e. Vienna Instruments, Play, NI Komplete...), some of the coolest plugs / Vi´s cannot be used in PT

reading all those threads users try to find a solution or workaround like hosting plugs in bidule, logic and so on really sucks

both performance and stability have to be improved - but when ? Next year summer ?

Dave D 01-15-2010 05:18 PM

Re: Midi notes completely disappearing ... including all backups!
 
I've just experienced the same issue. Luckily it was just a few bars of MIDI data that I lost. I was using an instance of UVI on the affected track.

And like the previous poster said, the MIDI is missing from the backup files as well. An empty MIDI region sits in the track containing no MIDI data.

Thanks for the tip on using "Save As".

I think I'll start doing that until I've confirmed this little bug has been squashed.

joeymusicguy 01-15-2010 07:43 PM

Re: Midi notes completely disappearing ... including all backups!
 
wait...

you're telling me kontakt isnt supported in pro tools?

what

the

...

BGMusic 01-15-2010 09:55 PM

Re: Midi notes completely disappearing ... including all backups!
 
This behavior stopped in PT 8.0.3. I also updated my plugins so perhaps that helped as well.

soundeziner 02-17-2010 09:21 AM

Re: Midi notes completely disappearing ... including all backups!
 
I just discovered that an entire songs worth of notes on one of my Hybrid tracks is gone. poof! and as you described they are gone from the backup files as well. I'm a very unhappy camper DIGI.


All times are GMT -7. The time now is 01:29 AM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com