Avid Pro Audio Community

Avid Pro Audio Community (http://duc.avid.com/index.php)
-   003, Mbox 2, Digi 002, original Mbox, Digi 001 (Win) (http://duc.avid.com/forumdisplay.php?f=17)
-   -   MBox 3 Lights flashing (http://duc.avid.com/showthread.php?t=310637)

augster 10-30-2011 10:20 AM

MBox 3 Lights flashing
My MBox 3 was working fine. Sure, every once in a while ProTools 9 would complain that it could not find the hardware, but a simple reinstall of the MBox drivers would fix that. Recently though, when I connect the MBox, all the lights flash in sequence as though the MBox is constantly being initialized. But it is never recognized by Windows. Reinstalling the MBox drivers doesn't fix this particular issue.

Has anyone else experienced this? Any suggestions for fixing this? (Besides getting a Mac - lol)

Here is my setup:
Samsung Laptop (this laptop is dedicated for ProTools use)
Windows 7, 64 bit
Intel i3 Chipset
500GB Disk
Pro Tools 9.0.5
MBox 3 (running driver v.1.0.19)

RTFM 10-30-2011 12:46 PM

Re: MBox 3 Lights flashing
This sounds to me like a hardware failure.

Pinball Wizard 10-31-2011 11:03 PM

Re: MBox 3 Lights flashing
This just happened to me too!

Even the stand-alone control panel won't find the mbox.

It isn't the mbox. The mbox works perfectly fine on two other computers.

Also, I am able to use a mbox pro 3 (firewire) ok on this computer. Looks like something is wrong with the usb.

I'll hack at it awhile & see what I can find out.

Pinball Wizard 11-02-2011 02:38 PM

Re: MBox 3 Lights flashing
I've spent two days on this and have made no progress.

The problem machine here is running XP SP3.

The mbox 3 works fine on two other computers. One is running XP home SP3 and the other is running Windows 7 professiona 64 bitl.

A mbox 3 pro works fine on the problem machine.

I have completely uninstalled all drivers & pro tools. I checked the registry to make sure that everything was gone. There were some drivers hiding in the prefetch folder but I got rid of them too. I even uninstalled and reinstalled the USB drivers. No joy.....the light show just keeps going on.
Another thread here suggests getting a card for the USB ports.


I will try that and report back in this thread. That is going to take a few days but I will keep hacking at this. I just don't get it.....this machine used to work ok with the mbox 3. Maybe a Microsoft update has done this.....I don't know.

augster 11-06-2011 08:28 AM

Re: MBox 3 Lights flashing
I also tried it on two other laptops and it works fine (both newer Windows 7 64bit). I'm also still hacking away at it - lol

augster 11-06-2011 10:49 AM

Re: MBox 3 Lights flashing - got it working!
I was able to finally get the MBox working again.

Here is what worked for me:

In Device Manager
Select "Universal Serial Bus controllers"
Right click on "Generic USB Hub" and click "Uninstall"
Select "Universal Serial Bus controllers" again
Right click on it and select "Scan for hardware changes"
I had to do this a couple of times

Since there are more than one Generic USB Hubs, I used the iLok dongle to locate the USB port that I needed to target. Here's how I did that:
Plug in the iLok to any USB port
Then, back in Device Manager I did the following:
Select "Universal Serial Bus controllers"
Right click on one of the "Generic USB Hub" and select "Properties"
Click on the "Power" tab and in the "Attached devices" section, you'll see the iLok device (if not, go to the next "Generic USB Hub")
Unplug the iLok device and quickly plug the MBox into that same port, then if the MBox is not recognized, uninstall that USB Hub following the steps above

The MBox is working fine now.

Pinball Wizard 11-08-2011 10:09 AM

Re: MBox 3 Lights flashing
Auigster: I am very happy that your mbox is now working. Mine is working too but I still am not sure that I understand what happened. I would like to make some real progress on this issue so we can all put it behind us and move on.

As you can see from my previous post, I did uninstall & reinstall the USB hubs just like you did but it didn't help me.

I still haven't received the usb card that I ordered. When I do I will play with it and see what I can learn.

In the meantime, I did find a port replicator for the problem machine (It is a Compaq laptop). When I connected the replicator, the problem went away and the machine now works ok.

I called together some very talented people that I know who professionally work on Avid video computer systems (Media Composer, Issis, Interplay, Air Speeds). I asked them for their opinions & they suggested that I look into USB power.

You can see how much current a device is drawing in Device Manager. I looked at a properly functioning mbox & it was pulling 498 ma. The limit for USB is 500 ma. That's real close. Just a small change in room temperature might be enough to push the mbox over the limit. Note that all computers & the mbox have VOLTAGE regulators to tightly control the voltages they use BUT current can go all over the place in response to what the devices need. Aging of polar capacitors in either the computer or the mbox MAY make them leaky. In that case, they may seem to work ok but they will draw more current.

The problem here is that although the USB spec defines 500ma as the limit, different cards handle that differently. When a device tries to draw more than 500 ma, some cards will just let it do that as much as they can provide. Others may not be able to do it and go into current limit with pretty much unpredictable results in what will happen to the interface. Others will switch the external device down to 100 ma. Still other shut down the device entirely until the computer is restarted. Yeah, it is a big problem for manufacturers to design equipment with all of these variables.

One more thing...... All of these hgih-current USB devices start up with a limit of 100 ma. They then request additional current and if the hub can give it to them, the hub switches them up to high current. I'm guessing that what we are seeing is the situation where the hub senses an over-current violation & switches the mbox back to 100 ma so it just tries over and over again to initialize a higher current-----evidenced by the light display.

When I get a little more time, I will cut open a USB cable so I can insert an ammeter (you can't use device manager to measure current if the device hasn't started). I will try to verify these speculations and maybe I can come up with a really solid diagnostic procedure and maybe a list of some known good cards that work with the mbox.

I will post whatever I learn here.


augster 11-09-2011 06:51 PM

Re: MBox 3 Lights flashing
I think you're on the right track regarding the USB power. I noticed how high the MBox was drawing from the port as well.

One recommendation I've seen online from some iPad users is to get an external USB port hub with its own AC power adapter (iPads draw a lot of power too and many times don't recharge in regular PC USB 2.0 ports). These hubs are not very expensive (under $30). I may try this if I have any more issues and I'll post any results.

Note that these hubs do not produce more than the USB standard 500mA, but I guess they are more likely to provide power more reliably than the integrated USB ports on the laptop. It's similar to your idea of getting a new USB card.

Pinball Wizard 11-16-2011 03:42 PM

Re: MBox 3 Lights flashing
I have more experience to report.

First, to review.....

I have an mbox 3 that works ok on two computers. One uses Windows 7, the other XP. The mbox 3 does not work on a third computer, a Compaq laptop running XP. All I get is the sequential 'chase light show.'

I have tried reinstalling the OS, Pro Tools, the mbox driver, & the USB driver to no avail.

The mbox does, however work fine on the problem computer when I use a port replicator.

Now, here is the new part.....

I went to Best Buy and purchased a powered USB hub.


When I connected the mbox 3 to the powered hub, it settled down and worked ok 'stand alone' even before I started the computer. I started the computer and the mbox then started flashing the blue power tly. I reinstalled Pro Tools and now it works fine.

Note that I am using the same USB port on the computer, the same drivers, etc. Everything is the same except I added the powered hub. I consider this to be fairly strong evidence that the USB power in the Compaq laptop is the culprit.

Please note that I am NOT saying that USB power is always the cause of the failures & that the powered hub will fix all instances of 'light show' or 'hardware not found.' It is just one of the fixes.

I will continue to make some more measurements as time allows to further confirm this. If anyone else is having an mbox 3 problem, please post the details here and I will try to help.


albee1952 11-16-2011 04:01 PM

Re: MBox 3 Lights flashing
One of the required Windows system tweaks is to turn OFF the power management feature on all USB ports:rolleyes:

All times are GMT -7. The time now is 01:34 AM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com