Avid Pro Audio Community

Avid Pro Audio Community (http://duc.avid.com/index.php)
-   Pro Tools 2018 (http://duc.avid.com/forumdisplay.php?f=157)
-   -   2018.10 works on MBP i9 with Vega 20 and Mojave (http://duc.avid.com/showthread.php?t=402058)

DarkandKurious 11-22-2018 06:36 AM

2018.10 works on MBP i9 with Vega 20 and Mojave
 
Just thought I'd let people know 2018.10 (standard) installs and runs on the 2018 MBP with the new Vega graphics options on 10.14.1. I haven't done any exhaustive tests yet, still authorising and downloading all my plugs.

PT did crash on startup due to one of the RX plugins, but, I was watching to see if anything happened, so I was able to move that one to the unused folder.

I'll add some more info as I test it with some heavy sessions.

Edit: I have tested the dual install with 2018.4 as well as 2018.10 and both work pretty much as expected. I haven't tried any tracking yet, but other than that everything seems fine - a 32 channel session played back fine under moderately heavy CPU load without major spikes, plugins were heavy on CPU ie oeksound and Acustica plugs.

lvaudio 11-26-2018 03:09 PM

Re: 2018.10 works on MBP i9 with Vega 20 and Mojave
 
Which plugins work and which don't??

Any issues or regrets with the Vega 20?

What video work are you doing?

DarkandKurious 11-27-2018 12:02 AM

Re: 2018.10 works on MBP i9 with Vega 20 and Mojave
 
I'll copy and expand on this from a post I made on GS. I won't list individual plugins as it would take far too long:

- iLok v5 works fine
- ProTools Standard 2018.4 and 2018.10 installed fine (renamed them PT 4 and PT 10 respectively so I can use 2018.4 for correct multichannel audiosuite because of PT bugs) One of the Izotope RX plugins caused it not to open though, so I put those in the unused plugin folder, and all was good, luckily it was one I didn't use anyway.
- Izotope: RX 7 Advanced, Ozone 8 Advanced, Neutron 2 Advanced, all the Izotope I have installed worked other than that one plugin (I think it was Hum Removal that was crashing PT on the first startup)
- Acustica: Aquarius works fine, all the AAX plugs work fine. N4 Player works.
- Komplete 10 works fine.
- Embertone Walker D needed to be renamed as Native Access couldn't link to the original named file, nothing to do with Mojave.
- Antelope Zen Tour works fine, as do the Antelope Launcher and Control Panel
- MAAT plugins with their Codemeter protection work fine.

I'll list all the other companies whose plugins I've installed that just worked: Antares, Arturia, Audified, Audiority, Black Rooster Audio, Blue Cat Audio, Boz Digital Labs, Cytomic, DMGAudio, Empirical Labs, EndeavourFX, Eventide, Exponential Audio, Fabfilter, Flux, Fuse Audio Labs, Goodhertz, IRCAM, Kazrog, Klanghelm, Kush Audio, Lexicon, Liquidsonics, Metric Halo, NUGEN Audio, NeuralDSP, Newfangled Audio, Ohlhorst Digital, Overloud, PSPAudioware, Plugin Alliance, Rare Signals, RedWirez, Scuffham, Softube, Sonic Studio, Soundtoys, Steven Slate, Tokyo Dawn Labs, Tritik, UVI, Valhalla DSP, Vertigo Sound, Zynaptiq, oeksound, sonible, u-he.

I haven't bothered installing Waves, as I found I never used them over other options. Might try later just to see.

Some of the manufacturers had changed their website address or login details (email instead of user name or similar), so I had to reset my username or password before things would work, and that gave me a fright as there was no explanation.

Also, the video engine in PT works fine. I always disable automatic graphics switching ever since I noticed the way it affects plugins, so I am using the Vega only. I played back video with audio in the session. Video was from an AJA KiPro for a motion capture session, but I am not a video guy so I can't be 100% how well it works, but nothing seemed different or unusual - the video played back smoothly as far as I could tell, and the engine worked without crashing. No regrets with the Vega, it's supposed to keep the computer cooler. I haven't even noticed the fans really kicking in as much as my previous laptop (2013 MBPr 10,1) even at 70-80% usage in PT across all cores.

As some people had mentioned issues with the T2 chip and audio stutters - I'm yet to hear a problem. I am wondering if people are using sub-optimal USB adapters or hubs for their interfaces and there are conflicts from power management (similar to the issue between USB 3 and wifi). I am using a CalDigit TS3+

Also, I did an 8 channel recording at 44.1 on a 64 buffer for 15 minutes with no interruptions of CPU issues. No plugins involved though.

All the functionality I am used to exists it seems. Hope that helps!

andyhardy 11-27-2018 01:23 PM

Re: 2018.10 works on MBP i9 with Vega 20 and Mojave
 
Try to open a OMF file there seems to be a big issue there


All times are GMT -7. The time now is 06:57 PM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com