Avid Pro Audio Community

Avid Pro Audio Community (http://duc.avid.com/index.php)
-   Pro Tools 12 (http://duc.avid.com/forumdisplay.php?f=142)
-   -   HUI Issues with Icon Platform M+ and PT12 Mac (http://duc.avid.com/showthread.php?t=396534)

Mark Roberts 01-22-2018 11:52 AM

HUI Issues with Icon Platform M+ and PT12 Mac
 
Hi People!

Had an excellently frustrating day trying to get my Icon Platform M+ control surface working with PT 12 on my Mac! Hoping someone out there can help :-)

My System:

Pro Tools 12.8.3
Mac Pro
OSX 10.12.5

Symptoms

I will try not to bore you all with the long story but instead tell you where I am currently at.

I now have the Icons transport working, it will also select on tracks and toggle through the session. When I move a fader the corresponding fader in PT will move, but not the other way round. So eventually the faders are "dead". They do not snap to the value in PT.

I have set up the peripherals correctly, selecting HUI and the Icon as the "receive" and "send to" and channel 8. The icons settings also seem fine the Midi Studio, reporting as connected and beeping cheerfully when in test mode and prodded.

As well as the lack of functionality I am also getting the "Pro Tools is unable to communicate with HUI. Power-cycle HUI and check its connections. Note, if HUI is not in use, update the Peripherals dialog to prevent further warnings" error message.

I have tried updating the Icon firmware and as far as I can tell it's all up to date (V 1.0.6) I have even done this on a PC as the Mac SW is buggy.

I have trashed preferences, updated etc and am at a bit of a loss. Will be a shame to send this thing back.

Is ANYONE out there successfully using this unit with PT12 Mac?

Thanks

Sir Hannes 02-02-2018 05:49 AM

Re: HUI Issues with Icon Platform M+ and PT12 Mac
 
also interesting for me, as I think about purchasing a unit for PT12.5 :-)

Mark Roberts 02-02-2018 07:27 AM

Re: HUI Issues with Icon Platform M+ and PT12 Mac
 
I got it working!

The latest firmware seemed to be the main fix, but also the PSU was an issue. It was trying to power off the USB.

All i all it is great! There'a couple of tiny issues but even those might be user error as I'v not had time to trouble shoot. The faders work and are nice, as is the transport and that's what I wanted it for.

Cheers

Sir Hannes 02-02-2018 10:41 AM

Re: HUI Issues with Icon Platform M+ and PT12 Mac
 
Nice to hear :-) I think I replace my almost new Korg nanoKontrol2 with one unit (without the screen, too expensive). Also I like to modify it if I need it for composing in LogicPro with Kontakt.

What do you mean with PSU?

Mark Roberts 02-02-2018 10:59 AM

Re: HUI Issues with Icon Platform M+ and PT12 Mac
 
Quote:

Originally Posted by Sir Hannes (Post 2472935)
Nice to hear :-) I think I replace my almost new Korg nanoKontrol2 with one unit (without the screen, too expensive). Also I like to modify it if I need it for composing in LogicPro with Kontakt.

What do you mean with PSU?

Yep, would deffo be a step up. You can always get the screen later down the line anyway. Give me a shout if you get stuck setting it up as I am now pretty clued up!

Regarding the PSU. Once I got the firmware finally sorted, the transport worked but not the faders. Icon suggested the PSU might be at fault, it should power up when not attached via USB. It had done this before as I had calibrated the faders and they all wizzed about fine. But when I tried it as pretty much a last ditch attempt to fix it, there was no power once I unplugged the USB. I tried a different PSU I had lying about and it worked.

Later I found that the included PSU was fine in another socket. This however wasn't the source of my issues to begin with, hence not making a big dal of it on here.

Hope that makes sense ;)

Sir Hannes 02-02-2018 11:05 AM

Re: HUI Issues with Icon Platform M+ and PT12 Mac
 
Yeah, got it. I heard from Faderport the same, if there's not enough power, you can use it normally, but not the motor fader.
Great you get it to work and thanks for your invitation to ask you. I'll do that, if I see problems. Right now, I just wait for my money from the last big project and then I go on to order this.

Aaah one important question: is on the Icon a mode to e.g. double click on a button (select) to get the fader to zero dB?

sematary 02-28-2018 09:28 PM

Re: HUI Issues with Icon Platform M+ and PT12 Mac
 
hey, just curious on overall functionality of your platform with pro tools. im running PT 12 and want to purchase the M+ and X for 16 channels but cant find alot of info online of how extensively it integrates with pro tools. thanks for info you can provide.

stevemaheraudio 11-18-2019 11:35 AM

Re: HUI Issues with Icon Platform M+ and PT12 Mac
 
Hi guys I'm using the iCon Platform M+ in my home setup here but I notice when I'm holding my finger on the fader, I cannot use my keyboard. I have to remove my finger from the fader before regaining keyboard signal. I don't want to use latch mode so that's not a fix for me.

Is this a HUI thing? It bothers me because I like to zoom in and out to see files approaching on my edit window when mixing.

Thanks,

Steve


All times are GMT -7. The time now is 09:00 AM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com