Avid Pro Audio Community

Avid Pro Audio Community (http://duc.avid.com/index.php)
-   Pro Tools 10 (http://duc.avid.com/forumdisplay.php?f=91)
-   -   24-bit audio doesn't work (MPEG streamclip and PT 10, PT 11) (http://duc.avid.com/showthread.php?t=404134)

jgiannis 04-16-2019 07:26 PM

24-bit audio doesn't work (MPEG streamclip and PT 10, PT 11)
 
Does anyone know how to keep 24-bit audio when using MPEG streamclip? The audio gets automatically converted to 16-bit.


Here's the whole story for anyone who wants to know how I got to this step in my pipeline and where Pro Tools fits in:

- I build final sound and video delivery.
- I receive video in Apple Pro Res 422 HQ format.
- I place the dialogue, music, and effects, and create a stereo mix in 24-bit, 48k format.
- The client requires some video edits that fortunately I can do with PT 11 HD.
- After performing video edits, I export a quicktime.
- The resulting quicktime successfully is Apple Pro Res 422 HQ, 48k stereo, 24-bit. The problem is that upon playback, the video freezes or goes black, right where I made the video edit(s).
- Importing that quicktime file back into a new PT 11 session reveals that the full audio track is there, but only a portion of the video comes in (up until where the video edit was in the original session).
- However, importing the video into PT 10 reveals that both the entire audio track and the entire video are intact. It appears that the metadata of the QT file retains info about where the video edits were, and as a result, PT 11 only imports up until the first video edit. But PT 10 imports the whole thing, as one continuous video.
- I would simply bypass PT 11 and work only in PT 10, except that PT 10 does not allow me to export with 24-bit audio. I have to go to PT 11 for that.
- So, to recap, the QT video is perfect, except that there appears to be some metadata that causes freezes and black screens. VLC, QuickTime, and PT 11 cannot properly playback the video. But PT 10 can.
- So I convert the video with MPEG streamclip. I retain all of the same settings so that the conversion is as lossless as possible. Namely, I keep it at Apple Pro Res 422 HQ, stereo, 48k, uncompressed audio.
- The result is that the bugs in the metadata are now gone, and all systems playback the video perfectly. But now the audio is 16-bit instead of 24-bit. If only I can force MPEG streamclip to retain 24-bit audio, then the problem would be solved.

The only way I can think to keep the 24-bit audio is to:

- take the new, converted video and load into PT 11.
- import the original audio track.
- export. this time most likely there wouldn't be any picture dropouts, though I haven't tested yet.
- the problem with this method is it take WAAAAAAY too long. It's actually ridiculous and creates way too many 20GB+ intermediate files.

Does anyone know any other method? Ideally, if MPEG streamclip were to retain the 24-bit audio, I would be okay. But I can't find any info on that.

cwsand 05-29-2019 11:17 PM

Re: 24-bit audio doesn't work (MPEG streamclip and PT 10, PT 11)
 
I'm not sure about the limitations of MPEG Streamclip, but my suggestion would be to find a better workflow - i.e. don't use Pro Tools as your primary video editor. I prefer to use video editing software to edit the video, then mix using Pro Tools. It's possible to use a single program for both, but most programs seem to focus on either video or audio and have suffering features on the other. But if all you're doing are straight cuts, I would think any decent video editing software would be able to edit the video and audio together and export a working file.

BScout 05-29-2019 11:41 PM

Re: 24-bit audio doesn't work (MPEG streamclip and PT 10, PT 11)
 
You’ve misunderstood what a video export with edits from ProTools does. “Mov” is the container. Inside of it you can package multiple clips. So with edits, each segment is a clip that is packaged into the container. Some programs can handle multiple bundled clips in one video container and some can’t on playback.

So what is the solution... re-encoding the multi clips into one. And that can be done straight from ProTools. Do not choose “same as video”; instead choose QuickTime options from there. Choose the same as your original video specs. That will re-encode your video (it will also be a longer video export and you’ll have a generational loss.)

cwsand 05-30-2019 07:13 PM

Re: 24-bit audio doesn't work (MPEG streamclip and PT 10, PT 11)
 
Quote:

Originally Posted by BScout (Post 2527799)
Do not choose “same as video”; instead choose QuickTime options from there. Choose the same as your original video specs. That will re-encode your video (it will also be a longer video export and you’ll have a generational loss.)

Interesting - I wonder if Final Cut or Premiere act the same as far as re-encoding the entire timeline? Or do they just re-encode changes or a certain number of frames around an edit? Just wondering as far as the "generational loss" you spoke of, though it may not be perceptible in the end.

BScout 05-30-2019 08:12 PM

Re: 24-bit audio doesn't work (MPEG streamclip and PT 10, PT 11)
 
The NLE video editors always re-encode on export of a timeline/sequence. You can inspect the exported container and see that it is one. (You can also inspect the container put out by ProTools when there are edits and see the multiples too.)


All times are GMT -7. The time now is 02:46 PM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com