Avid Pro Audio Community

Avid Pro Audio Community (http://duc.avid.com/index.php)
-   Pro Tools 2018 (http://duc.avid.com/forumdisplay.php?f=157)
-   -   ProTools 2018.4 Ultimate and macOS Mojave (http://duc.avid.com/showthread.php?t=400209)

BillDog793 07-15-2018 11:00 AM

ProTools 2018.4 Ultimate and macOS Mojave
 
Hey all, I know MacOS Mojave is still in it's beta phase, but I'm wondering what people's experiences were with the two most current versions of both. I'm still on ProTools 2018.3 waiting on news for the current version of MacOs High Sierra (10.13.6) to be officially supported, but will be wanting to switch over to Mojave if it doesn't kill PT

TNM 07-15-2018 06:30 PM

Re: ProTools 2018.4 Ultimate and MacOs Mojave
 
do you need Mojave? really? The latest HS isn't even supported yet! Why cutting edge all the time? If i get the imac pro i am never going to upgrade.. we lose all 32 bit support with mojave... ALL....

HS had so many issues, Mojave will be good this time NEXT year.....

TNM 07-15-2018 06:33 PM

Re: ProTools 2018.4 Ultimate and MacOs Mojave
 
http://avid.force.com/pkb/articles/c...m-Requirements

even 10,13,4 not supported, and I don't see any possible way to get an earlier version of High Sierra anyway

WOW avid are officially acknowledging "serious" low buffer cpu issues with HS 10.13.4 which would mean 10.13.5 and .6 are probably the same.

DARN.

This truly sucks. I hope they fix it! I won't have a choice if I get an imac pro! Damn it! Or even the new hexacore macbook pro! Will come with 10.13.6!

musicman691 07-16-2018 03:43 AM

Re: ProTools 2018.4 Ultimate and MacOs Mojave
 
Quote:

Originally Posted by TNM (Post 2494159)
http://avid.force.com/pkb/articles/c...m-Requirements

even 10,13,4 not supported, and I don't see any possible way to get an earlier version of High Sierra anyway

WOW avid are officially acknowledging "serious" low buffer cpu issues with HS 10.13.4 which would mean 10.13.5 and .6 are probably the same.

DARN.

This truly sucks. I hope they fix it! I won't have a choice if I get an imac pro! Damn it! Or even the new hexacore macbook pro! Will come with 10.13.6!

If one can get an initial release of HS somehow then all that is needed is the combo updater for whatever follow-on HS one wants and apply that. I've done that for previous versions of OSX.

TNM 07-18-2018 05:17 PM

Re: ProTools 2018.4 Ultimate and MacOs Mojave
 
Quote:

Originally Posted by musicman691 (Post 2494191)
If one can get an initial release of HS somehow then all that is needed is the combo updater for whatever follow-on HS one wants and apply that. I've done that for previous versions of OSX.

how? can't find it, i've looked.

Regardless, avid need to support the latest mac release..

Really, windows getting much more tempting, if it's didn't have that damn FLS slot issue i'd have switched months ago to a 14 core 28 thread desktop beast (7940x).

Now that there are workarounds for the multithread issue in Cubase which can use up to 32 threads in windows, only the FLS slot issue remains which affects PT, Cubase, all daws. So frustrating.. I have too decide soon as the next mac OS drops all 32 bit compatibility (which is why i can't wait for the 2019 mac pro) and i have too many 32 bit plugins i bridge then open in patchworx, as well as 32 bit apps unfortunately that i rely on. As well as lots of 32 bit hardware synth editors that will likely never get updated. That's the other reason.. I mean high sierra might be the last mac os I can ever use..

That said, if avid can fix it, the 10 core imac pro fully tricked out would probably do me for the next 8 years.

musicman691 07-18-2018 05:41 PM

Re: ProTools 2018.4 Ultimate and MacOs Mojave
 
Quote:

Originally Posted by TNM (Post 2494455)
how? can't find it, i've looked.

Maybe some kind soul could provide it to you.

Of course there's always Amazon:
https://www.amazon.com/10-13-High-Si...BSNHGRYCBAA63X

https://www.amazon.com/macOS-High-Si...erating+system

The first one is a dvd and the second a thumb drive.

TNM 07-18-2018 05:55 PM

Re: ProTools 2018.4 Ultimate and MacOs Mojave
 
Quote:

Originally Posted by musicman691 (Post 2494456)
Maybe some kind soul could provide it to you.

Of course there's always Amazon:
https://www.amazon.com/10-13-High-Si...BSNHGRYCBAA63X

https://www.amazon.com/macOS-High-Si...erating+system

The first one is a dvd and the second a thumb drive.

I appreciate it truly but they don't ship to OZ..

Also imac pro is not listed in compatibility as bootable with it.

How about Avid just fix it since only pro tools is affected?

Cubase and Logic are fine.

octatonic 07-18-2018 08:55 PM

Re: ProTools 2018.4 Ultimate and MacOs Mojave
 
Quote:

Originally Posted by TNM (Post 2494458)
I appreciate it truly but they don't ship to OZ..

Also imac pro is not listed in compatibility as bootable with it.

How about Avid just fix it since only pro tools is affected?

Cubase and Logic are fine.

You can't roll back to an earlier Operating System than what ships with the machine.

You will have to wait.
Sorry.

Sardi 07-18-2018 09:07 PM

Re: ProTools 2018.4 Ultimate and MacOs Mojave
 
Quote:

Originally Posted by octatonic (Post 2494472)
You can't roll back to an earlier Operating System than what ships with the machine.


When it was ORIGINALLY released, not what it is currently shipping with.



Sent from my iPhone using Tapatalk

TNM 07-18-2018 10:28 PM

Re: ProTools 2018.4 Ultimate and MacOs Mojave
 
Quote:

Originally Posted by Sardi (Post 2494474)
When it was ORIGINALLY released, not what it is currently shipping with.



Sent from my iPhone using Tapatalk

This.

Regardless, it doesn't matter, Avid told me they can't fix it, that it's apple's fault, and that other daws are affected with 10.13.4 and higher.

he then suggested i do NOT go to windows.. literally have the email right in front of me..

So he is telling me 10.13.4 and higher has to be fixed by apple, they have tried at avid and can't fix it, yet don't buy a windows machine cause too many variables.

I am just at such a loss...

kudos to Avid for answering so fast.. but i don't see any point in ever investing in a mac again as long as I live..

Because Avid support tell me it may be many months but when Apple fix it they will fix anything they need to from Avid's end as well..

Um.. don't they realise that 10.13.6 is lastly the final release of High Sierra and Apple will NOT be "fixing" anything else core audio wise, prior to Mojave?

So i have replied saying... There WILL be no "fix" from apple in High Sierra, so will Avid be fixing it or not.. yes or no?..I can not find any reports of low buffer issues in high sierra 10.13.4+ with cubase or logic.

I mean this is just ridiculous.. so tired of music chairs blame game.

Look at this.. propellerheads had the same issue, and they fixed it LOL.

https://help.propellerheads.se/hc/en...Sierra-10-13-4

So they can do it, but avid blame apple. Same thing, performance issues.

It's obviously never going to get fixed.. The idea of a new imac pro is like probably burning 12 thousand dollars with fire. Sigh.


All times are GMT -7. The time now is 08:01 PM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com