Avid Pro Audio Community

Avid Pro Audio Community (http://duc.avid.com/index.php)
-   Artist Series (http://duc.avid.com/forumdisplay.php?f=62)
-   -   Artist Mix failing to connect 9/10 (http://duc.avid.com/showthread.php?t=405938)

noiseboyuk 08-12-2019 02:38 PM

Artist Mix failing to connect 9/10
 
My Artist Mix (actually an MC Mix) has given many years of excellent service, but in the past couple of weeks has really started playing up. It might take 9 or 10 attempts of power cycling before the PC picks it up. I've updated to latest versions of both EuControl and Firmware, but same behaviour before and after. It also seems to be a bit flaky in use, with the left hand fader playing up a bit (it displayed OFF today for a while, which I've never seen before).

Any hope for the old beast do you think? Anything worth trying? Recommendations for repair?

EddieJones 08-13-2019 08:17 AM

Re: Artist Mix failing to connect 9/10
 
I would check the power supply first

noiseboyuk 09-16-2019 01:17 AM

Re: Artist Mix failing to connect 9/10
 
Quote:

Originally Posted by EddieJones (Post 2535343)
I would check the power supply first

Thanks Eddie (very belatedly). I bought a new supply from Lee Electronics in the UK, the authorised repairs centre. At first I thought it had solved the problem as connection seemed much more reliable, but it's just done it again, so I fear the problem hasn't entirely gone away. So it seems improved, but still not right, which is weird - I'd expect it to be fixed or the same?

EddieJones 09-16-2019 01:19 AM

Re: Artist Mix failing to connect 9/10
 
You could be seeing two separate issues, and the power supply cleared up one of them. Keep an eye open for any particular workflow that makes it worse ?

noiseboyuk 09-16-2019 02:33 AM

Re: Artist Mix failing to connect 9/10
 
Quote:

Originally Posted by EddieJones (Post 2538194)
You could be seeing two separate issues, and the power supply cleared up one of them. Keep an eye open for any particular workflow that makes it worse ?

Its been well behaved in other ways of late actually. Its just first connection on powering up, but I'll keep my eye on anything else strange or other conditions which trigger it - thanks for the replies :)

EddieJones 09-18-2019 10:37 AM

Re: Artist Mix failing to connect 9/10
 
Try not auto launching EuControl

noiseboyuk 09-26-2019 02:36 AM

Re: Artist Mix failing to connect 9/10
 
Quote:

Originally Posted by EddieJones (Post 2538501)
Try not auto launching EuControl

Apologies, only just seen this. It wasn't recognising the surface at all this morning, but exiting EuControl and then restarting it did first time. Is this a known issue? Does 19.9 fix?

Thanks Eddie.

EddieJones 09-26-2019 10:57 AM

Re: Artist Mix failing to connect 9/10
 
This only usually happens if EuControl is started before the network is up and running correctly. (Hence starting it after the Mac has fully booted)

noiseboyuk 09-26-2019 11:50 AM

Re: Artist Mix failing to connect 9/10
 
Quote:

Originally Posted by EddieJones (Post 2539294)
This only usually happens if EuControl is started before the network is up and running correctly. (Hence starting it after the Mac has fully booted)

Actually I'm Windows. As a next step, I'm trying disabling it from Task Manager startup, and putting it in the Windows StartUp folder instead, which I understand loads later than all the Task Manager processs.

If EuControl can't be tweaked to resolve this, how about adding a network reset button in the software?

EddieJones 09-26-2019 11:55 AM

Re: Artist Mix failing to connect 9/10
 
That would be basically restarting it. Its best to try and find out what is causing the network to change. How are you connected, through a switch, router or direct cable. Are you using DHCP or link local ?

noiseboyuk 09-26-2019 12:30 PM

Re: Artist Mix failing to connect 9/10
 
Connected through a switch. Not sure how to answer the DHCP question. Nothing has changed network-wise for a year or so, these issues started about 2 months ago I'd say.

BScout 09-26-2019 01:06 PM

Re: Artist Mix failing to connect 9/10
 
Quote:

Originally Posted by noiseboyuk (Post 2539304)
Actually I'm Windows. As a next step, I'm trying disabling it from Task Manager startup, and putting it in the Windows StartUp folder instead, which I understand loads later than all the Task Manager processs.

If EuControl can't be tweaked to resolve this, how about adding a network reset button in the software?

If you want a delayed start, use Windows "task scheduler"
You can set the trigger to be when you login and then you can set any delay time you want.

Don't use the Startup folder for this. Task scheduler is the right way.

BTW, Task Manager just shows everything that will start. It's an aggregate list and will include anything you add to the startup folder or task scheduler (there are actually four different places you can set startup tasks -- 2 more places in the registry). It isn't the one responsible for the actual startup. It is just telling you what will startup from these four places. Each of these places is triggered at a different time in the boot sequence.

EddieJones 09-26-2019 01:17 PM

Re: Artist Mix failing to connect 9/10
 
You should really use the EuControl method to make it auto start as thats what we test with.

noiseboyuk 09-26-2019 03:27 PM

Re: Artist Mix failing to connect 9/10
 
Quote:

Originally Posted by EddieJones (Post 2539321)
You should really use the EuControl method to make it auto start as thats what we test with.

But you said it can cause problems? If a delayed start up is needed, isn't BScout's advice the best way forward? (Thanks BScout btw)

I should have thought of all this. For several years the only way I could get EuCon to work reliably was delayed starts to the 3 services, with EuControl last. I thought those days had gone, but it appears not.

EddieJones 09-26-2019 03:40 PM

Re: Artist Mix failing to connect 9/10
 
I meant for testing, not just deleting the startup file etc.

Whilst I have heard of this before its not the norm, so other than delaying EUCON (or completely rewriting it which isn't off the cards either) theres not much i can suggest.

noiseboyuk 09-27-2019 01:47 AM

Re: Artist Mix failing to connect 9/10
 
OK thanks Eddie (really appreciate how active you are here btw - if only main PT forums had someone from Avid this involved!)

Today it wouldn't reconnect by stopping and re-starting even after several attempts and power cycles. However, additionally closing and resarting MC Client fixed the problem. I think I'm going to try and figure out a way to delay start - with long intervals - the different processes, as I used to do a few years ago. Isn't there a third service I need to involve too, or is that no longer used?

noiseboyuk 09-27-2019 01:52 AM

Re: Artist Mix failing to connect 9/10
 
Bonus question to the above - there is also a program called EuConStart. What order do I need to manually start which programs / services to best test this? Here are the contenders I know about:

EuConStart
MC Client
EuControl

EddieJones 09-27-2019 09:07 AM

Re: Artist Mix failing to connect 9/10
 
I just want to check again so I'm sure as I'm a Windows guy and don't see these issues. If EuControl isn't set to auto start and you start it after Windows has fully booted is everything OK ?

noiseboyuk 09-27-2019 10:59 AM

Re: Artist Mix failing to connect 9/10
 
Quote:

Originally Posted by EddieJones (Post 2539426)
I just want to check again so I'm sure as I'm a Windows guy and don't see these issues. If EuControl isn't set to auto start and you start it after Windows has fully booted is everything OK ?

So far so good. One manual start ok, then using Task Scheduler I tried one delayed for 2 minutes after startup - both times it found the Mix first time. I think it starts MC Client first, right? I didn't set that, but it didn't appear in Task Manager until EuControl started.

BScout 09-27-2019 11:21 AM

Re: Artist Mix failing to connect 9/10
 
Just checking, have you tried a complete uninstall of Eucontrol (using the installer's option to uninstall everything). Do a reboot. And then reinstall. (temporarily disable any delayed tasks in task scheduler)

Seems like you are having to jump through a lot of hoops to do something that works flawlessly on my Windows machine.

Also, do you have any other programs on that machine that have startup items? Possibly one of those is delaying things to complete. (or you've delayed a necessary service from its natural state of autostart in services.msc?)

noiseboyuk 09-27-2019 11:50 AM

Re: Artist Mix failing to connect 9/10
 
Quote:

Originally Posted by BScout (Post 2539452)
Just checking, have you tried a complete uninstall of Eucontrol (using the installer's option to uninstall everything). Do a reboot. And then reinstall. (temporarily disable any delayed tasks in task scheduler)

Seems like you are having to jump through a lot of hoops to do something that works flawlessly on my Windows machine.

Also, do you have any other programs on that machine that have startup items? Possibly one of those is delaying things to complete. (or you've delayed a necessary service from its natural state of autostart in services.msc?)

It all worked flawlessly for me until a couple of months ago too! I did update EuControl when I started having problems, but didn't do a complete uninstall, to be fair.

All that said, if this continues to work I'll stick to this method. For many years I had to delay these services, so its a familiar problem to me and once sorted last time it was good as gold. Likely there's some conflict somewhere with some other service, I could waste a month isolating that!

noiseboyuk 10-02-2019 01:41 AM

Re: Artist Mix failing to connect 9/10
 
Just a quick update - it's not 100% but MUCH better, I reckon I'm down from 9/10 failure to 2/10. Also one thing I didn't notice that's a bit of time-saver if it doesn't start is to right click the icon in Quick Launch and select "Restart all EuCon applications". So far that's worked every time first time.


All times are GMT -7. The time now is 07:43 PM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com