Avid Pro Audio Community

Avid Pro Audio Community (http://duc.avid.com/index.php)
-   Artist Series (http://duc.avid.com/forumdisplay.php?f=62)
-   -   Artist Mix failing to connect 9/10 (http://duc.avid.com/showthread.php?t=405938)

noiseboyuk 09-26-2019 12:30 PM

Re: Artist Mix failing to connect 9/10
 
Connected through a switch. Not sure how to answer the DHCP question. Nothing has changed network-wise for a year or so, these issues started about 2 months ago I'd say.

BScout 09-26-2019 01:06 PM

Re: Artist Mix failing to connect 9/10
 
Quote:

Originally Posted by noiseboyuk (Post 2539304)
Actually I'm Windows. As a next step, I'm trying disabling it from Task Manager startup, and putting it in the Windows StartUp folder instead, which I understand loads later than all the Task Manager processs.

If EuControl can't be tweaked to resolve this, how about adding a network reset button in the software?

If you want a delayed start, use Windows "task scheduler"
You can set the trigger to be when you login and then you can set any delay time you want.

Don't use the Startup folder for this. Task scheduler is the right way.

BTW, Task Manager just shows everything that will start. It's an aggregate list and will include anything you add to the startup folder or task scheduler (there are actually four different places you can set startup tasks -- 2 more places in the registry). It isn't the one responsible for the actual startup. It is just telling you what will startup from these four places. Each of these places is triggered at a different time in the boot sequence.

EddieJones 09-26-2019 01:17 PM

Re: Artist Mix failing to connect 9/10
 
You should really use the EuControl method to make it auto start as thats what we test with.

noiseboyuk 09-26-2019 03:27 PM

Re: Artist Mix failing to connect 9/10
 
Quote:

Originally Posted by EddieJones (Post 2539321)
You should really use the EuControl method to make it auto start as thats what we test with.

But you said it can cause problems? If a delayed start up is needed, isn't BScout's advice the best way forward? (Thanks BScout btw)

I should have thought of all this. For several years the only way I could get EuCon to work reliably was delayed starts to the 3 services, with EuControl last. I thought those days had gone, but it appears not.

EddieJones 09-26-2019 03:40 PM

Re: Artist Mix failing to connect 9/10
 
I meant for testing, not just deleting the startup file etc.

Whilst I have heard of this before its not the norm, so other than delaying EUCON (or completely rewriting it which isn't off the cards either) theres not much i can suggest.

noiseboyuk 09-27-2019 01:47 AM

Re: Artist Mix failing to connect 9/10
 
OK thanks Eddie (really appreciate how active you are here btw - if only main PT forums had someone from Avid this involved!)

Today it wouldn't reconnect by stopping and re-starting even after several attempts and power cycles. However, additionally closing and resarting MC Client fixed the problem. I think I'm going to try and figure out a way to delay start - with long intervals - the different processes, as I used to do a few years ago. Isn't there a third service I need to involve too, or is that no longer used?

noiseboyuk 09-27-2019 01:52 AM

Re: Artist Mix failing to connect 9/10
 
Bonus question to the above - there is also a program called EuConStart. What order do I need to manually start which programs / services to best test this? Here are the contenders I know about:

EuConStart
MC Client
EuControl

EddieJones 09-27-2019 09:07 AM

Re: Artist Mix failing to connect 9/10
 
I just want to check again so I'm sure as I'm a Windows guy and don't see these issues. If EuControl isn't set to auto start and you start it after Windows has fully booted is everything OK ?

noiseboyuk 09-27-2019 10:59 AM

Re: Artist Mix failing to connect 9/10
 
Quote:

Originally Posted by EddieJones (Post 2539426)
I just want to check again so I'm sure as I'm a Windows guy and don't see these issues. If EuControl isn't set to auto start and you start it after Windows has fully booted is everything OK ?

So far so good. One manual start ok, then using Task Scheduler I tried one delayed for 2 minutes after startup - both times it found the Mix first time. I think it starts MC Client first, right? I didn't set that, but it didn't appear in Task Manager until EuControl started.

BScout 09-27-2019 11:21 AM

Re: Artist Mix failing to connect 9/10
 
Just checking, have you tried a complete uninstall of Eucontrol (using the installer's option to uninstall everything). Do a reboot. And then reinstall. (temporarily disable any delayed tasks in task scheduler)

Seems like you are having to jump through a lot of hoops to do something that works flawlessly on my Windows machine.

Also, do you have any other programs on that machine that have startup items? Possibly one of those is delaying things to complete. (or you've delayed a necessary service from its natural state of autostart in services.msc?)


All times are GMT -7. The time now is 06:52 AM.

Powered by: vBulletin, Copyright ©2000 - 2008, Jelsoft Enterprises Limited. Forum Hosted By: URLJet.com