PDA

View Full Version : Client wants to connect to unknown proxy


JohnnyB
03-30-2009, 09:04 PM
When I use the client software at my studio, [bleep]it works fine. [bleep] When I try it at home, [bleep]it always want's to connect to a strange proxy server. [bleep] It asks for a user / pswd [bleep]and I can never get connected. [bleep] Port 8000? Would you have any idea why? [bleep] Something to do with DNS? [bleep] I have deleted and re-installed numerous times. [bleep] I am using 2.1.1b394. At the studio, I am behind a router. At home I am also behind a router. The same problem at home existed when I had an older router. Now I am running DDWRT V24SP1.

Can anyone help me?

cmarkle_aspera
04-02-2009, 10:24 AM
Chris Markle here from Aspera... There is a way to tell the client not to mess with proxies that sometimes helps in situations like this. What you can try is to add an empty folder named "noproxy" to c:\Program Files\Aspera\DigiDelivery (so you'd send up with folder: c:\Program Files\Aspera\DigiDelivery\noproxy). See if that helps...

Chris

cmarkle_aspera
04-02-2009, 10:47 AM
[...] What you can try is to add an empty folder named "noproxy" to c:\Program Files\Aspera\DigiDelivery (so you'd send up with folder: c:\Program Files\Aspera\DigiDelivery\noproxy). See if that helps...Chris

I tested this by setting a dummy machine as a proxy in the Internet Explorer options, that mahcine being 10.0.0.1. I turned on DD client trace logging and see the following when the client starts:

xxx, Debug, DD_Prefs.cpp DD_Prefs::UpdateProxySettings 678
Using HTTP Proxy: http://10.0.0.1:8080
xxx, User, DD_AppUtils.cpp DD_ParseCommandLine 377
-- blank line --
xxx, Debug, DgD_TxnHandler.cpp DgD_TxnHandler::OnPreDispatch 67
/servercomm2 executing Msg_FireCheckForUpdates
[...]

And the client didn;t work becasue 10.0.0.1 was not a proxy.

Then I added the noproxy empty directory as I described in the earlier post and then the trace showed this

04/02/2009, 10:36:32.031, User, DD_AppUtils.cpp DD_ParseCommandLine 377
-- blank line --
04/02/2009, 10:36:32.031, Debug, DgD_TxnHandler.cpp DgD_TxnHandler::OnPreDispatch 67
/servercomm2 executing Msg_FireCheckForUpdates
[...]

And the client worked even though IE was configured to use a proxy.

To turn on client logging, you can either:

1) reinstall the client or "change" it via Control Panel - Add/Remove Programs and check the installer checkbox to enable logging; or

2) Add the folder called "Logs" (note uppercase "L") to C:\Program Files\DigiDelivery resulting in the folder C:\Program Files\DigiDelivery\Logs.

If you do this then each time you start the DD cleint a log file called lognnn.txt will be created there.

Chris