PDA

View Full Version : Digi 002 Standalone mode problem with digital sync


UK RAF
10-14-2005, 01:59 AM
I have discovered what I can only imagine is a bug in the Digi 002's firmware, and have tried to find any information on this using google and the search feature on these forums, but cannot find anything out there. Maybe someone else who has a Digi 002 can verify that this is happening to them too?

My hardware:
Shuttle XPC (Like the Music XPC) running Windows XP Home (Picture of Computer (http://img406.imageshack.us/img406/753/finalshuttle3ev.jpg)).
Digi 002 (connected with Firewire and with optical spdif between the computer's optical output and the Digi 002's optical input)
Active loudspeakers

The situation:
When not using Pro Tools I like to use the Digi 002 and its active monitors to listen to iTunes (for WinXP), game audio and other computer-audio.
Because the "wave" drivers for windows do not work properly, I have hit upon the idea to use the 002 in stand-alone mode, receiving audio from the computer via optical spdif and replaying over the monitors.

This works fine, but there is a bug...
Once everything is configured on the 002 (go into standalone mode, change channel 5-6 to spdif, select optical spdif, select spdif as wordclock source, fade up channels 5-6) I have saved a snapshot that always loads with everything set-up. This snapshot always loads when I enter standalone mode. I am aware though, that the wordclock settings are saved with the "preferences" rather than the "snapshot".

Here is the bug:
I have set-up everything as above, I exit standby mode and power-down the 002. When I next power-on the mixer the previous snapshot loads but the sound is aliased and sounds terrible. When I check the wordclock source (in "Utility" - "Pref" - "Wrdclk") it still says "SPDIF", but it clearly is not set to sync from the external source. All I need to do is cycle through the options to "Internal" then back to "SPDIF" and suddenly it syncs properly and everything sounds better again.

I have tried this multiple times and using different startup orders etc, and come back to the same conclusion: that there is a bug in the Digi 002 firmware that stops it from switching properly to external sync on startup even though the spdif option is saved in the preferences.

Is there someone with a 002 that can verify the above, or someone from Digidesign who can confirm that this is a bug (and let us know if it can be fixed)?
I would be very disappointed if I had to reselect spdif word clock everytime I powered the box on.

On a side-note in stand-alone mode whether the 002 is in the bugged state of having SPDIF set but still clocking internally, or whether it is locked to the optical spdif signal, the "48" sample rate button blinks (which indicates a sync error). Using this same optical signal connected to the 002, but running Pro Tools, Pro Tools locks up (at 48kHz) to the optical spdif with no complaints (and a steady "48" light). Therefore there could be another bug in the way the standalone part of the 002 deals with digital sync. It does seem to lockup ok though in standalone mode once you re-select optical SPDIF, even though the "48" light is blinking.

PS: There is no natural place for this post as it is a "STANDALONE" issue with the Digi 002, not a Windows or Mac specific problem, and not really a "host tip" or "host technique". I will post it here, and maybe put pointers in the mac and pc ones.

Any help or confirmation of this bug is eagerly anticipated. Word from Digi that you can fix this is even more eagerly anticipated...

Ducky
10-14-2005, 09:40 AM
This would be worth a few minutes on the phone with customer service.
I have an OO2 but never use it in this way.

UK RAF
10-14-2005, 10:24 AM
I took your advice, but after about 25 minutes on hold I am losing the will to live.
I need either or both of the following:
1) Other 002 users to check out these steps to see if it is a problem with the firmware on all 002s
2) Digi support to confirm that this is or isnt a problem, and how to fix it, or if they are going to fix it (and when)

still holding...

UK RAF
10-14-2005, 01:20 PM
Submitted bug report. It would really help if others could report that they can replicate this bug - does anyone else use a Digi 002 in Standalone mode?

Ducky
10-14-2005, 03:14 PM
Sorry RAF... I would but I don't like messin' with things that work the way I need them to.
I've had nothing but problems with syncing equipment (outboards) consistently. When the power comes up, it's like everyone is talking at once and then utter silence when everything goes to their own room (reverts back to their own clocks).

albee1952
10-14-2005, 06:43 PM
AFAIK, the stand-alone setup is only designed to be 8 in and all analog. I am surprised that the spdif works at all. Check the manual on stand alone mode to see if spdif is even mentioned.

UK RAF
10-15-2005, 02:57 AM
AFAIK, the stand-alone setup is only designed to be 8 in and all analog. I am surprised that the spdif works at all. Check the manual on stand alone mode to see if spdif is even mentioned.



Hi albee1952, thanks for the reply.
Yeah, I RTFM - thats how I got it set-up. Digital i/o works, SPDIF either coax or optical works, Optical can be switched from SPDIF to ADAT... Its all there, there is just a bug in the firmware (on power-up, external sync is not switched in correctly), it would be great if anyone else could try to replicate this with their own 002.

Thanks in advance!

UK RAF
10-15-2005, 03:04 AM
Sorry RAF... I would but I don't like messin' with things that work the way I need them to.
I've had nothing but problems with syncing equipment (outboards) consistently. When the power comes up, it's like everyone is talking at once and then utter silence when everything goes to their own room (reverts back to their own clocks).



Hi Ducky,
Are you saying that you also have problems with syncing digital equipment and the 002 in standalone mode? This is useful feedback, thank you.
Even if you have not taken the time to find the cause of the problems, it is valuable to know that others are also having digital sync problems.
I think that this is something we need to document here as Digidesign is obviously unaware of the problem (or if they are aware of it, they will be less inclined to fix it if no-one out here is complaining about it!)
I also think I know enough about the way that the 002 syncs to be able to help you to get all of your equipment working properly (maybe using the work-around for the bug I discussed earlier), so if you post your setup and how you would like it to be connected, maybe I can suggest something. I have a nagging suspicion that there is a deeper problem with digital sync in standalone mode (because of the blinking "48" light), but maybe if we can get through your issues we will know more about what needs to be fixed in the 002.

bb_aus
10-15-2005, 08:43 PM
have you tried spdif on coax?
what software you you using and sound card are you using? i find some weird things going on if the output it not at 44.1, which seems to be in windows or the driver. most consumer cards have questionable outputs.
as long as i use a good program like winamp with a 44.1Khz file it plays fine

do you need the mixer or are you just using it to get computer sound? the simplesthing thing to do is just run analogue from your computer to the alt-in and with a simple push of a button you can monitor your computer sound

UK RAF
10-16-2005, 02:42 AM
have you tried spdif on coax?
what software you you using and sound card are you using? i find some weird things going on if the output it not at 44.1, which seems to be in windows or the driver. most consumer cards have questionable outputs.
as long as i use a good program like winamp with a 44.1Khz file it plays fine

do you need the mixer or are you just using it to get computer sound? the simplesthing thing to do is just run analogue from your computer to the alt-in and with a simple push of a button you can monitor your computer sound



Hi BB_Aus, thanks for the advice.
-No coax on my computer, so it is gonna have to work with optical (it should work on optical after all).
-Agreed that the soundcard (Realtek AC97) could be providing a questionable digital output... BUT the 002 in "pro tools" mode happily accepts this signal, locks to it and records it fine (The flashing "48" light is steady when in Pro Tools mode). Therefore there must either be a difference between how the Digi 002 handles digital signals in standalone mode and in pro tools mode (since it is the same signal), or there is a bug in the standalone mode (it will sync to this signal once I cycle through the wordclock options back to "optical"), or both of the above (I think there are problems with both).
-I just need it for the computer sound (when not running pro tools, obviously) not mixing - I want to take advantage of all the high quality audio gear. If you read Ducky's 2nd post, above, you will see that he also has digital sync problems that he has given up on. I think if we get to the bottom of this then the 002 will be better for people who need it as a mixer as well (because the sync issues would be stable and not bugged, like they currently are).
-My optical output appears to be 48kHz, even when playing CD (which I only did for testing purposes). I haven't used Winamp, but I do not believe that the application matters (I get the same 48kHz output from the computer whether I am running games, using iTunes or windows media player. I also get the same behaviour from the 002 when connecting a 48kHz digital radio via the optical connection). If everything is fine with 44.1kHz, maybe this is where the bug is (ie: syncs fine with 44.1kHz signal but not 48kHz). This is very useful feedback and may help the Digi engineers to find where this bug is.
-Good suggestion about the analog audio - it was one of the first things I tried and is quite clean, but cuts off when my headset/mic is plugged into the headphone/microphone ports. I appreciate the suggested work-around, but I actually want the optical input on the 002 to work without having to go into the options every time I switch the 002 on. Like I said - I have done pretty exhaustive testing and have discovered this bug which I am sure is at fault. I would really appreciate it if people with 002s could try and verify this (whether they try with optical or coaxial spdif!)

bb_aus
10-16-2005, 02:58 AM
My optical output appears to be 48kHz, even when playing CD


then it must be a software problem with some sort of SRC


If everything is fine with 44.1kHz, maybe this is where the bug is (ie: syncs fine with 44.1kHz signal but not 48kHz). This is very useful feedback and may help the Digi engineers to find where this bug is.


nope a proper 48KHz signal works fine for me, eg from a DVD player or from a guitar FX board with digital out (and the clock in that thing is questionable at best)

ive only ever used coax spdif as i use optical for ADAT, while they should work the same i would not be surprised if problems only relate to one. there was some bug in PT with coax/optical at one stage, i cant remember what it was as it didnt consern me.
i used to run my computer sound into spdif and every so often ill go to standalone mode so i can but in general its just not worth it. i find when clocked from the computer soundcard there isnt much difference in quality than just running to the alt-in and its much simplier than going into standalone mode. if you want better quality for listening to music use the wave driver

UK RAF
10-16-2005, 10:38 AM
nope a proper 48KHz signal works fine for me, eg from a DVD player or from a guitar FX board with digital out (and the clock in that thing is questionable at best)

ive only ever used coax spdif as i use optical for ADAT, while they should work the same i would not be surprised if problems only relate to one. there was some bug in PT with coax/optical at one stage, i cant remember what it was as it didnt consern me.
i used to run my computer sound into spdif and every so often ill go to standalone mode so i can but in general its just not worth it. i find when clocked from the computer soundcard there isnt much difference in quality than just running to the alt-in and its much simplier than going into standalone mode. if you want better quality for listening to music use the wave driver



maybe its a problem with optical vs. coaxial then... Like I said before, this signal should be "proper", as Pro Tools does not complain at all when syncing up with it, and the sync problems go away once I cycle through the word clock options back to "spdif", it just means doing this after every power-on of the 002. It would be cool if you have time to test this using coaxial, but only if you have time. I have tried a couple of times to get the wavedriver working, and it always bugs out, I'll try one more time if you are saying that it works properly. Analogue in is not really an option for me because I already have a headset connected to the computer, and the digital works with the workaround.

EDIT: Update: Wave drivers work for iTunes, but not for games (well, the one game I tried: Starcraft ). If I'm gonna use it, its got to work for everything. Maybe analog i/o is the easiest, but I am determined to get to the bottom of this optical 48kHz SPDIF sync problem. Has ANYONE tried to replicate this problem yet?

bb_aus
10-18-2005, 02:19 AM
Update: Wave drivers work for iTunes, but not for games (well, the one game I tried: Starcraft ). If I'm gonna use it, its got to work for everything. Maybe analog i/o is the easiest, but I am determined to get to the bottom of this optical 48kHz SPDIF sync problem. Has ANYONE tried to replicate this problem yet?


i wouldnt expect games to run smoothly with the wave driver, have you got the MME helper?
ill try optical in when ive got time

UK RAF
10-18-2005, 02:49 AM
i wouldnt expect games to run smoothly with the wave driver, have you got the MME helper?
ill try optical in when ive got time



MME Helper did it! Seems very stable, just added "starcraft.exe" to the list, updated, and I now get sounds through the Digi002 with Starcraft, iTunes and the rest (albeit one at a time...)
This is a very good solution, many, many thanks!

By all means please double-check the optical 48kHz when you have time - it would be good to get confirmation of that bug so that Digi can work on a fix.

UK RAF
10-20-2005, 01:30 PM
MME Helper did it! Seems very stable, just added "starcraft.exe" to the list, updated, and I now get sounds through the Digi002 with Starcraft, iTunes and the rest (albeit one at a time...)
This is a very good solution, many, many thanks!
By all means please double-check the optical 48kHz when you have time - it would be good to get confirmation of that bug so that Digi can work on a fix.



It seems I spoke too soon. Although fine with itunes (so far), the wavedriver with MME Helper is VERY flaky with games unfortunately. Although it works to start with, sooner or later it starts bugging out.
So its back to the dodgy optical spdif for me, although I might just admit defeat for now and use the analog cable until digi fixes this. ANY help replicating this bug is still very much appreciated (please see initial posts).